Jump to content

change dimension ID 1.6.4

Recommended Posts

I try to make a modpack for myself with Divine RPG and other mods with new dimensions. Divine RPG's dimensions use IDs up to 10, and other mods like The Ether may use already taken IDs. I resolved problem with IDs of items/blocks with idfix mod, but it doesn't help with dimensions. I looked for fixes for dimensions but couldn't find anything for 1.6.4

For example, The Ether doesn't have a config file. Also there is no dimensions in Divine RPG's config.

I don't know much about java coding. I tried to decompile jar to a package, change file, then convert it to jar in Eclipse, but it didn't work. Also i tried to change class in zip file and convert it online to a jar file, but minecraft didn't see my jar files or changed zip file.

here's fragment of a crash report(starting minecraft with original Divine RPG and The Ether files):

java.lang.IllegalArgumentException: Failed to register dimension for id 4, One is already registered
    at net.minecraftforge.common.DimensionManager.registerDimension(DimensionManager.java:127)
    at ether.client.mod_olympian.load(mod_olympian.java:446)

I can't find any useful topics on forums about it (most topics suggest change "I:dimensionID=x" in configs, but again these mods don't have it), please help if you know what to do


UPD. sorry if its a wrong forum cant delete post anyway

Edited by radiant
Link to comment
Share on other sites

This topic is now closed to further replies.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.