Jump to content

[SOLVED] JSON File Error Missing Required Property 'values' When Adding a Structure Forge 1.18.2


Jellofish83

Recommended Posts

So I was trying to make a custom structure with Forge 1.18.2, the reference I used was TelepathicGrunt's structure tutorial for Forge 1.18.2. The JSON files seems fine since I just modified the name to my structure's name, all the file's path are also the same. But when I open my JSON file, there's an warning showing "Missing required property 'values' ." The quick fix option implemented this at the bottom of my file:

"values": [
    
  ]

But I don't know what to put in there. This warning occured at src/main/resources/data/fariouscraft/worldgen/configured_structure_feature/shabby_tent.json

Same warning also occured at src/main/resources/data/fariouscraft/worldgen/structure_set/shabby_tent.json

At first I ignored the warning, but when I launched into game and tried generate a new world, it tells me there was an error in the datapack loaded and I must use safe mode. But the button won't respond to do anything when I press safe mode.

Here's the JSON files

src/main/resources/data/fariouscraft/worldgen/configured_structure_feature/shabby_tent.json

{
  "type": "minecraft:village",

  "config": {
    "start_pool": "fariouscraft:shabby_tent/start_pool",

    "size": 2
  },

  "biomes": "#fariouscraft:has_structure/shabby_tent",

  "adapt_noise": true
}

src/main/resources/data/fariouscraft/worldgen/structure_set/shabby_tent.json

{
  "structures": [
    {
      "structure": "fariouscraft:shabby_tent",
      "weight": 1
    }
  ],
  "placement": {
    "salt": 1464187780,

    "spacing": 12,

    "separation": 8,

    "type": "minecraft:random_spread"
  }
}

The start_pool.json and the files within the template_pool directory is fine. But the console throw me an error:

Caused by: com.google.gson.JsonParseException: Error loading registry data: Failed to parse fariouscraft:worldgen/configured_structure_feature/shabby_tent.json file: com.google.gson.stream.MalformedJsonException: Expected name at line 23 column 2 path $.adapt_noise

I basically just copy and pasted TelepathicGrunt's files and even added them in the game, his works just fine, but mine won't work for some reason.

Any help would be appreciated, thanks :) 

 

Edit: I just added the mob spawning control code to the JSON file after adapt_noise, then debugged the program. After debugging, the error just magically disappeared when I ran the program again even though I have already tried that before debugging.

Edited by Jellofish83
Problem Solved
Link to comment
Share on other sites

  • Jellofish83 changed the title to [SOLVED] JSON File Error Missing Required Property 'values' When Adding a Structure Forge 1.18.2

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • !warudo.isClientSide() still not a gui not an error just a simple message [06:44:39] [Render thread/WARN] [minecraft/MenuScreens]: Failed to create screen for menu type: mercmod:gem_polishing_menu Not a hint of what the problem is  this silent simple error dont tell much about the problem the code i made don't show errors highlighted   in mi old code 1.19.4 i launch the menu part from client side  but now i recheck the video and kapenjoe does it server side         
    • Hey, for getting your model to show up in Forge, double-check the way you've set up your model registration. Sometimes, it's just a tiny mix-up with where you've put your model file or maybe missing the right event to hook it up. Also, peek at your @Mod.EventBusSubscriber setup; it's gotta be listening in the right place. And don't forget to place your model file in the exact right spot with the correct naming. If in doubt, the Forge docs or forum threads can be super helpful.
    • Since flying mobs like bees and flies aren't affected, the problem likely lies with how ground mob AI interacts with the server environment. Checking the server logs, as you've done, is a good step. You might want to look for errors related to mob AI or pathfinding. Consider removing or updating mods one at a time to isolate the issue. Additionally, ensure your server's performance isn't being overly taxed by the modpack, as this can sometimes lead to unusual behavior with entity AI.
    • I'm having the same issue rn. Hostile mobs wont move until attacked but peaceful land mobs wont move at all. If it swims or flies its unaffected until it touches blocks.
    • Im trying to register model for my item but it doesn't works. First I Created a class where i declared all my items.   public class ModItems { public static final List<Item> ITEMS = new ArrayList<Item>(); public static final Item MY_ITEM = new MyItemClass(); } Then I created the MyItemClass where i describe my item. public class MyItemClass extends Item { public MyItemClass() { this.setRegistryName("my_item"); this.setUnlocalizedName("my_item"); this.setCreativeTab(CreativeTabs.COMBAT); ModItems.ITEMS.add(this); } } And The i created a class where i was trying register the model and where i registered my item @Mod.EventBusSubscriber public class EventsHandler { @SubscribeEvent public void registerItems(RegistryEvent.Register<Item> event) { event.getRegistry().register(new MyItemClass()); } @SubscribeEvent @SideOnly(Side.CLIENT) public static void onRegistryModel(ModelRegistryEvent event) { registryModel(new MyItemClass()); } @SideOnly(Side.CLIENT) private static void registryModel(Item item) { final ResourceLocation regName = item.getRegistryName(); final ModelResourceLocation mr1 = new ModelResourceLocation(regName, "inventory"); ModelBakery.registerItemVariants(item, mr1); ModelLoader.setCustomModelResourceLocation(item, 0, mr1); } } The registerItems method just registers my items. Then im catching ModelRegistryEvent to register my model. And in the last private method im registering models. In The game iitem still has purple-black cube instead of texture. I dont forgot to create the models\item folder and my_item.json file im sorry if this text has a grammatical errors. My english is very low  
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.