Jump to content

(SOLVED)[1.20.2] Incorrect/"default" values for instance-specific fields in custom entity in some overridden methods


Sixela963

Recommended Posts

Hey folks.

I am working on a custom "Mecha" entity (extended from LivingEntity) that the player builds up from blocks that should get modular stats depending on the used blocks.

e.g. depending on what will be used for the legs, the entity will have a different jump strength.

However, something unexpected is happening when trying to override a few of LivingEntity's functions and using my new own "Mecha" specific fields: instead of their actual instance-specific value, the default value is used (0f for a float, null for an object...)

This is especially strange as when executing with the same entity from a point in the code specific to the mecha entity, the correct value is used.

Here are some code snippets to better illustrate what I mean:


/*
The main Mecha class, cut down for brevity
 */
public class Mecha extends LivingEntity {
  	protected float jumpMultiplier;
	//somewhere later during the code when spawning the entity, jumpMultiplier is set to something like 1.5f
	//changing the access to public didn't help


    @Override //Overridden from LivingEntity, this function is only used in the jumpFromGround() function, used in the aiStep() function, used in the LivingEntity tick() function
    protected float getJumpPower() {
        //something is wrong with this function
        //for some reason I can't correctly access the fields and methods from the instanciated entity when I am in one of those overridden protected functions. this is very annoying
        LogUtils.getLogger().info(String.valueOf(this.jumpMultiplier))) //will print 0f
        return this.jumpMultiplier * super.getJumpPower();
    }
	//The code above does not operate properly. Written as is, the entity will not jump, and adding debug logs shows that when executing the code, the value of this.jumpMultiplier is 0f

	//in contrast, it will be the correct value when done here:
    @Override
    public void tick() {
        super.tick(); //inherited LivingEntity logic
      	
      	//Custom logic
        LogUtils.getLogger().info(String.valueOf(this.jumpMultiplier))) //will print 1.5f
    }
}

My actual code is slightly different, as the jumpMuliplier is stored in another object (so I am calling "this.legModule.getJumpPower()" instead of the float), but even using a simple float exactly like in the code above didn't help.

When running my usual code, the object I try to use is found to be null instead, leading to a crash from a nullPointerException. Here is the stacktrace of said crash:

Quote

at fr.sixela.mechawalkers.entity.Mecha.getJumpPower(Mecha.java:159) ~[%23194!/:?] {re:classloading}
    at net.minecraft.world.entity.LivingEntity.jumpFromGround(LivingEntity.java:2153) ~[forge-1.20.2-48.1.0_mapped_parchment_2023.10.08-1.20.2-recomp.jar%23188!/:?] {re:classloading}
    at net.minecraft.world.entity.LivingEntity.aiStep(LivingEntity.java:2744) ~[forge-1.20.2-48.1.0_mapped_parchment_2023.10.08-1.20.2-recomp.jar%23188!/:?] {re:classloading}
    at net.minecraft.world.entity.LivingEntity.tick(LivingEntity.java:2472) ~[forge-1.20.2-48.1.0_mapped_parchment_2023.10.08-1.20.2-recomp.jar%23188!/:?] {re:classloading}
    at fr.sixela.mechawalkers.entity.Mecha.tick(Mecha.java:218) ~[%23194!/:?] {re:classloading}
Caused by: java.lang.NullPointerException: Cannot invoke "fr.sixela.mechawalkers.mechModule.leg.LegAbstractModule.getJumpPower()" because "this.legModule" is null

    at net.minecraft.client.multiplayer.ClientLevel.tickNonPassenger(ClientLevel.java:280) ~[forge-1.20.2-48.1.0_mapped_parchment_2023.10.08-1.20.2-recomp.jar%23188!/:?] {re:classloading,pl:runtimedistcleaner:A}
    at net.minecraft.world.level.Level.guardEntityTick(Level.java:522) ~[forge-1.20.2-48.1.0_mapped_parchment_2023.10.08-1.20.2-recomp.jar%23188!/:?] {re:classloading,pl:accesstransformer:B}
    at net.minecraft.client.multiplayer.ClientLevel.lambda$tickEntities$4(ClientLevel.java:262) ~[forge-1.20.2-48.1.0_mapped_parchment_2023.10.08-1.20.2-recomp.jar%23188!/:?] {re:classloading,pl:runtimedistcleaner:A}
    at net.minecraft.world.level.entity.EntityTickList.forEach(EntityTickList.java:53) ~[forge-1.20.2-48.1.0_mapped_parchment_2023.10.08-1.20.2-recomp.jar%23188!/:?] {re:classloading}
    at net.minecraft.client.multiplayer.ClientLevel.tickEntities(ClientLevel.java:260) ~[forge-1.20.2-48.1.0_mapped_parchment_2023.10.08-1.20.2-recomp.jar%23188!/:?] {re:classloading,pl:runtimedistcleaner:A}

The full code can be viewed here.

I have found a workaround in the case of jump strength, but have already found the same problem for another parameter I want to do, and I do not understand why the code is behaving as such, and I would very much like to be able to override those methods as intended - they seemed to work just fine like that for vanilla mobs...

Any clues as to what may be happening here?

Edited by Sixela963
marked the problem as solved
Link to comment
Share on other sites

So, it turns out I mostly needed a good night's sleep... I also ommited some details from my explaination that would have been necessary to understand the problem because I thought they were not relevant.

I found the reason for the wrong values, and I am now working on a fix. Long story short, it's the client/server sides again.

The code that modified the entity specific fields was only happening on the server, and I hadn't implemented proper entity syncing. I have now started working on that. The parts of the code that worked properly were executed only on the server, and the parts that didn't work were executed only on the client (getJumpPower() was client only because the Mecha entity is a ridden entity). When I modified the code in tick() to run on client, it showed the same problem as earlier.

Marking the problem as fixed.

Link to comment
Share on other sites

  • Sixela963 changed the title to (SOLVED)[1.20.2] Incorrect/"default" values for instance-specific fields in custom entity in some overridden methods

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.