Jump to content

{Solved} [1.6.4]Help! NoSuchField Error: dyePowder


adam567890

Recommended Posts

Hey, I am working on a mod for a private server  that adds a recipe to craft coal into black dye, and I just cant seem to run it outside of eclipse. Here is the link to my code: https://gist.github.com/anonymous/8228598

 

I would love any help possible as to why whenever I export it from eclipse as a jar (not runnable, only including my mod classes) that I get a no such field error for the item dyePowder. I have tried deobfuscating, but that seems to only output the class files themselves and I want to be able to distribute a jar with my mod in it.

 

Thanks!

 

 

By the way, The version I am trying to mod is MC 1.6.4 with forge 9.11.1.965 src version.

 

****

It Turns out that I needed to be more precise with my placement of the class files in the zip.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.