Jump to content

[1.7.2]Updating my mod from 1.6 to 1.7- multiple issues


tatsu011

Recommended Posts

Upon updating my mod from 1.6 to 1.7, I found and fixed most of the errors within the code.  However, there are four bugs which I do not have a solution for:

 

TileEntityBoiler:

NBT data does not seem to save properly myself, and another coder looked at it and could not find an issue. 

 

All custom item icons:

None of the items that I have made render their icons properly.

 

EDIT: this now just applies to items, no longer blocks.

 

All custom items:

Whenever I leave the world with custom items in the player's inventory and log out, the client hiccups when logging back in and the player inventory becomes corrupt.  I have no idea why.

 

here is the forge log

http://pastebin.com/SpTp4kJq

 

Dropbox link to source:

https://dl.dropboxusercontent.com/u/21554636/ThermalDynamics_src.zip

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I'm Murray Brenda by name, a single mom of three kid's, got scammed on forex trade, never taught of getting tricked in such a way, was convinced by a social media friend to invest on the forex platform of which i heed to, after 1 week of thinking about the proposal, i invested $5Gs, then the trade increased and i was asked to deposit so i stay on the trade and avoid running loss and i did, it was so hurtful when i realize that i have been scammed, i reached out to the directors and support service, non where responding, i was always asked for more payment after one payment has been made, after having my funds back with the help of AlienWizbot i was so happy and rejoiceful simply because it was at the edge of giving up, i gave the last trial simply because coming from a reliable source i taught of giving it  try, only then did i came to find out the truth about impostors testimony online which has ended many people losing more money to scam, you can reach out to Alienwizbot by sms (+1 6262645164) or E-mail alienwizbot(@)Gmail(.)com, best service ever experienced, do hire him for all kinds of cyber issues or hacks.  
    • so basically ive been trying to make a modded server for 1.7.10 and i follow the tutorial perfectly but every tutorial has something called a bat file in there folder when they install forge client into a folder but it doesn't show for me i only get these options in the folder config, libraries, logs, mods, eula, forge 1.7.10, minecraft server 1.7.10 and server proprieties so im not sure what to do and google hasn't really been helping
    • { "type": "magic_overhaul:rune_inscribing", "base": { "item": "//base item" }, "template": { "item": "//template item" }, "output": { "count": 1, "item": "//output item" } } ^ Ok, where is your recipe JSON placed in your file structure? What's it called? And paste the actual JSON you're testing with, because it needs to be valid.
    • I'm trying to run Forge 1.12.2 on Minecraft  so I can use certain mods, but this error popped up. I've seen multiple errors but I just can't figure this one out. Unable to locate the Java runtime. Error details: 0x00000000 - system: The operation completed successfully. Filename on disk:  Path: . Exists: Directory
    • https://mclo.gs/b422RFc
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.