Jump to content

Can't find Source in Eclipse?


SureenInk

Recommended Posts

So, I've followed about 4 different tutorials, one of which got me to be able to load eclipse up finally without a problem. However, when I go to read the source code for Minecraft Forge, I get an error that says "The JAR file C:\Users\Sureen\.gradle\caches\minecraft\net\minecraftforge\forge\1.7.2-10.1.0.1024\forgeBin-1.7.2-10.12.0.1024.jar has no source attachment." Then it tells me to attach a source. I don't understand what's wrong?

 

Here's my last forge log (I think this is the forge log? It was the only log I could find)

 

 

[15:24:36] [main/INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLTweaker

[15:24:36] [main/INFO]: Using primary tweak class name cpw.mods.fml.common.launcher.FMLTweaker

[15:24:36] [main/INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLTweaker

[15:24:36] [main/INFO]: Forge Mod Loader version 7.2.116.1024 for Minecraft 1.7.2 loading

[15:24:36] [main/INFO]: Java is Java HotSpot 64-Bit Server VM, version 1.7.0_51, running on Windows 7:amd64:6.1, installed at C:\Program Files\Java\jre7

[15:24:36] [main/INFO]: Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation

[15:24:36] [main/INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker

[15:24:36] [main/INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker

[15:24:36] [main/INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker

[15:24:36] [main/INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker

[15:24:36] [main/INFO]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper

[15:24:36] [main/ERROR]: The binary patch set is missing. Either you are in a development environment, or things are not going to work!

[15:24:37] [main/ERROR]: The minecraft jar file:/C:/Users/Sureen%20Ink/.gradle/caches/minecraft/net/minecraftforge/forge/1.7.2-10.12.0.1024/forgeBin-1.7.2-10.12.0.1024.jar!/net/minecraft/client/ClientBrandRetriever.class appears to be corrupt! There has been CRITICAL TAMPERING WITH MINECRAFT, it is highly unlikely minecraft will work! STOP NOW, get a clean copy and try again!

[15:24:37] [main/ERROR]: FML has been ordered to ignore the invalid or missing minecraft certificate. This is very likely to cause a problem!

[15:24:37] [main/ERROR]: Technical information: ClientBrandRetriever was at jar:file:/C:/Users/Sureen%20Ink/.gradle/caches/minecraft/net/minecraftforge/forge/1.7.2-10.12.0.1024/forgeBin-1.7.2-10.12.0.1024.jar!/net/minecraft/client/ClientBrandRetriever.class, there were 0 certificates for it

[15:24:37] [main/ERROR]: FML appears to be missing any signature data. This is not a good thing

[15:24:37] [main/INFO]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper

[15:24:37] [main/INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLDeobfTweaker

[15:24:37] [main/INFO]: Launching wrapped minecraft {net.minecraft.client.main.Main}

[15:24:38] [main/INFO]: Setting user: Player972

[15:24:38] [Client thread/INFO]: LWJGL Version: 2.9.0

[15:24:39] [Client thread/INFO]: Attempting early MinecraftForge initialization

[15:24:39] [Client thread/INFO]: MinecraftForge v10.12.0.1024 Initialized

[15:24:39] [Client thread/INFO]: Replaced 128 ore recipies

[15:24:39] [Client thread/INFO]: Completed early MinecraftForge initialization

[15:24:39] [Client thread/INFO]: Searching C:\Users\Sureen Ink\Desktop\Minecraft Mods\forge 172\eclipse\mods for mods

[15:24:39] [Client thread/INFO]: Mod Radial is missing the required element 'name'. Substituting Radial

[15:24:39] [Client thread/ERROR]: FML has detected a mod that is using a package name based on 'net.minecraft.src' : net.minecraft.src.FMLRenderAccessLibrary. This is generally a severe programming error.  There should be no mod code in the minecraft namespace. MOVE YOUR MOD! If you're in eclipse, select your source code and 'refactor' it into a new package. Go on. DO IT NOW!

[15:24:39] [Client thread/ERROR]: FML has detected a mod that is using a package name based on 'net.minecraft.src' : net.minecraft.src.Start. This is generally a severe programming error.  There should be no mod code in the minecraft namespace. MOVE YOUR MOD! If you're in eclipse, select your source code and 'refactor' it into a new package. Go on. DO IT NOW!

[15:24:40] [Client thread/INFO]: Forge Mod Loader has identified 5 mods to load

[15:24:40] [Client thread/INFO]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:Example Mod, FMLFileResourcePack:Radial

[15:24:40] [Client thread/INFO]: Configured a dormant chunk cache size of 0

[15:24:41] [Client thread/INFO]: Created: 512x256 textures/blocks-atlas

[15:24:41] [sound Library Loader/INFO]: Sound engine started

[15:24:41] [Client thread/INFO]: Created: 256x256 textures/items-atlas

[15:24:41] [Client thread/INFO]: Forge Mod Loader has successfully loaded 5 mods

[15:24:41] [MCO Availability Checker #1/ERROR]: Couldn't connect to Realms

[15:24:49] [server thread/INFO]: Starting integrated minecraft server version 1.7.2

[15:24:49] [server thread/INFO]: Generating keypair

[15:24:49] [server thread/INFO]: Injecting new block and item data into this server instance

[15:24:49] [server thread/INFO]: Loading dimension 0 (Test) (net.minecraft.server.integrated.IntegratedServer@75491ada)

[15:24:49] [server thread/INFO]: Loading dimension 1 (Test) (net.minecraft.server.integrated.IntegratedServer@75491ada)

[15:24:49] [server thread/INFO]: Loading dimension -1 (Test) (net.minecraft.server.integrated.IntegratedServer@75491ada)

[15:24:49] [server thread/INFO]: Preparing start region for level 0

[15:24:50] [Netty Client IO #0/INFO]: Server protocol version 1

[15:24:50] [Netty IO #1/INFO]: Client protocol version 1

[15:24:50] [Netty IO #1/INFO]: Client attempting to join with 5 mods : [email protected],[email protected],[email protected],[email protected],Radial@Alpha v1

[15:24:50] [Netty IO #1/INFO]: Attempting connection with missing mods [] at CLIENT

[15:24:50] [Netty Client IO #0/INFO]: Attempting connection with missing mods [] at SERVER

[15:24:50] [server thread/INFO]: [server thread] Server side modded connection established

[15:24:50] [server thread/INFO]: Player972[local:E:0d1bac19] logged in with entity id 268 at (-713.0967568092921, 72.0, -332.9515234645175)

[15:24:50] [server thread/INFO]: Player972 joined the game

[15:24:50] [Client thread/INFO]: [Client thread] Client side modded connection established

[15:24:56] [server thread/INFO]: Saving and pausing game...

[15:24:56] [server thread/INFO]: Saving chunks for level 'Test'/Overworld

[15:24:56] [server thread/INFO]: Saving chunks for level 'Test'/Nether

[15:24:56] [server thread/INFO]: Saving chunks for level 'Test'/The End

[15:25:03] [server thread/INFO]: Stopping server

[15:25:03] [server thread/INFO]: Saving players

[15:25:03] [server thread/INFO]: Saving worlds

[15:25:03] [server thread/INFO]: Saving chunks for level 'Test'/Overworld

[15:25:03] [server thread/INFO]: Saving chunks for level 'Test'/Nether

[15:25:03] [server thread/INFO]: Saving chunks for level 'Test'/The End

[15:25:03] [server thread/INFO]: Unloading dimension 0

[15:25:03] [server thread/INFO]: Unloading dimension -1

[15:25:03] [server thread/INFO]: Unloading dimension 1

[15:25:04] [Client thread/INFO]: Stopping!

 

 

 

Here's what was in the "gradle.txt" file...I can't find any other logs, though... This is from when I ran setupDecompWorkspace just now

 

 

****************************

Powered By MCP:           

http://mcp.ocean-labs.de/ 

Searge, ProfMobius, Fesh0r,

R4wk, ZeuX, IngisKahn     

MCP Data version : unknown

****************************

:extractUserDev

:getAssetsIndex

:getAssets

:copyAssets

:extractNatives

:genSrgs UP-TO-DATE

:downloadMcpTools UP-TO-DATE

:downloadClient SKIPPED

:downloadServer SKIPPED

:mergeJars SKIPPED

:deobfuscateJar

Applying SpecialSource...

Applying Exceptor...

Injecting source info...

:decompile

:doFmlPatches

:addFmlSources

:remapJar

:doForgePatches

:addForgeJavadoc

:extractForgeSrc

:recompForgewarning: [options] bootstrap class path not set in conjunction with -source 1.6

Note: Some input files use or override a deprecated API.

Note: Recompile with -Xlint:deprecation for details.

Note: Some input files use unchecked or unsafe operations.

Note: Recompile with -Xlint:unchecked for details.

1 warning

 

:repackForge

:setupDecompWorkspace

 

BUILD SUCCESSFUL

 

Total time: 2 mins 1.017 secs

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • LINK DAFTAR : KLIK DISINI LINK DAFTAR : KLIK DISINI   Slot seabank meruapakan salah satu situs slot paling gacor deposit seabank 100% mudah maxwin, hari ini situs slot seabank meghadirkan permainan slot dengan kemudahan bergabung hanya dengan menggunakan aplikasi Seabank langsung bisa join dengan bandar slot Seabank terbaik dan terpercaya no.1 di indonesia. Slot Seabank resmi di daftar situs slot deposit pakai Seabank 5000 Gampang Maxwin dimana aplikasi Seabank tersebut telah sanggat membantu para bosku untuk bermain slot online deposit via Seabank saat ini slot Seabank ini membantu dalam mempermudah transaksi disaat bosku ingin deposit melakukan pembayaran. kini orang orang ingin bermian judi online khusus nya games slot tidak perlu khawatir lagi apabila tidak memilikui saldo di ATM, sebab dengan adanya aplikasi Seabank sudah memberikan dampak signifikan buat perjudian di indonesia. Selain slot pakai Seabank, terdapat beberapa aplikasi e-wallet yang dapat di gunakan untuk bertansaksi antara lain, slot deposit 5000 Seabank, slot dana, slot ovo, slot pulsa tanpa potongan, dan slot shopeepay mudah menang bisa bosku pakai untuk setoran Seabank resmi terbaru. intinya slot online deposit Seabank memberikan jamianan kemudahan saat main games slot gacor uang asli terbaik di indonesia bos.
    • LINK DAFTAR : KLIK DISINI LINK DAFTAR : KLIK DISINI   Slot deposit bank bsi merupakan salah satu situs slot gacor deposit bank bsi 24 jam mudah maxwin tanpa batas. hari ini slot deposit bank bsi menawarkan bonus terbesar untuk player yang sudah bergabung di situs slot bank bsi ini, dengan ada nya slot bank bsi sanget mempermudah player untuk melakukan transaksi deposit dengan bank bsi. Sebagai Situs Slot Deposit Bank Bsi meyediakan banyak permainan seperti slot online, live casino, sabung ayam, tembak ikan, sportbook semua game tersebuat sangat aman dan terpercaya. Beramin slot bank bsi sangat mudah hanya dengan niminal deposit 5000 ribu saja anda sudah bisa bermain di semua game yang sudah di sediakan oleh situs slot bank bsi. Slot bank bsi adalah saranan untuk Pemain yang mencari pengalaman bermain slot gacor sekarang dapat menemukan metode pembayaran beragam di berbagai situs slot gacor yang tersebar luas di seluruh negeri. Munculnya situs Slot Bank BSI, kini para pemain dapat menikmati kemudahan dan kenyamanan dalam melakukan transaksi pembayaran. Bahkan memungkinkan pemain untuk fokus sepenuhnya pada permainan yang mereka nikmati sepanjang waktu. Ini adalah langkah penting dalam memperluas aksesibilitas judi slot online di Indonesia dan memberikan pengalaman bermain yang lebih baik kepada para pecinta slot gacor.    
    • Sometimes love could be the worst experience. you get to love and trust your partner only to feel regret over it. i have been married for 7 years now and i found some sudden change in my partner attitude, i tried talking about it but he complains i'm nagging a lot . i tried to ignore his attitude but it became unbearable so i was advised to hire a hacker to help me gain access to his phone so i had know if he is cheating or not so i was introduced to [ Remote spy hacker @ g m ail . c o m ] and this expert helped me gain access to his phone without his notice. i got to see his messages, photos, call recordings and many more . Now i can see his cheating and that's the reason for the attitude all along.
    • hola thanks for answering  i set some system outs to test and see whats going on      @Override     protected void saveAdditional( CompoundTag nbt ){                  nbt.put("itemhandler", itemhandler.serializeNBT() );         nbt.putInt("progress", this.progress );         System.out.println("saveAdditional(nbt)");                 System.out.println(NbtUtils.prettyPrint(nbt)); //<-- this is whats getting saved         super.saveAdditional( nbt );     }     @Override     public void load( CompoundTag nbt ){         itemhandler.deserializeNBT( nbt.getCompound("itemhandler") );         this.progress = nbt.getInt("progress" );         System.out.println(NbtUtils.prettyPrint(nbt)); //<-- this is whats minecraft is giving back to the entity          System.out.println("load(nbt)");         super.load( nbt );     }   This dead adventurer body  has two parts a block and a block Item  both has their own item-handlers and their own menus all of that seems fine  Testing remarks : *when i change some element inside the gui  it triggers the saveAdditional(nbt) system out and shows a pretty print of the data being saved  *when the world map loads it triggers the load(nbt) system out and shows a pretty print of the data minecraft is giving to this Block Entity For the testing i gonna set mi BlockEntityBodyBlock, save something in it, close minecraft, fireup the game again and check if the items remain      ################ first try set the block entity (dead adventurer body like shaped) and left only a weath seed  in the slot 10 the console says its all right    close minecraft, launch it again i see the system out whit the data returned to the entity and its look good theres is only a weed seed  ################ Second try, now i gonna change the seed for two arrows  the console says its all right the two arrows are being saved    ######### Now close and run again bam Error  minecraft returns the original data whit only a wheat seed the two arrows has been loss   ########## try again now i gonna put 3 wheat seeds Console system out says it gets it and is saving the data   ############## but after close fire again  wheat seed,  data losed once more time  and it just throw the original   ####################################################################################### sorry for the long post and the crappy video  this is the reason why i say its saving the Block Entity data only when it feels like  coze its saves data when it feels like  ¿ its something wrong whit mi BlockEntity.saveAdditional()  if  i keep trying eventually it updates and the data chages      i alredy try to  level.removeBlockEntity(pos); level.setBlockEntity(pos, bebb);     BlockEntityBodyBlock.class   BlockEntityInit.class     body_blockitem.class                  
    • Yesterday I buy a minecraft server to play with my friends you know... One of my friends send me the list of mods to add and then i start to dowload them, when i add them to the server it start crashing but i don't know about this things because it's my first time buying a minecraft server This is the error: https://paste.ee/p/sJf7B
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.