Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

1.6.4 Random Severe Error + Crash


MtPete
 Share

Recommended Posts

After trying a modpack, ALL the different versions of Forge stopped working for me, and for all the modpacks, I got the same error. Here's one of them:

 

 

 

[2014-04-23 15:39:51] Logging into Minecraft!

[2014-04-23 15:39:52] Launching Minecraft with the following arguments (user related stuff has been removed): [C:\Program Files\Java\jre1.8.0_20\bin\javaw, -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump, -Xms256M, -Xmx1024M, -XX:PermSize=512M, -Dfml.ignorePatchDiscrepancies=true, -Dfml.ignoreInvalidMinecraftCertificates=true, -Dfml.log.level=INFO, -Djava.library.path=C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\natives, -cp, C:\Users\Matthew\Downloads\ATLauncher\ATLauncher.exe;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\jarmods\forge-1.6.4-9.11.1.965-universal.jar;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\launchwrapper-1.8.jar;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\asm-all-4.1.jar;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\scala-library-2.10.2.jar;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\scala-compiler-2.10.2.jar;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\lzma-0.0.1.jar;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\jopt-simple-4.5.jar;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\jopt-simple-4.5.jar;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\codecjorbis-20101023.jar;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\codecwav-20101023.jar;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\libraryjavasound-20101123.jar;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\librarylwjglopenal-20100824.jar;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\soundsystem-20120107.jar;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\argo-2.25_fixed.jar;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\bcprov-jdk15on-1.47.jar;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\guava-14.0.jar;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\commons-lang3-3.1.jar;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\commons-io-2.4.jar;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\jinput-2.0.5.jar;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\jutils-1.0.0.jar;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\gson-2.2.2.jar;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\lwjgl-2.9.0.jar;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\lwjgl_util-2.9.0.jar;C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness\bin\minecraft.jar, net.minecraft.launchwrapper.Launch, --username, REDACTED, --session, token:REDACTED:REDACTED, --version, 1.6.4, --gameDir, C:\Users\Matthew\Downloads\ATLauncher\Instances\FromTheDarkness, --assetsDir, C:\Users\Matthew\Downloads\ATLauncher\Configs\Resources\virtual\legacy, --width=854, --height=480, --tweakClass=cpw.mods.fml.common.launcher.FMLTweaker]

[2014-04-23 15:39:56] Apr 23, 2014 3:39:55 PM net.minecraft.launchwrapper.LogWrapper log

[2014-04-23 15:39:56] INFO: Loading tweak class name cpw.mods.fml.common.launcher.FMLTweaker

[2014-04-23 15:39:56] Apr 23, 2014 3:39:56 PM net.minecraft.launchwrapper.LogWrapper log

[2014-04-23 15:39:56] INFO: Using primary tweak class name cpw.mods.fml.common.launcher.FMLTweaker

[2014-04-23 15:39:56] Apr 23, 2014 3:39:56 PM net.minecraft.launchwrapper.LogWrapper log

[2014-04-23 15:39:56] INFO: Calling tweak class cpw.mods.fml.common.launcher.FMLTweaker

[2014-04-23 15:39:57] [iNFO] [ForgeModLoader] Forge Mod Loader version 6.4.49.965 for Minecraft 1.6.4 loading

[2014-04-23 15:39:57] [iNFO] [ForgeModLoader] Java is Java HotSpot Client VM, version 1.8.0_20-ea, running on Windows 7:x86:6.1, installed at C:\Program Files\Java\jre1.8.0_20

[2014-04-23 15:39:57] [WARNING] [ForgeModLoader] The coremod codechicken.core.launch.DepLoader does not have a MCVersion annotation, it may cause issues with this version of Minecraft

[2014-04-23 15:39:58] [WARNING] [ForgeModLoader] The coremod appeng.transformer.AppEngCore does not have a MCVersion annotation, it may cause issues with this version of Minecraft

[2014-04-23 15:39:58] [iNFO] [ForgeModLoader] [AppEng] Core Init

[2014-04-23 15:39:58] [WARNING] [ForgeModLoader] The coremod codechicken.core.launch.CodeChickenCorePlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft

[2014-04-23 15:40:03] [iNFO] [sTDERR] Warning: version of CodeChickenLib-universal-1.6.4-, 1.0.0.49 is newer than request 1.0.0.43

[2014-04-23 15:40:03] [WARNING] [ForgeModLoader] The coremod invtweaks.forge.asm.FMLPlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft

[2014-04-23 15:40:03] [WARNING] [ForgeModLoader] The coremod mcp.mobius.mobiuscore.asm.CoreDescription does not have a MCVersion annotation, it may cause issues with this version of Minecraft

[2014-04-23 15:40:03] [WARNING] [ForgeModLoader] The coremod codechicken.nei.asm.NEICorePlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft

[2014-04-23 15:40:03] [WARNING] [ForgeModLoader] The coremod tconstruct.preloader.TConstructLoaderContainer does not have a MCVersion annotation, it may cause issues with this version of Minecraft

[2014-04-23 15:40:04] [iNFO] [TCon-Preloader] Scalpel. Suction. Lumber axe. CLEAR! *zap*

[2014-04-23 15:40:04] [iNFO] [TCon-Preloader] Constructing preloader (Modules: [tconstruct.preloader.AccessTransformers, tconstruct.preloader.ASMInterfaceRepair])

[2014-04-23 15:40:04] [iNFO] [TCon-Preloader] Found a properties file. Attempting load...

[2014-04-23 15:40:04] [iNFO] [TCon-Preloader] Loaded properties successfully. Using specified settings.

[2014-04-23 15:40:04] [WARNING] [ForgeModLoader] The coremod com.chunkbase.mod.forge.mods.unglitch.UnglitchLoader does not have a MCVersion annotation, it may cause issues with this version of Minecraft

[2014-04-23 15:40:04] [iNFO] [ForgeModLoader] Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker

[2014-04-23 15:40:04] [iNFO] [ForgeModLoader] Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker

[2014-04-23 15:40:04] [iNFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker

[2014-04-23 15:40:04] [sEVERE] [ForgeModLoader] Unable to launch

[2014-04-23 15:40:04] java.util.ConcurrentModificationException

[2014-04-23 15:40:04] at java.util.ArrayList$Itr.checkForComodification(Unknown Source)

[2014-04-23 15:40:04] at java.util.ArrayList$Itr.remove(Unknown Source)

[2014-04-23 15:40:04] at net.minecraft.launchwrapper.Launch.launch(Launch.java:114)

[2014-04-23 15:40:04] at net.minecraft.launchwrapper.Launch.main(Launch.java:27)

[2014-04-23 15:40:04] Java HotSpot Client VM warning: ignoring option PermSize=512M; support was removed in 8.0

 

 

 

The same "[sEVERE] [ForgeModLoader] Unable to launch - java.util.ConcurrentModificationException" keeps happening now, ever since I used the From the Darkness modpack, and I still haven't been able to fix it D:

 

Someone please help, and thanks in advance

Link to comment
Share on other sites

Before I started using Java 8, when I used Java 7, I always got this error message:

 

Error: Could not create the Java Virtual Machine

Error: A fatal exception has occurred. Program will exit

 

And I could never fix that, even with the Xmx or Xms Java commands. The only other thing I could think to do is to find a way with Java 8, or use Java 6

Link to comment
Share on other sites

It turns out I was right. After 2 and a half hours of screwing around with oracle, trying to get Java 6, I finally got it. Java 6 worked, but not the first time, which is fine since it's not crashing the way it did the very first time. Thanks for the help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • So i just bought a RLcraft server for me and my friends to play on. I launched it and it is working fine but it tells me that i need to download all the mods i go to mods and press "minecraft forge" and nothing shows up that i can open files. If anyone have a suggestion i would need the help. This is the server hosting i  used 
    • i did it in 1.12.2 not walking for me can anyone help me get it pls???  
    • Got the rotation working. I had to look at LivingEntityRenderer#render and setupRotations a little more closely, and I realized that I needed to change the custom entity's yBodyRot and yBodyRotO.  private static boolean renderingCustomEntity = false; private static CustomEntity customEntity; private static void refreshCustomEntity(LocalPlayer localPlayer, LivingEntity livingEntity) { if (customEntity == null || customEntity.isRemoved()) { customEntity = ModEntities.CUSTOM_ENTITY.get().create(localPlayer.clientLevel); } if (!customEntity.level.dimension().equals(livingEntity.level.dimension())) { customEntity.discard(); } } @SubscribeEvent public static void replaceMobModel(RenderLivingEvent.Pre<LivingEntity, EntityModel<LivingEntity>> event) { LocalPlayer localPlayer = Minecraft.getInstance().player; if (localPlayer != null && event.getEntity() instanceof Mob mob) { if (/* put your own condition here */) { if (!renderingCustomEntity) { try { renderingCustomEntity = true; event.setCanceled(true); refreshCustomEntity(localPlayer, mob); // (truth be told, my custom entity does not have a "head", so these lines aren't needed) // customEntity.setYHeadRot(mob.getYHeadRot()); // customEntity.yHeadRotO = mob.yHeadRotO; customEntity.setYBodyRot(mob.yBodyRot); customEntity.yBodyRotO = mob.yBodyRotO; customEntity.setPose(mob.getPose()); Minecraft.getInstance().getEntityRenderDispatcher().getRenderer(customEntity).render( customEntity, customEntity.yBodyRot, event.getPartialTick(), event.getPoseStack(), event.getMultiBufferSource(), event.getPackedLight() ); } finally { renderingCustomEntity = false; } } } } }   As shown in my code, if the mob whose model is replaced moves to a different dimension, I unload the custom entity with Entity#discard and then reinitialize it on the next tick. I wonder if I also have to unload the custom entity when the mob it is "replacing" dies.
    • Thank you for the video, but I found the issue. I had to update the Gradle from 7.2 to 7.3 in gradle/wrapper/gradle-wrapper.properties.
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.