Jump to content

[1.7.2]World crashing when generating custom fluid in world


Taji34

Recommended Posts

So i'm generating my custom fluid in the world and have run into a problem. I decided to use minecraft's built in WorldGenLakes() and WorldGenLiquids() methods, however, they seem to be crashing for some reason. All I can figure out is it's either my fluid's properties, can anybody help me decipher what is happening?

 

Crash Report: https://gist.github.com/anonymous/383f9ffd293052295773

 

WorldGeneration.java: https://gist.github.com/anonymous/b56435b374d4946041e5

 

LiquidEnergyBlock.java: https://gist.github.com/anonymous/f3772330c063f04d0adc

 

Troncraft.java: https://gist.github.com/anonymous/2109c5c3750b906c7d99

 

When I comment out the lines in WorldGeneration.java that contains WorldGenLakes() everything works perfectly, so it has to be something with what I'm putting into that line right?

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.