Jump to content

Why am I spawning in the ground?


Recommended Posts

I think the ground in your dimension is lower than the ground in the overworld.

Maybe you can fix this by making the teleport coordinates above the y70 or a check that let players only spawn in air.

 

But I am not sure because I have never added a dimension.

Link to comment
Share on other sites

The Teleporter class has a method that places a player in a portal, placePlayerInExistingPortal(), I believe.

 

In that method, you can change where the player should spawn. I don't fully understand the Teleporter class, but I worked around it by storing the player's position as an extended property and returning the player to that position when he returns to the overworld. (Though setting up extended properties is a bit cumbersome is you don't already have something set up.)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.