Jump to content

Minecraft forge [1.6.4] SOURCE not downloading correctly


Recommended Posts

I have recently began modding with forge again, after some experience with modding with Risugami's Modloader. I knew how to set up directory, etc-but looked up a lot of videos just in case- I'm a little rusty.

I set up the source code for forge, then used the INSTALLER-- 'install.bat', if I remember correctly, to set up MCP. It looked good until it got to the bottom. Then, it said--

================ Forge ModLoader Setup Start ===================

Checking MCP zip (may take time to download)

Extracting MCP to 'C:\Users\Monkers\Desktop\forgeMod\forge\mcp'

Setting up MCP

Patching commands.py

patching file commands.py

    Commands patch applied successfully

Copying FML conf

Creating Repackaged data

    Creating re-packaged srg

    Creating re-packaged exc

    Creating re-packaged MCP patches

Fixing MCP Workspace

Downloading 42 libraries

    launchwrapper-1.8.jar Done

    asm-debug-all-4.1.jar Done

    asm-debug-all-4.1-sources.jar Done

    scala-library-2.10.2.jar Done

    scala-library-2.10.2-sources.jar Done

    scala-compiler-2.10.2.jar Done

    scala-compiler-2.10.2-sources.jar Done

    jopt-simple-4.5.jar Done

    jopt-simple-4.5-sources.jar Done

    lzma-0.0.1.jar Done

    codecjorbis-20101023.jar Done

    codecwav-20101023.jar Done

    libraryjavasound-20101123.jar Done

    librarylwjglopenal-20100824.jar Done

    soundsystem-20120107.jar Done

    lwjgl-2.9.0.jar Done

    lwjgl-2.9.0-sources.jar Done

    lwjgl_util-2.9.0.jar Done

    lwjgl_util-2.9.0-sources.jar Done

    argo-2.25_fixed.jar Done

    argo-2.25.jar Done

    argo-2.25-sources.jar Done

    bcprov-jdk15on-1.47.jar Done

    bcprov-jdk15on-1.47-sources.jar Done

    guava-14.0.jar Done

    guava-14.0-sources.jar Done

    commons-lang3-3.1.jar Done

    commons-lang3-3.1-sources.jar Done

    commons-io-2.4.jar Done

    commons-io-2.4-sources.jar Done

    jinput-2.0.5.jar Done

    jinput-2.0.5-sources.jar Done

    jutils-1.0.0.jar Done

    jutils-1.0.0-sources.jar Done

    gson-2.2.2.jar Done

    gson-2.2.2-sources.jar Done

    lwjgl-platform-2.9.0-natives-windows.jar Done

        Extracting OpenAL32.dll

        Extracting OpenAL64.dll

        Extracting lwjgl.dll

        Extracting lwjgl64.dll

    lwjgl-platform-2.9.0-natives-osx.jar Done

        Extracting liblwjgl.jnilib

        Extracting openal.dylib

    lwjgl-platform-2.9.0-natives-linux.jar Done

        Extracting liblwjgl.so

        Extracting liblwjgl64.so

        Extracting libopenal.so

        Extracting libopenal64.so

    jinput-platform-2.0.5-natives-windows.jar Done

        Extracting jinput-dx8.dll

        Extracting jinput-dx8_64.dll

        Extracting jinput-raw.dll

        Extracting jinput-raw_64.dll

        Extracting jinput-wintab.dll

    jinput-platform-2.0.5-natives-osx.jar Done

        Extracting libjinput-osx.jnilib

    jinput-platform-2.0.5-natives-linux.jar Done

        Extracting libjinput-linux.so

        Extracting libjinput-linux64.so

Backing up client

Downloaded 1.6.4.jar

Backing up server

Download of minecraft_server.1.6.4.jar failed hash check, deleting abcf286a14f7a

ee82e8bf89270433509 ba3145656b1480122bd8759cecd7b7a1

Something failed verifying minecraft files, see log for details.

Decompile Exception: 1

Press any key to continue . . .



I thought, oh well it probably does this all the time, so I redownloaded it after deleting MCP from it. I tried again, and the same thing happened. 5 times. I tried decompiling first, but no luck. I started up Eclipse Luna but, even though the directory was correct it always said 'Build path specifies execution environment JavaSE-1.6. There are no JREs installed in the workspace that are strictly compatible with this environment. Minecraft Build path JRE System Library Problem' I guess I've been as clear as I can, and I hope you can help me. -Monkermon


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I made a block entity in forge 1.20.1, I want to prevent hopper from taking input slot item, i tried to override the extractItem method, it prevented hopper from taking input slot item, but the player also unable to take/change the item in input slot unless the slot is empty. public class FluidSeparatorBlockEntity extends BlockEntity implements MenuProvider { private static final int INPUT_SLOT = 0; private final CustomItemHandler itemHandler = new CustomItemHandler(3){ @Override protected void onContentsChanged(int slot) { setChanged(); } @Override public boolean isItemValid(int slot, @NotNull ItemStack stack) { return slot == INPUT_SLOT; } @Override public @NotNull ItemStack extractItem(int slot, int amount, boolean simulate) { if (slot == INPUT_SLOT) { return ItemStack.EMPTY; } return super.extractItem(slot, amount, simulate); } }; private LazyOptional<IItemHandler> lazyItemHandler = LazyOptional.empty(); protected final ContainerData data; private int progress = 0; private int maxProgress = 78; public FluidSeparatorBlockEntity(BlockPos pPos, BlockState pBlockState) { super(ModBlockEntities.FLUID_SEPARATOR_BE.get(), pPos, pBlockState); this.data = new ContainerData() { @Override public int get(int pIndex) { return switch (pIndex) { case 0 -> FluidSeparatorBlockEntity.this.progress; case 1, 2 -> FluidSeparatorBlockEntity.this.maxProgress; default -> 0; }; } @Override public void set(int pIndex, int pValue) { switch (pIndex) { case 0 -> FluidSeparatorBlockEntity.this.progress = pValue; case 1, 2 -> FluidSeparatorBlockEntity.this.maxProgress = pValue; } } @Override public int getCount() { return 3; } }; } @Override public @NotNull <T> LazyOptional<T> getCapability(@NotNull Capability<T> cap, @Nullable Direction side) { if(cap == ForgeCapabilities.ITEM_HANDLER) { return lazyItemHandler.cast(); } return super.getCapability(cap, side); } @Override public void onLoad() { super.onLoad(); lazyItemHandler = LazyOptional.of(() -> itemHandler); } @Override public void invalidateCaps() { super.invalidateCaps(); lazyItemHandler.invalidate(); } public void drops() { SimpleContainer inventory = new SimpleContainer(itemHandler.getSlots()); for(int i = 0; i < itemHandler.getSlots(); i++) { inventory.setItem(i, itemHandler.getStackInSlot(i)); } Containers.dropContents(this.level, this.worldPosition, inventory); } @Override public Component getDisplayName() { return Component.translatable("block.chemmaster.fluid_separator"); } @Nullable @Override public AbstractContainerMenu createMenu(int pContainerId, Inventory pPlayerInventory, Player pPlayer) { return new FluidSeparatorMenu(pContainerId, pPlayerInventory, this, this.data); } @Override protected void saveAdditional(CompoundTag pTag) { pTag.put("inventory", itemHandler.serializeNBT()); pTag.putInt("fluid_separator.progress", progress); super.saveAdditional(pTag); } @Override public void load(CompoundTag pTag) { super.load(pTag); itemHandler.deserializeNBT(pTag.getCompound("inventory")); progress = pTag.getInt("fluid_separator.progress"); } public void tick(Level pLevel, BlockPos pPos, BlockState pState) { ItemStack inputStack = this.itemHandler.getStackInSlot(INPUT_SLOT); if (inputStack.getCount() < 2) { resetProgress(); return; } if(hasRecipe()) { increaseCraftingProgress(); setChanged(pLevel, pPos, pState); if(hasProgressFinished()) { craftItem(); resetProgress(); } } else { resetProgress(); } } private void resetProgress() { progress = 0; } private void craftItem() { Optional<FluidSeparatingRecipe> recipe = getCurrentRecipe(); if (recipe.isPresent()) { List<ItemStack> results = recipe.get().getOutputs(); ItemStack inputStack = this.itemHandler.getStackInSlot(INPUT_SLOT); if (inputStack.getCount() < 2) { // If there are not enough items, do not proceed with crafting return; } // Extract the input item from the input slot this.itemHandler.internalExtractItem(INPUT_SLOT, 2, false); // Loop through each result item and find suitable output slots for (ItemStack result : results) { int outputSlot = findSuitableOutputSlot(result); if (outputSlot != -1) { this.itemHandler.setStackInSlot(outputSlot, new ItemStack(result.getItem(), this.itemHandler.getStackInSlot(outputSlot).getCount() + result.getCount())); } else { // Handle the case where no suitable output slot is found // This can be logging an error, throwing an exception, or any other handling logic System.err.println("No suitable output slot found for item: " + result); } } } } private int findSuitableOutputSlot(ItemStack result) { // Implement logic to find a suitable output slot for the given result // Return the slot index or -1 if no suitable slot is found for (int i = 0; i < this.itemHandler.getSlots(); i++) { // Ensure we do not place the output item in the input slot if (i == INPUT_SLOT) { continue; } ItemStack stackInSlot = this.itemHandler.getStackInSlot(i); if (stackInSlot.isEmpty() || (stackInSlot.getItem() == result.getItem() && stackInSlot.getCount() + result.getCount() <= stackInSlot.getMaxStackSize())) { return i; } } return -1; } private boolean hasRecipe() { Optional<FluidSeparatingRecipe> recipe = getCurrentRecipe(); if (recipe.isEmpty()) { return false; } List<ItemStack> results = recipe.get().getOutputs(); for (ItemStack result : results) { if (!canInsertAmountIntoOutputSlot(result) || !canInsertItemIntoOutputSlot(result.getItem())) { return false; } } return true; } private Optional<FluidSeparatingRecipe> getCurrentRecipe(){ SimpleContainer inventory = new SimpleContainer(this.itemHandler.getSlots()); for (int i = 0; i < itemHandler.getSlots(); i++) { inventory.setItem(i, this.itemHandler.getStackInSlot(i)); } return this.level.getRecipeManager().getRecipeFor(FluidSeparatingRecipe.Type.INSTANCE, inventory, level); } private boolean canInsertAmountIntoOutputSlot(ItemStack result) { for (int i = 1; i < this.itemHandler.getSlots(); i++) { ItemStack stackInSlot = this.itemHandler.getStackInSlot(i); if (stackInSlot.isEmpty() || (stackInSlot.getItem() == result.getItem() && stackInSlot.getCount() + result.getCount() <= stackInSlot.getMaxStackSize())) { return true; } } return false; } private boolean canInsertItemIntoOutputSlot(Item item) { for (int i = 1; i < this.itemHandler.getSlots(); i++) { ItemStack stackInSlot = this.itemHandler.getStackInSlot(i); if (stackInSlot.isEmpty() || stackInSlot.getItem() == item) { return true; } } return false; } private boolean hasProgressFinished() { return progress >= maxProgress; } private void increaseCraftingProgress() { progress++; } }  
    • No dice. Unfortunately this fix didn't work, thank you though.
    • Maybe you need a rayon mod. https://www.curseforge.com/minecraft/mc-mods/rayon
    • Not sure what's going on the logs are making even less sense than usual to me. Any help would be much appreciated.   https://paste.ee/p/KBHyP#s=0
  • Topics

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.