Jump to content

NEI in dev environment


Nauktis

Recommended Posts

Hi,

 

I want to add Waila support to my mod.

I followed the procedure ProfMobius highlighted on his website, adding the following to the gradle build file.

 

repositories {
    maven {
        name "Mobius Repo"
        url "http://mobiusstrip.eu/maven"
    }
    maven {
        name 'CB Repo'
        url "http://chickenbones.net/maven/"
    }
}

dependencies {
    // I dont have to specify NEI.. because gradle magic. aka: transitive dependency resolution
    compile "mcp.mobius.waila:Waila:1.5.3_1.7.10"
}

 

Then a small: gradle clean setupDecompWorkspace eclipse --refresh-dependencies

Jar files are there in my Eclipse and I start wrtiting my add-on.

The problem I have is that when I start Minecraft from Eclipse, Forge complains that a requirement is not there: NEI

 

Could someone help me?

 

Thanks a lot.

Link to comment
Share on other sites

Thanks for your help.

I added -Dfml.coreMods.load=codechicken.core.launch.CodeChickenCorePlugin,codechicken.nei.asm.NEICorePlugin

 

Seems to go a bit further but now it crashes when starting:

 

 

[23:02:38] [main/INFO] [GradleStart]: No arguments specified, assuming client.
[23:02:38] [main/INFO] [GradleStart]: Extra: []
[23:02:38] [main/INFO] [GradleStart]: Running with arguments: [--userProperties, {}, --username, ForgeDevName, --tweakClass, cpw.mods.fml.common.launcher.FMLTweaker, --accessToken, {REDACTED}, --assetIndex, 1.7.10, --assetsDir, /Users/Harold/.gradle/caches/minecraft/assets, --version, 1.7.10]
[23:02:38] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLTweaker
[23:02:38] [main/INFO] [LaunchWrapper]: Using primary tweak class name cpw.mods.fml.common.launcher.FMLTweaker
[23:02:38] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLTweaker
[23:02:38] [main/INFO] [FML]: Forge Mod Loader version 7.10.25.1207 for Minecraft 1.7.10 loading
[23:02:38] [main/INFO] [FML]: Java is Java HotSpot(TM) 64-Bit Server VM, version 1.7.0_51, running on Mac OS X:x86_64:10.9.4, installed at /Library/Java/JavaVirtualMachines/jdk1.7.0_51.jdk/Contents/Home/jre
[23:02:38] [main/INFO] [FML]: Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation
[23:02:38] [main/INFO] [FML]: Found a command line coremod : codechicken.core.launch.CodeChickenCorePlugin
[23:02:38] [main/WARN] [FML]: The coremod codechicken.core.launch.CodeChickenCorePlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft
[23:02:38] [main/INFO] [FML]: Found a command line coremod : codechicken.nei.asm.NEICorePlugin
[23:02:38] [main/WARN] [FML]: The coremod codechicken.nei.asm.NEICorePlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft
[23:02:38] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
[23:02:38] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker
[23:02:38] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
[23:02:38] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
[23:02:38] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
[23:02:39] [main/ERROR] [FML]: The binary patch set is missing. Either you are in a development environment, or things are not going to work!
[23:02:40] [main/ERROR] [FML]: The minecraft jar file:/Users/Harold/.gradle/caches/minecraft/net/minecraftforge/forge/1.7.10-10.13.0.1207/forgeSrc-1.7.10-10.13.0.1207.jar!/net/minecraft/client/ClientBrandRetriever.class appears to be corrupt! There has been CRITICAL TAMPERING WITH MINECRAFT, it is highly unlikely minecraft will work! STOP NOW, get a clean copy and try again!
[23:02:40] [main/ERROR] [FML]: FML has been ordered to ignore the invalid or missing minecraft certificate. This is very likely to cause a problem!
[23:02:40] [main/ERROR] [FML]: Technical information: ClientBrandRetriever was at jar:file:/Users/Harold/.gradle/caches/minecraft/net/minecraftforge/forge/1.7.10-10.13.0.1207/forgeSrc-1.7.10-10.13.0.1207.jar!/net/minecraft/client/ClientBrandRetriever.class, there were 0 certificates for it
[23:02:40] [main/ERROR] [FML]: FML appears to be missing any signature data. This is not a good thing
[23:02:40] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
[23:02:40] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
[23:02:40] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
[23:02:40] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
[23:02:40] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLDeobfTweaker
[23:02:43] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.TerminalTweaker
[23:02:43] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.TerminalTweaker
[23:02:43] [main/INFO] [LaunchWrapper]: Launching wrapped minecraft {net.minecraft.client.main.Main}
[23:02:47] [main/INFO]: Setting user: ForgeDevName
[23:02:51] [Client thread/INFO]: LWJGL Version: 2.9.1
[23:02:52] [Client thread/INFO] [MinecraftForge]: Attempting early MinecraftForge initialization
[23:02:52] [Client thread/INFO] [FML]: MinecraftForge v10.13.0.1207 Initialized
[23:02:52] [Client thread/INFO] [FML]: Replaced 182 ore recipies
[23:02:52] [Client thread/INFO] [MinecraftForge]: Completed early MinecraftForge initialization
[23:02:52] [Client thread/INFO] [FML]: Searching /Users/Harold/Documents/minecraft/mods/SolarFlux/eclipse/mods for mods
[23:02:52] [Client thread/INFO] [FML]: Also searching /Users/Harold/Documents/minecraft/mods/SolarFlux/eclipse/mods/1.7.10 for mods
[23:02:54] [Client thread/ERROR] [FML]: FML has detected a mod that is using a package name based on 'net.minecraft.src' : net.minecraft.src.FMLRenderAccessLibrary. This is generally a severe programming error.  There should be no mod code in the minecraft namespace. MOVE YOUR MOD! If you're in eclipse, select your source code and 'refactor' it into a new package. Go on. DO IT NOW!
[23:02:57] [Client thread/INFO] [FML]: Forge Mod Loader has identified 7 mods to load
Aug 21, 2014 11:02:57 PM com.google.common.eventbus.EventBus$LoggingSubscriberExceptionHandler handleException
SEVERE: Could not dispatch event: cpw.mods.fml.common.LoadController@6ea3ffa8 to public void cpw.mods.fml.common.LoadController.buildModList(cpw.mods.fml.common.event.FMLLoadEvent)
[23:02:57] [Client thread/INFO]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge
---- Minecraft Crash Report ----
// You're mean.

Time: 8/21/14 11:02 PM
Description: Initializing game

java.util.NoSuchElementException: Missing nodes from graph
at cpw.mods.fml.common.toposort.TopologicalSort$DirectedGraph.addEdge(TopologicalSort.java:70)
at cpw.mods.fml.common.toposort.ModSorter.buildGraph(ModSorter.java:114)
at cpw.mods.fml.common.toposort.ModSorter.<init>(ModSorter.java:46)
at cpw.mods.fml.common.Loader.sortModList(Loader.java:251)
at cpw.mods.fml.common.Loader.loadMods(Loader.java:472)
at cpw.mods.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:204)
at net.minecraft.client.Minecraft.startGame(Minecraft.java:532)
at net.minecraft.client.Minecraft.run(Minecraft.java:941)
at net.minecraft.client.main.Main.main(Main.java:164)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at net.minecraft.launchwrapper.Launch.launch(Launch.java:134)
at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at GradleStart.bounce(GradleStart.java:107)
at GradleStart.startClient(GradleStart.java:100)
at GradleStart.main(GradleStart.java:55)


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- Head --
Stacktrace:
at cpw.mods.fml.common.toposort.TopologicalSort$DirectedGraph.addEdge(TopologicalSort.java:70)
at cpw.mods.fml.common.toposort.ModSorter.buildGraph(ModSorter.java:114)
at cpw.mods.fml.common.toposort.ModSorter.<init>(ModSorter.java:46)
at cpw.mods.fml.common.Loader.sortModList(Loader.java:251)
at cpw.mods.fml.common.Loader.loadMods(Loader.java:472)
at cpw.mods.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:204)
at net.minecraft.client.Minecraft.startGame(Minecraft.java:532)

-- Initialization --
Details:
Stacktrace:
at net.minecraft.client.Minecraft.run(Minecraft.java:941)
at net.minecraft.client.main.Main.main(Main.java:164)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at net.minecraft.launchwrapper.Launch.launch(Launch.java:134)
at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at GradleStart.bounce(GradleStart.java:107)
at GradleStart.startClient(GradleStart.java:100)
at GradleStart.main(GradleStart.java:55)

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.