Jump to content

[1.7.10] [Not Solved] Change Item Metadata on Keypress


Whyneb360

Recommended Posts

My problem is as the title says. I am trying to change an items metadata on a key-press. My current code is as follows (apologies in advance, but I can't seem to get the insert code function to work):

 

public class GliderKeybinding {

public static final int TOGGLEGLIDER = 0;

private static final String[] desc = {"Open/Close Glider"};

private static final int[] keyValues = {Keyboard.KEY_R};

private final KeyBinding[] keys;

public boolean GliderActive;

public GliderKeybinding() {

keys = new KeyBinding[desc.length];

for (int i = 0; i < desc.length; ++i) {

keys = new KeyBinding(desc, keyValues, "Elemental Imperium");

ClientRegistry.registerKeyBinding(keys);

 

 

}

}

 

 

 

public void onKeyInput(KeyInputEvent event, ItemStack par1itemstack, World par2world, EntityPlayer par3player) {

if (keys[TOGGLEGLIDER].isPressed() && Minecraft.getMinecraft().thePlayer.inventory.getItemStack() == par1itemstack) {

if (GliderActive) {

GliderActive = false;

setDamage(par1itemstack, 1);

}else{

GliderActive = true;

setDamage(par1itemstack, 0);

}

}

}

 

 

private void setDamage(ItemStack par1itemstack, int i) {

 

}

}

 

===== And I have registered it as:======

 

FMLCommonHandler.instance().bus().register(new GliderKeybinding());

 

 

What have I done wrong?

 

Many thanks in advance,

- Whyneb360

Link to comment
Share on other sites

Now I have done this:

 

@SubscribeEvent

public void onKeyInput(KeyInputEvent event) {

if (keys[TOGGLEGLIDER].isPressed()) {

if (GliderActive) {

GliderActive = false;

setDamage(ElementalImperium.Test, 0);

System.out.println("Glider Deployed");

}else{

GliderActive = true;

setDamage(ElementalImperium.Test, 1);

System.out.println("Glider Restracted");

}

}

}

 

 

public void setDamage(Item test, int i) {

 

}

}

 

 

and that works for the println, but not the setDamage. Did I reference the item wrong?

 

Thanks for bearing with me

Link to comment
Share on other sites

So, my code is as follows:

 

public class Glider extends Item
{
private String[] name = {"staff", "glider"};

@SideOnly(Side.CLIENT)
private IIcon[] icons;

public static final int TOGGLEGLIDER = 0;
private static final String[] desc = {"Open/Close Glider"};
private static final int[] keyValues = {Keyboard.KEY_R};
private final KeyBinding[] keys;
public static boolean GliderActive;
private ItemStack Glider;

public Glider() {

	keys = new KeyBinding[desc.length];
	for (int i = 0; i < desc.length; ++i) {
		keys[i] = new KeyBinding(desc[i], keyValues[i], "Elemental Imperium");
		ClientRegistry.registerKeyBinding(keys[i]);

		setUnlocalizedName(Constants.MODID + "_" + "test");
		setHasSubtypes(true);
		setCreativeTab(ElementalCreativeTab.elementalimperium);
		setMaxStackSize(1);
		setFull3D();

	}
}


@Override
public String getUnlocalizedName(ItemStack par1ItemStack) {
	int metadata = MathHelper.clamp_int(par1ItemStack.getItemDamage(), 0, 15);

	return super.getUnlocalizedName() + "." + name[metadata];
}

@SideOnly(Side.CLIENT)
@Override
public void registerIcons(IIconRegister par1IconRegister) {
	icons = new IIcon[name.length];

	for (int i = 0; i < icons.length; i++) {
		icons [i] = par1IconRegister.registerIcon(Constants.MODID + ":" + "test" + " " + name[i]);
	}
}

@Override
public IIcon getIconFromDamage(int par1) {
	return icons[par1];
}


@SuppressWarnings ({"unchecked", "rawtypes" })
@SideOnly(Side.CLIENT)
@Override
public void getSubItems(Item par1, CreativeTabs par2CreativeTabs, List par3List) {
	for (int x = 0; x < name.length; x++)
	{
		par3List.add(new ItemStack(this, 1, x));
	}
}

@SubscribeEvent
public void onKeyInput(KeyInputEvent event) {
	if (keys[TOGGLEGLIDER].isPressed()) {
		if (GliderActive) {
			GliderActive = false;
			System.out.println("Glider Deployed");
		}else{
			GliderActive = true;
			System.out.println("Glider Restracted");
		}	
	}
}
}

 

Okay, so what I am trying to do in the last bit is change the metadata on the key-press of 'R'. I've been told I need to use a packet, and was wondering if anyone could link me to, or supply something that would help me.

 

Any help would be useful

Thanks in advance

 

-Whyneb360

Link to comment
Share on other sites

There's a tutorial on the SimpleNetworkWrapper in the tutorials section.

Don't PM me with questions. They will be ignored! Make a thread on the appropriate board for support.

 

1.12 -> 1.13 primer by williewillus.

 

1.7.10 and older versions of Minecraft are no longer supported due to it's age! Update to the latest version for support.

 

http://www.howoldisminecraft1710.today/

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Please share a link to your crash report on https://paste.ee, as explained in the FAQ. Dumping it directly into the thread often triggers the anti-spam and makes it hard to read due to word wrapping
    • Hi all, I'm running a 1.20.1 Minecraft Forge server with a hosting website and something seems to have gone wrong. It started as an occasional crash that has now become extremely frequent and I don't know what exactly is causing it. I already tried disabling watchdog but the server crashes anyway. Oddly it only occasionally generates a crash report after a crash occurs. Based on viewing the server console's research usage it seems that the CPU spikes astronomically high (100% usage), especially when chunks are being loaded or when a new person joins the server. I downloaded Spark to create a profile (https://spark.lucko.me/bBlWe7ou29) but I lack experience with this mod and don't understand what I'm looking at/how this should help me diagnose the issue. I am using a lot of mods so I'm guessing there is some sort of issue there or a corrupted chunk (although MCRF found no chunk errors). We actually don't experience any lag until the crash occurs, so it's some sort of sudden spike in resource usage. Based on the crash report I've already tried removing Canary and Modernfix but there was no change. Thanks for any help you can provide. Specs:  4 cores x 4200MHz AMD Ryzen 9 5950X 4GB RAM Crash report:  
    • will test that once i get home, thanks
    • I am getting this exception (I am new and just trying to create an item) Caused by: java.io.FileNotFoundException: abrasmagics:models/item/ingot_test.json at net.minecraft.client.resources.SimpleReloadableResourceManager.getResource(SimpleReloadableResourceManager.java:69) ~[SimpleReloadableResourceManager.class:?] at net.minecraft.client.renderer.block.model.ModelBakery.loadModel(ModelBakery.java:334) ~[ModelBakery.class:?] at net.minecraftforge.client.model.ModelLoader.access$1400(ModelLoader.java:115) ~[ModelLoader.class:?] at net.minecraftforge.client.model.ModelLoader$VanillaLoader.loadModel(ModelLoader.java:861) ~[ModelLoader$VanillaLoader.class:?] at net.minecraftforge.client.model.ModelLoaderRegistry.getModel(ModelLoaderRegistry.java:157) ~[ModelLoaderRegistry.class:?]   However the directory is set up correctly and the file does exist   idk how to upload images so here is a treeview of the directories:   src ├───main │ ├───java │ │ └───net │ │ └───abrasmods │ │ └───abrasmagics │ │ ├───init │ │ ├───items │ │ └───utils │ │ ├───handlers │ │ ├───misc │ │ └───proxy │ └───resources │ └───assets │ └───abrasmagics │ ├───models │ │ ├───block │ │ └───item │ └───textures └───test ├───java └───resources   the file ingot_test.json is under models/item. The directory seems fine and the file does exist so anyone plz help.   i am using intellij and is coding for 1.12.2
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.