Jump to content

[1.7.10] [Solved] ResourceLocation not working.


Awesome_Spider

Recommended Posts

I have made a block with a custom model (ItemPipe). It work fine except for one problem, the ResourceLocation isn't working. I use this code to render the model:

@Override
public void renderTileEntityAt(TileEntity tileEntity, double x,
		double y, double z, float scale) {
        GL11.glPushMatrix();

        GL11.glTranslatef((float) x + 0.5F, (float) y + 1.5F, (float) z + 0.5F);

        ResourceLocation textures = (new ResourceLocation(Mechanistic.MODID, "textures/blocks/StoneItemPipe.png")); 

        Minecraft.getMinecraft().renderEngine.bindTexture(textures);
                   
        GL11.glPushMatrix();
        GL11.glRotatef(180F, 0.0F, 0.0F, 1.0F);

        this.model.render((Entity)null, 0.0F, 0.0F, -0.1F, 0.0F, 0.0F, 0.0625F);

        GL11.glPopMatrix();
        GL11.glPopMatrix();
}

 

When I run it, it says there is a missing resource, but I put the resource in the right place:

1XK4WIG.png

 

Is there something I'm doing wrong? Thanks in advance. :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.