Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[SOLVED] Compiler warning: overridden method is a bridge method


coolAlias
 Share

Recommended Posts

I noticed this warning for the first time today:

RenderEntityKeese.java:48: warning: getEntityTexture (Entity) in RenderEntitykeese overrides getEntityTexture(Entity) in RenderBat; overridden method is a bridge method
     protected ResourceLocation getEntityTexture(Entity entity) {

 

Code responsible:

// RenderEntityKeese extends RenderBat
@Override
protected ResourceLocation getEntityTexture(Entity entity) {
return getEntityTexture((EntityKeese) entity); // this is exactly the same as how RenderBat overrides getEntityTexture
}

 

Which got me reading about bridge methods and type erasure, here, here, and here.

 

I tried various things to see if I could get the warning to go away to no avail. Everything seems to work fine, but I don't like getting warnings :P

 

Is this something I can 'fix', or is it not an issue?

Link to comment
Share on other sites

Ah, that makes sense. For whatever reason, I didn't put 2 and 2 together.

 

I was able to fix all but one of the warnings that way: I have a class that extends EntityVillager and overrides createChild(EntityAgeable), but I cannot change the parameter type without the method signature failing.

@Override
public EntityGoron createChild(EntityAgeable entity) {
EntityGoron goron = new EntityGoron(worldObj);
goron.onSpawnWithEgg(null);
goron.updateEntityAttributes(true);
return goron;
}

Link to comment
Share on other sites

Uh, but that's not a generic parameter as far as I can tell. Just using the EntityAgeable version should be fine.

In this case it's not a generic parameter, it's the covariant return type that is causing the bridge method to be created, but changing the return type to EntityVillager (or worse, EntityAgeable), even if it were an option, simply does not work to remove the warning.

 

If only I could magically absorb all knowledge of the JVM and javac... :\

Link to comment
Share on other sites

Ah, right. Well, the bridge method in EntityVillager is called func_180488_b, so that's what you have to override.

 

Edit: Err... *non-bridge.

Hm, in 1.8 yes, but in 1.7.10 the EntityVillager#createChild implementation doesn't call any other methods.

 

Well, I'll just ignore that one, then, since there doesn't seem to be anything to do about it until I update to 1.8. Thanks for the help!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • So i just bought a RLcraft server for me and my friends to play on. I launched it and it is working fine but it tells me that i need to download all the mods i go to mods and press "minecraft forge" and nothing shows up that i can open files. If anyone have a suggestion i would need the help. This is the server hosting i  used 
    • i did it in 1.12.2 not walking for me can anyone help me get it pls???  
    • Got the rotation working. I had to look at LivingEntityRenderer#render and setupRotations a little more closely, and I realized that I needed to change the custom entity's yBodyRot and yBodyRotO.  private static boolean renderingCustomEntity = false; private static CustomEntity customEntity; private static void refreshCustomEntity(LocalPlayer localPlayer, LivingEntity livingEntity) { if (customEntity == null || customEntity.isRemoved()) { customEntity = ModEntities.CUSTOM_ENTITY.get().create(localPlayer.clientLevel); } if (!customEntity.level.dimension().equals(livingEntity.level.dimension())) { customEntity.discard(); } } @SubscribeEvent public static void replaceMobModel(RenderLivingEvent.Pre<LivingEntity, EntityModel<LivingEntity>> event) { LocalPlayer localPlayer = Minecraft.getInstance().player; if (localPlayer != null && event.getEntity() instanceof Mob mob) { if (/* put your own condition here */) { if (!renderingCustomEntity) { try { renderingCustomEntity = true; event.setCanceled(true); refreshCustomEntity(localPlayer, mob); // (truth be told, my custom entity does not have a "head", so these lines aren't needed) // customEntity.setYHeadRot(mob.getYHeadRot()); // customEntity.yHeadRotO = mob.yHeadRotO; customEntity.setYBodyRot(mob.yBodyRot); customEntity.yBodyRotO = mob.yBodyRotO; customEntity.setPose(mob.getPose()); Minecraft.getInstance().getEntityRenderDispatcher().getRenderer(customEntity).render( customEntity, customEntity.yBodyRot, event.getPartialTick(), event.getPoseStack(), event.getMultiBufferSource(), event.getPackedLight() ); } finally { renderingCustomEntity = false; } } } } }   As shown in my code, if the mob whose model is replaced moves to a different dimension, I unload the custom entity with Entity#discard and then reinitialize it on the next tick. I wonder if I also have to unload the custom entity when the mob it is "replacing" dies.
    • Thank you for the video, but I found the issue. I had to update the Gradle from 7.2 to 7.3 in gradle/wrapper/gradle-wrapper.properties.
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.