Jump to content

[1.8] everyting has become white and green, is a limit for textures ?<Solved>


perromercenary00

Recommended Posts

good nigths 

 

this is what ill  talking about

 

this happed just in the normal client, in eclipse it works well

soo i was using forge-1.8-11.14.1.1336 soo i update  it, eclipse and normal minecraft are now forge-1.8-11.14.1.1350 then  recompile and it still white and green in the normal client but eclipse works normal.

 

this looks like a textures problem but it works on eclipse

the las thing i do was create two pistols and a bullet clip,  so i check again and all textures are 512x512 png  and all folders are lowerCase  and all routes are fine

 

 

and it works on eclipse soo du not know

 

Link to comment
Share on other sites

You must have done something REALLY bad in rendering code. What rendering events are you using? Codes?

Probably forgot to reset GL state or some blending mode.

1.7.10 is no longer supported by forge, you are on your own.

Link to comment
Share on other sites

nop

 

noting of complex rendering

all items are just plane json files

i do animations switching textures 

 

i notice someting that have cause me this teory of the limit in the textures amoung

 

the last i make was two guns and a bullet clip

every gun uses like 23 json files and the clip uses 45

there are so many coz this guns are complez every guns works whith three types of bullet clip all animated load unload

every bullet clip works whith two kinds of munition all animated

all the bullet clips are sub items from the cargadorFM9X class

 

 

 

mercenaryModTextures.java


ModelBakery.addVariantName(MercenaryModItems.pistolaFM92, new String[]{
    
    		"modmercenario:pistolamf92/pistolaFM92_icono",
    		"modmercenario:pistolamf92/pistolaFM92_SC",
    		    		
    		"modmercenario:pistolamf92/pistolaFM92_CC",
    		"modmercenario:pistolamf92/pistolaFM92_CC_A00",
    		"modmercenario:pistolamf92/pistolaFM92_CC_A01",
    		"modmercenario:pistolamf92/pistolaFM92_CC_A02",
    		"modmercenario:pistolamf92/pistolaFM92_CC_A03",
    		"modmercenario:pistolamf92/pistolaFM92_CC_A04",
    		"modmercenario:pistolamf92/pistolaFM92_CC_disparo",
    		
    		"modmercenario:pistolamf92/pistolaFM92_CL",
    		"modmercenario:pistolamf92/pistolaFM92_CL_A00",
    		"modmercenario:pistolamf92/pistolaFM92_CL_A01",
    		"modmercenario:pistolamf92/pistolaFM92_CL_A02",
    		"modmercenario:pistolamf92/pistolaFM92_CL_A03",
    		"modmercenario:pistolamf92/pistolaFM92_CL_A04",
    		"modmercenario:pistolamf92/pistolaFM92_CL_disparo",

    		"modmercenario:pistolamf92/pistolaFM92_CG",
    		"modmercenario:pistolamf92/pistolaFM92_CG_A00",
    		"modmercenario:pistolamf92/pistolaFM92_CG_A01",
    		"modmercenario:pistolamf92/pistolaFM92_CG_A02",
    		"modmercenario:pistolamf92/pistolaFM92_CG_A03",
    		"modmercenario:pistolamf92/pistolaFM92_CG_A04",
    		"modmercenario:pistolamf92/pistolaFM92_CG_disparo",
    		   		

    });
    
    Minecraft.getMinecraft().getRenderItem().getItemModelMesher().register(MercenaryModItems.pistolaFM92,0 , 
    new ModelResourceLocation("modmercenario:pistolamf92/pistolaFM92_icono", "inventory"));
    
    
    
    ModelBakery.addVariantName(MercenaryModItems.pistolaFM93R, new String[]{
    	    
    		"modmercenario:pistolamf93r/pistolaFM93R_icono",
    		"modmercenario:pistolamf93r/pistolaFM93R_SC",
    		    		
    		"modmercenario:pistolamf93r/pistolaFM93R_CC",
    		"modmercenario:pistolamf93r/pistolaFM93R_CC_A00",
    		"modmercenario:pistolamf93r/pistolaFM93R_CC_A01",
    		"modmercenario:pistolamf93r/pistolaFM93R_CC_A02",
    		"modmercenario:pistolamf93r/pistolaFM93R_CC_A03",
    		"modmercenario:pistolamf93r/pistolaFM93R_CC_A04",
    		"modmercenario:pistolamf93r/pistolaFM93R_CC_disparo",
    		
    		"modmercenario:pistolamf93r/pistolaFM93R_CL",
    		"modmercenario:pistolamf93r/pistolaFM93R_CL_A00",
    		"modmercenario:pistolamf93r/pistolaFM93R_CL_A01",
    		"modmercenario:pistolamf93r/pistolaFM93R_CL_A02",
    		"modmercenario:pistolamf93r/pistolaFM93R_CL_A03",
    		"modmercenario:pistolamf93r/pistolaFM93R_CL_A04",
    		"modmercenario:pistolamf93r/pistolaFM93R_CL_disparo",

    		"modmercenario:pistolamf93r/pistolaFM93R_CG",
    		"modmercenario:pistolamf93r/pistolaFM93R_CG_A00",
    		"modmercenario:pistolamf93r/pistolaFM93R_CG_A01",
    		"modmercenario:pistolamf93r/pistolaFM93R_CG_A02",
    		"modmercenario:pistolamf93r/pistolaFM93R_CG_A03",
    		"modmercenario:pistolamf93r/pistolaFM93R_CG_A04",
    		"modmercenario:pistolamf93r/pistolaFM93R_CG_disparo"
    		   		

    });
    
    
    Minecraft.getMinecraft().getRenderItem().getItemModelMesher().register(MercenaryModItems.pistolaFM93R,0 , 
    new ModelResourceLocation("modmercenario:pistolamf93r/pistolaFM93R_icono", "inventory"));
    
    
    
    ModelBakery.addVariantName(MercenaryModItems.cargadorFM9X, new String[]{
    	    
    		"modmercenario:cargadorfm9x/cargadorFM9X_CC_icono",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CG_icono",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CL_icono",
    		
    		"modmercenario:cargadorfm9x/cargadorFM9X_CC_A00",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CC_A01",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CC_A02",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CC_A03",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CC_A04",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CC_b",    // clip whith bullets
    		"modmercenario:cargadorfm9x/cargadorFM9X_CC_e",    // empty clip
    	
    		"modmercenario:cargadorfm9x/cargadorFM9X_CCr_A00",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CCr_A01",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CCr_A02",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CCr_A03",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CCr_A04",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CCr_b",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CCr_e",
    		
    		"modmercenario:cargadorfm9x/cargadorFM9X_CG_A00",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CG_A01",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CG_A02",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CG_A03",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CG_A04",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CG_b",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CG_e",
    		
    		"modmercenario:cargadorfm9x/cargadorFM9X_CGr_A00",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CGr_A01",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CGr_A02",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CGr_A03",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CGr_A04",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CGr_b",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CGr_e",
    		
    		"modmercenario:cargadorfm9x/cargadorFM9X_CL_A00",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CL_A01",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CL_A02",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CL_A03",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CL_A04",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CL_b",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CL_e",
    		
    		"modmercenario:cargadorfm9x/cargadorFM9X_CLr_A00",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CLr_A01",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CLr_A02",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CLr_A03",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CLr_A04",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CLr_b",
    		"modmercenario:cargadorfm9x/cargadorFM9X_CLr_e"
    		   		
    		
    });
    	    
    
    Minecraft.getMinecraft().getRenderItem().getItemModelMesher().register(MercenaryModItems.cargadorFM9X,1 , 
    new ModelResourceLocation("modmercenario:cargadorfm9x/cargadorFM9X_CC_icono", "inventory"));
    
    Minecraft.getMinecraft().getRenderItem().getItemModelMesher().register(MercenaryModItems.cargadorFM9X,2 , 
    new ModelResourceLocation("modmercenario:cargadorfm9x/cargadorFM9X_CC_icono", "inventory"));
    	    
    Minecraft.getMinecraft().getRenderItem().getItemModelMesher().register(MercenaryModItems.cargadorFM9X,3 , 
    new ModelResourceLocation("modmercenario:cargadorfm9x/cargadorFM9X_CC_icono", "inventory"));
    
    Minecraft.getMinecraft().getRenderItem().getItemModelMesher().register(MercenaryModItems.cargadorFM9X,4 , 
    new ModelResourceLocation("modmercenario:cargadorfm9x/cargadorFM9X_CL_icono", "inventory"));
    	    
    Minecraft.getMinecraft().getRenderItem().getItemModelMesher().register(MercenaryModItems.cargadorFM9X,5 , 
    new ModelResourceLocation("modmercenario:cargadorfm9x/cargadorFM9X_CL_icono", "inventory"));

    Minecraft.getMinecraft().getRenderItem().getItemModelMesher().register(MercenaryModItems.cargadorFM9X,6 , 
    new ModelResourceLocation("modmercenario:cargadorfm9x/cargadorFM9X_CL_icono", "inventory"));

    Minecraft.getMinecraft().getRenderItem().getItemModelMesher().register(MercenaryModItems.cargadorFM9X,7 , 
    new ModelResourceLocation("modmercenario:cargadorfm9x/cargadorFM9X_CG_icono", "inventory"));

    Minecraft.getMinecraft().getRenderItem().getItemModelMesher().register(MercenaryModItems.cargadorFM9X,8 , 
    new ModelResourceLocation("modmercenario:cargadorfm9x/cargadorFM9X_CG_icono", "inventory"));

    Minecraft.getMinecraft().getRenderItem().getItemModelMesher().register(MercenaryModItems.cargadorFM9X,9 , 
    new ModelResourceLocation("modmercenario:cargadorfm9x/cargadorFM9X_CG_icono", "inventory"));

 

 

if I  //coment the textures for //mf92 and for the clips //cargadorFM9X  compile and run, in the normal client

the textures of the world are now normal and the mf93r work whit all his textures

 

then revert and //coment //mf93r and //cargadorFM9x compile

the textures of the world are now normal and the mf92 work whit all his textures

 

then //coment the two guns and only left  the cargadorFM9x textures compile

ñaa the word is white and green again

 

//coment the two guns and only left  the first 17 textures from cargadorFM9x compile test

the world is normal and the clip works whit only the textures representing the shorth versions of the clip

 

//coment a lot of textures from other //items and the two //guns, and uncomment all the textures for the clip, compile

the world is normal all the clips works whit all his textures everithing else works including the two type of bullets animations, just missing the textures for all the comented items and the guns

 

afther see this tests  i come whith the teory of a limit i dont thing is for amount but for size cos i have register like 405 textures for all including tools  guns and clips and are 235 items for all and 2 blocks

most of mi items are 64x textures and the fire guns are 512x textures

 

In eclipse this is not a trouble looks like is not afected for whatever this it is,

everithing works on eclipse whitout having to comment nothing

 

and everything works individualy when tested in normal client  commenting the textures for other items soo there is no erros in routes names or png size/type

 

i dont wanna remove nothing from the actual mod, and more  i wanna add more guns but look like is no room for more

i tink i have to split this mod in parts   

 

what you tink ??

Link to comment
Share on other sites

When did that started happening? What have you done between that run, and the previous working?

Don't PM me with questions. They will be ignored! Make a thread on the appropriate board for support.

 

1.12 -> 1.13 primer by williewillus.

 

1.7.10 and older versions of Minecraft are no longer supported due to it's age! Update to the latest version for support.

 

http://www.howoldisminecraft1710.today/

Link to comment
Share on other sites

I'd go with standard debugging procedure.

 

Comment out everything in your mod (at most basic level - registy) and add one after another.

1st I'd check events (if you use any) then go with item registration and rendering.

 

There is not much to say to help you, are you sure you are not using anything in RenderGameOverlay? How are you drawing your gui?

1.7.10 is no longer supported by forge, you are on your own.

Link to comment
Share on other sites

weel the last time i test the mod and works normal was monday

that day i begin doing the code for the guns and the clip

the Thursday end and everithing works on eclipse so i decide to test mi new guns in the normal minecraft client and there it goes green and white

 

soo the trouble begin whith the new guns,

these are new coz i alredy have colt1911 fn57 fnp90 and that 3 are are older than monday

 

so i have five guns

 

aniway i do guns the way vainilla bow works

 

lets make some tests

 

first this is in the normal client minecraft using mi mod plus this others mods i like to test aside others mod to be sure it wont mess whit something else

/home/tenchi/.minecraft/mods/bamsgrave-1.8-1.4.3.jar

/home/tenchi/.minecraft/mods/BattleTowers-1.8.jar

/home/tenchi/.minecraft/mods/Birds-mod-by-silvercatcher-1.8.jar

/home/tenchi/.minecraft/mods/Bloodmoon-1.1.jar

/home/tenchi/.minecraft/mods/Cute-mob-models-mod-by-yarrmateys-1.8.jar

/home/tenchi/.minecraft/mods/CyanosLootableBodies-1.3.4.jar

/home/tenchi/.minecraft/mods/Damage-Indicators-Mod-1.8.jar

/home/tenchi/.minecraft/mods/DynamicLights-1.8.jar

/home/tenchi/.minecraft/mods/Ender-Zoo-Mod-1.8.jar

/home/tenchi/.minecraft/mods/forge_TheEpicarnoMod-1.0.9.7.jar

/home/tenchi/.minecraft/mods/InventoryTweaks-1.59-beta-175.jar

/home/tenchi/.minecraft/mods/iPixelis-Gender-Mod-1.8.jar

/home/tenchi/.minecraft/mods/LavaBoat-Mod-1.8.jar

/home/tenchi/.minecraft/mods/Minions-1.8.jar

/home/tenchi/.minecraft/mods/MrCrayfishs-Furniture-Mod-1.8.jar

/home/tenchi/.minecraft/mods/Roguelike-Dungeons-Mod-1.8.jar

/home/tenchi/.minecraft/mods/Ruins-1.8.jar

/home/tenchi/.minecraft/mods/Sound-Filters-Mod-1.8.jar

/home/tenchi/.minecraft/mods/UpdateCheckerMod-1.8.jar

/home/tenchi/.minecraft/mods/vintagetg-1.8-1.0.2.jar

/home/tenchi/.minecraft/mods/World-Tools-Mod-1.8.jar

 

/home/tenchi/.minecraft/mods/modmercenario-1.8.jar

 

 

first test

i dont mess whit the guns code i only /*comment*/ the textures to dissabling textures for mf92 mf93r and cagadormf9x  to test the old guns.

 

second test

still whithout messing whit the code this time i /*comment*/ the textures for the old guns and let only to test the new guns

 

thirth test

whithout messing whit the code i uncoment all the textures for all the items everithing is enable

to the left eclipse minecrat all textures work  to the rigth nomrmal client minecraft everiting is green and white

 

four test

this time i coment every texture except for fireguns but the bullet clip  cargadorFM9X

 

 

conclusions

 

it is a limit aplicated to the size of the images png.  but only affect the client minecraft, but not the eclipse minecraft

cargadorFM9X is to big for this limit and if resize it to 128x128 it looks affull

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • i have the decocraft mod and i can see all of them. i can click right click and place the items but as soon as i put it down it disappears. im so sad it doesnt work and i dont know how to fix it. i used cursed forge to launch minecraft as well.
    • Me and my friend wanted to make a custom mod pack hosted on aternos. I downloaded the same mods as the server then started the server and my minecraft and I joined the server without issues. Then I sent the mods to my friend compressed in a zip folder (i don’t know if that has anything to do with the issue). He unpacked it put it in his mod folder and started it but couldn't join the server and got this issue:   internal exception: java.lang.runtimeexception: server not initialized yet! call IMDLib.entityHandler (modid)   Also we are using curseforge launcher to manage the mods on client side. But as I said it works on my side but not with my friend, that’s why it doesn’t make sense   Mod list:   xplosives-1.2.0.jar whisperwoods-1.18.2-2.1.0-forge.jar waystones-forge-1.18.2-10.2.2.jar voicechat-forge-1.18.2-2.4.32.jar trashslot-forge-1.18.2-11.0.3.jar towns_and_towers_forge-1.10.0.1+1.18.2.jar torchmaster-18.2.1.jar ToolBelt-1.18.2-1.18.9.jar toms_storage-1.18.2-1.4.4.jar swingthroughgrass-1.18.2-1.9.1.jar strictly_origins_v5.1_1.18.2.jar starlight-1.0.2+forge.546ae87.jar SpartanWeaponry-1.18.2-3.0.4.jar SimpleQuarry-1.18.2-18.2.5.jar simpleplanes-1.18.2-5.2.2.jar secretrooms-1.18.2-1.1.5.jar right-click-harvest-3.2.0+1.18.2-forge.jar REIPluginCompatibilities-forge-8.0.89.jar RoughlyEnough|tems-8.3.681-forge.jar RegionsUnexploredForge-0.4.1_1+1.18.2.jar TerraBlender-forge-1.18.2-1.2.0.126.jar Recall_Potion_v1.0.3-1.18.2.jar Quark-3.2-358.jar PickleTweaks-1.18.2-6.1.2.jar Pehkui-3.7.11+1.18.2-forge.jar Origins-1.18.2-1.4.1.4-unified.jar naturalist-forge-1.1.1-1.18.2.jar mysticaloaktree-1.18.2-1.2.jar selene-1.18.2-1.17.14.jar MysticalAgradditions-1.18.2-5.1.4.jar MysticalAgriculture-1.18.2-5.1.5.jar MultiMine-1.18.7.jar moyai-1.18.2-1.1.4.jar ModernDynamicSurroundings-5.0.0.4.jar lootbeams-1.18.1-release-july1722.jar journeymap-1.18.2-5.9.7-forge.jar ironfurnaces-1.18.2-3.3.3.jar ironchest-1.18.2-13.2.11.jar industrial-foregoing-1.18.2-3.3.1.6-10.jar titanium-1.18.2-3.5.11-45.jar immersive_armors-1.5.6+1.18.2-forge.jar hardcorerevival-forge-1.18.2-8.0.1.jar HammerLib-1.18.2-18.2.16. jar gravestone-1.18.2-1.0.1.jar geckolib-forge-1.18-3.0.57.jar findme-3.0.6-forge.jar faithfulbackrooms3.0.0.7.jar elevatorid-1.18.2-1.8.4.jar EasyMagic-v3.3.0-1.18.2-Forge.jar PuzzlesLib-v3.5.9-1.18.2-Forge.jar easy_villagers-1.18.2-1.0.11.jar easy_mob_farm_1.18.2-7.1.0.jar DynamicTrees-1.18.2-1.0.4.jar dragonseeker-1.1.1-1.18.2.jar iceandfire-2.1.12-1.18.2.jar Cucumber-1.18.2-5.1.5 jar cloth-config-6.5.116-forge.jar citadel-1.11.3-1.18.2.jar chunkloaders-1.2.8a-forge-mc1.18.jar supermartijn642configlib-1.1.8-forge-mc1.18.jar supermartijn642corelib-1.1.17-forge-mc1.18.jar cave_dweller-1.18.2-1.6.4.jar carryon-1.18.2-1.17.1.12.jar caelus-forge-1.18.1-3.0.0.2.jar BotanyTrees-Forge-1.18.2-4.0.13.jar BotanyPots-Forge-1.18.2-8.1.29.jar Bookshelf-Forge-1.18.2-13.3.56.jar balm-3.2.6.jar AutoRegLib-1.7-53.jar ars_nouveau-1.18.2-2.9.0.jar curios-forge-1.18.2-5.0.9.2.jar Patchouli-1.18.2-71.1.jar architectury-4.12.94-forge.jar almostunified-forge-1.18.2-0.3.10.jar [1.18.2] SecurityCraft v1.9.8.jar
    • Thank you for trying, I really appreciate it
    • It worked! Now I can run my modpack without crashes, thanks!
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.