Jump to content

[1.6.4]Forge Src Install Won't Download 1.6.4 Server


SkyeRangerDelta

Recommended Posts

Hi!

I am trying to install the Forge src correctly and when I run the "install.cmd" it does all that stuff like the 42 library download and then gives me an error about not being able to download the "minecraft_server.1.6.4.jar" when backing up the server. I have checked the download links in the fml folder in "install.py" and they are all current (as far as I can tell). I have heard that you can try to manually put the server jar into the correct directory but people say that doesn't work either. How do I get the installer command window to download the correct server thing with no error?

 

Help will be appreciated!

 

Here is the full error text:

"Download of minecraft_server.1.6.4.jar failed hash check, deleting abcf286a14f7aee82e8bf89270433509 ba3145656b1480122bd8759cecd7b7a1

Something failed verifying minecraft files, see log for details.

Decompile exception: 1

Press any key to continue . . ."

BTW: I do not know where the log it is talking about is...

 

I am coding for 1.6.4 because that seems to be the most popular version for modpacks.

  • Like 1

Highlander Propulsion Laboratories

HPL CEO & Chairman - SkyeRangerDelta

 

Planetary Dynamics - Builders of 4th World Planets

USS Aurora Borealis NCC: 91213-C

Link to comment
Share on other sites

1.6.4 is no longer supported. Use 1.8 or at least 1.7.10 (or, IF you are using 1.6.4 for whatever dumb reason, the one you gave is not valid, use the *latest* version).

 

Yes, I know that it is no longer supported. I noted that I wanted to mod for it because it is the most popular for modpacks. I have no interest in modding for 1.8 or 1.7 until i finish this one, there are mods I want to make my mod work together with that only support 1.6.4.

 

Do you still know of any way around this error, or is it impossible to mod for 1.6.4 through this method anymore.

Highlander Propulsion Laboratories

HPL CEO & Chairman - SkyeRangerDelta

 

Planetary Dynamics - Builders of 4th World Planets

USS Aurora Borealis NCC: 91213-C

Link to comment
Share on other sites

The statement that "1.6.4 is the most popular for modpacks" is bs. If you must though, use the forge version for 1.6.4 that uses ForgeGradle.

 

What is ForgeGradle? Where can I get it?

 

And if you look at FTB's and Technic Platform's launchers, most of their most popular modpacks use 1.6.4. I would gladly make my mod for 1.8 since it is the most updated, but none of the mods I want mine to work in cohesion with actually are not 1.8 or 1.7 at that.

Highlander Propulsion Laboratories

HPL CEO & Chairman - SkyeRangerDelta

 

Planetary Dynamics - Builders of 4th World Planets

USS Aurora Borealis NCC: 91213-C

Link to comment
Share on other sites

Gradle is an automated build tool. ForgeGradle is a plugin for gradle that is currently used by forge to provide you with a workspace to make mods in. It decompiles and deobfuscates minecraft and various other things. The src download comes with a sample workspace to set it up, there are instructions available, you should be able to find them.

 

For 1.6.4 there is version #964 which has FG.

 

(Oh and about mods not being updated to 1.7... if they aren't by now you should abandon them, 1.6.4 is 2 years old!)

 

So I found Gradle, and I got my little folder setup where I am putting it all, and now when I build it, I get another error concerning not being able to unpack something. It downloads the first ".zip" and then tries to extract it and then dies. I'll go try to find the error message.

Highlander Propulsion Laboratories

HPL CEO & Chairman - SkyeRangerDelta

 

Planetary Dynamics - Builders of 4th World Planets

USS Aurora Borealis NCC: 91213-C

Link to comment
Share on other sites

  • 2 years later...
  • Guest locked this topic
Guest
This topic is now closed to further replies.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Yes - maybe a conflict/incompatibility with another mod
    • LINK ADA DI BAWAH INI  LINK LOGIN LINK DAFTAR EXTRAWD ADALAH AGEN SLOT , TOGEL DAN BOLA TERBESAR INDONESIA YANG MERUPAKAN SITUS ONLINE PERTAMA YANG MENYEDIAKAN BERBAGAI JENIS PERMAINAN DAN BETTING ONLINE TELENGKAP, SEPERTI PERMAINAN CASINO ONLINE, SLOT ONLINE, TOGEL ONLINE, BOLA ONLINE, DAN MASIH BANYAK JENIS PILIHAN PERMAINAN LAINNYA. PROVIDER TERLENGKAP DAN TERNAMA UNTUK SLOT : PRAGMATIC PLAY-PG SOFT-NOLIMIT CITY-JOKER-PNG SLOT-BIG TIM GAMING-NETENT-TIGER PROVIDDER TERLENGKAP LIVEGAME : PRAGMATIC PLAY - VEGAS LOUNGE - SA GAMING - BG LIVE - EVOLUTION GAMING SWEET BONANZA CANDYLAND, MEGAWHEEL X 500, BACCARAT, ROULETTE PELAYANAN TERBAIK DARI OPERATOR KAMI YANG SIAP MELAYANI ANDA SELAMA 24 JAM
    • LINK ADA DI BAWAH INI  LINK LOGIN LINK DAFTAR EXTRAWD ADALAH AGEN SLOT , TOGEL DAN BOLA TERBESAR INDONESIA YANG MERUPAKAN SITUS ONLINE PERTAMA YANG MENYEDIAKAN BERBAGAI JENIS PERMAINAN DAN BETTING ONLINE TELENGKAP, SEPERTI PERMAINAN CASINO ONLINE, SLOT ONLINE, TOGEL ONLINE, BOLA ONLINE, DAN MASIH BANYAK JENIS PILIHAN 
    • Platform tempat untuk melangsungkan perjudian togel yang paling aman saat ini dan bisa merasakan sensasi hadiah JP jeda tentunya hanya bisa menggunakan situs agen toto togel resmi EXTRAWD . Bersama website agen togel ini anda akan mendapatkan jaminan bahwa hadiah kemenangan pasti dibayar tanpa ada potongan biaya administrasi. Hal terpenting di dalam permainan judi togel melalui situs EXTRAWD adalah wajib memiliki legalitas demi menghindari risiko terhadap hadiah kemenangan. Legalitas tersebut merupakan badan hukum untuk mengawasi terjadinya proses pengundian, sehingga cita-cita untuk mendapatkan JP togel semakin mudah untuk direalisasikan.  
    • I'm having trouble updating my mod Primal Magick to MC1.20.4 on Forge 49.0.48 with JEI 17.3.0.49. I believe I've followed the Forge and JEI instructions correctly, but I'm getting the following exception when I try to run the data generator: java.lang.module.ResolutionException: Modules jei._1._20._4.common.api and jei export package mezz.jei.api.runtime to module primalmagick Full output sample here, and the build.gradle file in question is here. Trying to run the game client results in a different type of exception, but with the same inner error. It looks like I'm getting two separate JEI modules which are interfering with each other, but I'm not sure why that would be. Things I've discovered in my investigations so far: Blowing away my repository and re-cloning from remote does not fix the error, even in combination with nuking my entire gradle cache.  I'm *mostly* sure that it's not just because my workspace is in a bad state. Commenting out line 144 of the build.gradle file, where it specifies the runtime-only deobf dependency of JEI makes the exception not get thrown, but means that JEI is not active in my debug runtime.  While this is a partial workaround for the issue, it leaves me unable to debug any of my JEI integration code, and so is far from ideal. Most maddeningly, running the client and/or data generator from the gradle CLI *also* causes the bug to not reproduce.  Data files get generated, and the client even runs with JEI; it just leaves me unable to trace through the code. I've already reached out to Mezz on the JEI Discord and he's stumped as well.  If I didn't know better, I'd say that one of the "compileOnly" or "runtimeOnly" directives are being executed when they shouldn't be, but why that would be happening now, or happening only when run in Eclipse, is beyond me.  If anyone knows how to resolve this issue, I would be very grateful.  Thank you, and stay safe.
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.