Jump to content

Modded Server not working due to missing mod?


Recommended Posts

Hey there! I have been trying to get my server working for a while now but I keep getting the same error when I try to use TreeCapitator and its core on my 1.7.10 modded server.....

Server Log -

[00:06:37 INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLServer

Tweaker

[00:06:38 INFO]: Using primary tweak class name cpw.mods.fml.common.launcher.FML

ServerTweaker

[00:06:38 INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLServerTweak

er

[00:06:38 INFO]: Forge Mod Loader version 7.10.25.1207 for Minecraft 1.7.10 load

ing

[00:06:39 INFO]: Java is Java HotSpot Client VM, version 1.7.0_80, running o

n Windows 8.1:x86:6.3, installed at C:\Program Files (x86)\Java\jre7

[00:06:40 INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLInject

ionAndSortingTweaker

[00:06:40 INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfT

weaker

[00:06:40 INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAn

dSortingTweaker

[00:06:40 INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAn

dSortingTweaker

[00:06:40 INFO]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLP

luginWrapper

[00:06:42 INFO]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLP

luginWrapper

[00:06:42 INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLDeobfTweake

r

[00:06:43 INFO]: Loading tweak class name cpw.mods.fml.common.launcher.TerminalT

weaker

[00:06:43 INFO]: Calling tweak class cpw.mods.fml.common.launcher.TerminalTweake

r

[00:06:43 INFO]: Launching wrapped minecraft {net.minecraft.server.MinecraftServ

er}

[00:06:53 INFO]: Starting minecraft server version 1.7.10

[00:06:53 INFO]: Attempting early MinecraftForge initialization

[00:06:53 INFO]: MinecraftForge v10.13.0.1207 Initialized

[00:06:53 INFO]: Replaced 182 ore recipies

[00:06:53 INFO]: Completed early MinecraftForge initialization

[00:06:53 INFO]: Searching C:\Users\Artres\Desktop\Desktop Shortcuts\Servers\Ren

aissancePlus Gaming\mods for mods

[00:06:55 INFO]: Forge Mod Loader has identified 9 mods to load

[00:06:55 ERROR]: The mod bspkrsCore (bspkrsCore) requires mod versions [Forge@[

10.13.2.1291,)] to be available

[00:06:55 ERROR]: Encountered an unexpected exception

cpw.mods.fml.common.MissingModsException

        at cpw.mods.fml.common.Loader.sortModList(Loader.java:244) ~[Loader.clas

s:git-Cauldron-MCPC-Plus-1.7.10-1.1207.01.198]

        at cpw.mods.fml.common.Loader.loadMods(Loader.java:472) ~[Loader.class:g

it-Cauldron-MCPC-Plus-1.7.10-1.1207.01.198]

        at cpw.mods.fml.server.FMLServerHandler.beginServerLoading(FMLServerHand

ler.java:87) ~[FMLServerHandler.class:git-Cauldron-MCPC-Plus-1.7.10-1.1207.01.19

8]

        at cpw.mods.fml.common.FMLCommonHandler.onServerStart(FMLCommonHandler.j

ava:317) ~[FMLCommonHandler.class:git-Cauldron-MCPC-Plus-1.7.10-1.1207.01.198]

        at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(Dedicated

Server.java:170) ~[lt.class:?]

        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:620) [M

inecraftServer.class:?]

        at java.lang.Thread.run(Unknown Source) [?:1.7.0_80]

[00:06:55 ERROR]: This crash report has been saved to: C:\Users\Showab\Desktop\D

esktop Shortcuts\Servers\RenaissancePlus Gaming\.\crash-reports\crash-2

015-07-31_00.06.55-server.txt

[00:06:55 WARN]: Can't revert to frozen GameData state without freezing first.

[00:06:55 INFO]: Applying holder lookups

[00:06:55 INFO]: Holder lookups applied

[00:06:55 INFO]: The state engine was in incorrect state CONSTRUCTING and forced

into state SERVER_STOPPED. Errors may have been discarded.

 

  Click a button to stop the server . . .

 

Crash Report -

---- Minecraft Crash Report ----

// Hey, that tickles! Hehehe!

 

Time: 30/07/15 23:50

Description: Exception in server tick loop

 

cpw.mods.fml.common.MissingModsException

at cpw.mods.fml.common.Loader.sortModList(Loader.java:244)

at cpw.mods.fml.common.Loader.loadMods(Loader.java:472)

at cpw.mods.fml.server.FMLServerHandler.beginServerLoading(FMLServerHandler.java:87)

at cpw.mods.fml.common.FMLCommonHandler.onServerStart(FMLCommonHandler.java:317)

at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:170)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:620)

at java.lang.Thread.run(Unknown Source)

 

 

A detailed walkthrough of the error, its code path and all known details is as follows:

---------------------------------------------------------------------------------------

 

-- System Details --

Details:

Minecraft Version: 1.7.10

Operating System: Windows 8.1 (x86) version 6.3

Java Version: 1.7.0_80, Oracle Corporation

Java VM Version: Java HotSpot Client VM (mixed mode), Oracle Corporation

Memory: 826619152 bytes (788 MB) / 1037959168 bytes (989 MB) up to 1037959168 bytes (989 MB)

JVM Flags: 2 total; -Xmx1G -Xms1G

AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used

IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0

FML: MCP v9.05 FML v7.10.25.1207 Minecraft Forge 10.13.0.1207 9 mods loaded, 9 mods active

mcp{9.05} [Minecraft Coder Pack] (minecraft.jar) Unloaded

FML{7.10.25.1207} [Forge Mod Loader] (cauldron-1.7.10-1.1207.01.198-server.jar) Unloaded

Forge{10.13.0.1207} [Minecraft Forge] (cauldron-1.7.10-1.1207.01.198-server.jar) Unloaded

bspkrsCore{6.16} [bspkrsCore] ([1.7.10]bspkrsCore-universal-6.16.jar) Unloaded

Treecapitator{1.7.10} [Treecapitator] ([1.7.10]Treecapitator-universal-2.0.4.jar) Unloaded

antiqueatlas{4.2.4-1.7.10} [Antique Atlas] (antiqueatlas-4.2.4-1.7.10.jar) Unloaded

customnpcs{1.7.10b} [CustomNpcs] (CustomNPCs_1.7.10b.jar) Unloaded

GraveStone{2.12.3} [GraveStone] (GraveStone-2.12.4.jar) Unloaded

Railcraft{9.6.1.0} [Railcraft] (Railcraft_1.7.10-9.6.1.0.jar) Unloaded

Profiler Position: N/A (disabled)

Is Modded: Definitely; Server brand changed to 'cauldron,craftbukkit,mcpc,fml,forge'

Type: Dedicated Server (map_server.txt)

 

Any help on this matter would be much appreciated.

This is how the world ends, not with a bang but a whimper.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Ok yeah I think this might be where the problem starts. For starters, I think you can get rid of your RecipeType impl and make it a static constant instead. I'm not 100% sure this will fix it but it's posssible. RuneInscribingRecipe public class RuneInscribingRecipe implements Recipe<SimpleContainer> { public static final RecipeType<RuneInscribingRecipe> RECIPE_TYPE = new RecipeType<>(){}; // .... @Override public RecipeType<?> getType() { return RECIPE_TYPE; } // .... } RuneInscriberMenu private Optional<RecipeHolder<RuneInscribingRecipe>> getCurrentRecipe() { SimpleContainer inventory = new SimpleContainer(2); inventory.setItem(BASE_INPUT_SLOT, this.inventory.getStackInSlot(BASE_INPUT_SLOT)); inventory.setItem(TEMPLATE_INPUT_SLOT, this.inventory.getStackInSlot(TEMPLATE_INPUT_SLOT)); List<RecipeHolder<RuneInscribingRecipe>> list = this.blockEntity.getLevel().getRecipeManager().getRecipesFor(RuneInscribingRecipe.RECIPE_TYPE, inventory, this.blockEntity.getLevel()); if (list.isEmpty()) { return Optional.empty(); } return Optional.of(list.get(0)); }   Also, this here is a little suspicious where you're getting the `this.inventory.getStackInSlot` calls. I'd try and make sure those are what you expect they are with either a Debug line in IDE or print statement SimpleContainer inventory = new SimpleContainer(2); inventory.setItem(BASE_INPUT_SLOT, this.inventory.getStackInSlot(BASE_INPUT_SLOT)); System.out.printf("CHECKING BASE INPUT OF RECIPE: %s\n", this.inventory.getStackInSlot(BASE_INPUT_SLOT)); inventory.setItem(TEMPLATE_INPUT_SLOT, this.inventory.getStackInSlot(TEMPLATE_INPUT_SLOT)); System.out.printf("CHECKING TEMPLATE INPUT OF RECIPE: %s\n", this.inventory.getStackInSlot(TEMPLATE_INPUT_SLOT)); ^ See what the result of those print statements are, make sure they're right
    • Upon testing again after adding them, the game still doesn't crash however the resource packs are still unfortunately broken.
    • Hi! Can someone please point me to the correct FAQ or place? I'm not able do DuckDuckGo myself out of this one. As you can hopefully see, chunks are not rendered. I run a forge server, fresh install on a linux VM. Curseforge on the Win11 client with Embeddium, Oculus and Unbound shader. No mods. Forge 47.2.23 on server & client.  No errors, no crashes, no apparent CPU or RAM issues with the VM. This screenshot was captured while creative, but the same happens when flying in survival. Waiting (floating) for a few minutes sooner or (often) later, lets the missing chunks appear. Usually takes 5-10 minutes.  When on a local game, the chunks appear slowly, but they do appear without pause.   This must be something simple, obvious, but I can't find the correct "search words" to find my way out. "Chunks not loading / rendering" didn't help. Browsing several forums neither. 
    • This is the Forge forums. We only support Forge here. Read the FAQ
    • 1.The game doesn't crash, everything seems normal, but when i insert the designated items into the block entity, the result item does not show up. 2.Yes, I'm using a custom menu, here's the source code:  
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.