Jump to content

java.lang.IllegalArgumentException when trying to make first entity (1.8)


King_Arthur_III

Recommended Posts

I am trying to make my first entity ( 1.8 )  but when I run the client I get this message:

 

"java.lang.IllegalArgumentException: Can not set static com.kingarthur.elementalswords.ClientProxy field com.kingarthur.elementalswords.ClientProxy.modInstance to com.kingarthur.elementalswords.Main"

 

This is the relevant code in my client proxy:

 

public class ClientProxy extends CommonProxy {

 

@Instance(Main.MODID)

public static ClientProxy modInstance;

 

@Override

public void preInit(FMLPreInitializationEvent e) {

super.preInit(e);

}

 

@Override

public void init(FMLInitializationEvent e) {

super.init(e);

ModEntities.mainRegistry();

ItemRenderRegister.registerItemRenderer();

}

 

And this is the code in my ModEntities file:

 

public class ModEntities {

 

public static void mainRegistry() {

registerEntity();

}

 

public static void registerEntity() {

 

                createEntity(EntityFireGuardian.class, "Guardian of Fire", 0xF20505, 0xD8DE31);

}

 

public static void createEntity(Class entityClass, String entityName, int solidColor, int spotColor) {

 

                int randomId = EntityRegistry.findGlobalUniqueEntityId();

 

EntityRegistry.registerGlobalEntityID(entityClass, entityName, randomId);

 

EntityRegistry.registerModEntity(entityClass, entityName, randomId,

                ClientProxy.modInstance, 80, 3, true);

 

createEgg(randomId, solidColor, spotColor);

}

 

private static void createEgg(int randomId, int solidColor, int spotColor) {

 

                EntityList.entityEggs.put(Integer.valueOf(randomId), new EntityList.EntityEggInfo(

                randomId, solidColor, spotColor));

}

}

Link to comment
Share on other sites

The field with the

@Instance

annotation needs to be the same type as your main mod class (the one with the

@Mod

annotation), since it holds the instance of that class.

 

Why are you doing this in

ClientProxy

? Entities need to be registered on both sides.

 

There's no reason to use global entity IDs (

EntityRegistry.registerGlobalEntityID

) or manually add spawn eggs in 1.8, if you need a spawn egg just call the

EntityRegistry.registerModEntity

overload with the two extra

int

parameters (the background and foreground colours of the egg).

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • What MC version? What's the IP? Are any mods needed to be able to join?
    • Thank you for your answer ! Unfortunatly i have the same problem when i use setPos() public static int movingfunction(CommandContext<CommandSourceStack> context){ CommandSourceStack source = context.getSource(); if (!(source.getEntity() instanceof ServerPlayer)) { return 0; } ServerPlayer player = (ServerPlayer ) source.getEntity(); double moveSpeed = 0.5; for (int i =0; i<10000;i++) { LOGGER.info("running for the {} time", i); double x = player.getX() + player.getViewVector(1.0f).x * moveSpeed; double y = player.getY(); double z = player.getZ() + player.getViewVector(1.0f).z * moveSpeed ; Vec3 movementVec = new Vec3(x, y, z); LOGGER.info("x ={} y ={} z ={}", x, y, z); player.setPos( movementVec); } return 1; } With the logs i can see that x and z are increasing but once again my player is not moving. is there a function to use to sync the server and the client ? I also tried to use LocalPlayer instead of ServerPlayer but my code would stop when i got the object. Also i will change a bit the main topic but is there a way to similate key press ? i found KeyBinding.setKeyBindState on others post but it look like there is no more KeyBinding in 1.20   I found this code : KeyMapping.click(Minecraft.getInstance().options.keyUp.getKey()); But it doesn't seems to work   And i found this one : Minecraft.getInstance().options.keyUp.setDown(true); wich works but doesn't exactly do what i want , it doesn't release the key so for exemple i can't make him run. Minecraft.getInstance().options.keyUp.setDown(true); Minecraft.getInstance().options.keyUp.setDown(false); Minecraft.getInstance().options.keyUp.setDown(true); doesn't make him run
    • Add crash-reports with sites like https://paste.ee/ Maybe an issue with blur, essentials or cumulus_menus
    • Add the crash-report or latest.log (logs-folder) with sites like https://paste.ee/ and paste the link to it here  
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.