Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[SOLVED] Mod version compatibility


Recommended Posts

Hey guys, so I get my mod workin as expected and i'm glad ^^

I use gradle to build it and it works great though somethin 's botherin me :

I built it for 1.8.9 and 1.7.10; but now I see some cool mods aren't available for 1.8.9 but only for 1.8.1...

So I guess there is a way to publish a version for 1.8.x (without building for each version) currently my gradle build file contains somethin like the line below for 1.8.9 :

    version = "1.8.9-"

can i just change that to :

    version = "1.8.*" ?

sounds too good to be true..

Link to comment
Share on other sites

Forge doesn't exist for 1.8.1, only 1.8, 1.8.8 and 1.8.9.


Unless your mod only touches a minimal amount of the Minecraft codebase, it likely won't be compatible with any version of Minecraft other than the one it was built for. You can't build a single project against multiple versions of Minecraft, though you can maintain a separate copy of the project for each version (as branches of a single repository or as completely separate repositories) and write a script to build them all at once.

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

There are multiple layers of version compatibility, and sorting them out may be more trouble than it's worth, but...


While your mod will almost always need to run in a forge client or server for which it was compiled, it might be possible for one version of a client to log into and play nice with another version of the server. That means that you might be able to compile your mod in for each related MC version (1.8, 1.8.8, 1.8.9), put the right mod on each client and on each server, and then have some gap between server and its clients (use a 1.8.9 client to join a 1.8 world). I think that higher clients are more likely to play with lower servers than vice-versa, but I'm not sure.


My mods don't get spread widely enough to bother. I play my 1.7.10 world-server with a 1.7.10 client, and they all have the 1.7.10 versions of my mods; likewise 1.8. I'll skip 1.8.8 and 1.8.9 (and probably 1.9) to do 1.9.2. But that's just me.


The debugger is a powerful and necessary tool in any IDE, so learn how to use it. You'll be able to tell us more and get better help here if you investigate your runtime problems in the debugger before posting.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.