Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Cant use player.getItemInUse() Server side


elementalvenom
 Share

Recommended Posts

Hey so I'm able to use player.getItemInUse() when I run it in single player. But when I connect to a server the server crashes when the code is run. This code is only allowed to run server side and I saw another forum post that said this cant be run server side. If I cant then how do I get what item the player has out?

Link to comment
Share on other sites

In 1.8.9,

EntityPlayer#getItemInUse

is client-only. You'll need to use reflection to get the value of

EntityPlayer#itemInUse

instead.

 

In 1.9,

EntityLivingBase#getActiveItemStack

(the replacement for

EntityPlayer#getItemInUse

) is usable from both sides.

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.