Jump to content

[1.9] Strange crash at startup when loading back into custom dimension


sblectric

Recommended Posts

When I save and exit, then come back into my dimension, before the world loads, I am greeted with the following crash:

http://pastebin.com/31NxFvwx

The crash seems to happen when the world tries to check unloaded chunks for lava for whatever reason. If I delete the dimension folder and reload it, it works perfectly fine. What is even happening?

Link to comment
Share on other sites

I ended up fixing this crash by adding the following to my WorldProvider class:

@Override
public void onPlayerAdded(EntityPlayerMP p) {
int cx = ((int)p.posX) >> 4;
int cz = ((int)p.posZ) >> 4;
for(int x = cx - 1; x <= cx + 1; x++) {
	for(int z = cz - 1; z <= cz + 1; z++) {
		this.worldObj.getChunkProvider().provideChunk(x, z);
	}
}
}

which basically preloads a 3x3 chunk area centered on the player before the above crash could happen. It's a bit strange, but it works.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.