Jump to content

[1.9]Custom Potion Icons have issues when they are rendered on the HUD


The_Fireplace

Recommended Posts

Hey guys, the new feature with 1.9 where potion icons are rendered on the HUD doesn't work quite right with my current code for adding a potion icon, and I was hoping someone could help me come up with a fix. So, the icon works correctly when rendered in the inventory, as always.

T9frXqy.png

Now, the issue is that when it is rendered on the HUD, some of the vanilla icons are rendered as whatever happens to be at the position on my texture, because my icons' texture is still bound, rather than the vanilla one.

SX0VdUR.png

 

My code that gets it to render is in this file.

If I helped please press the Thank You button.

 

Check out my mods at http://www.curse.com/users/The_Fireplace/projects

Link to comment
Share on other sites

Hey guys, the new feature with 1.9 where potion icons are rendered on the HUD doesn't work quite right with my current code for adding a potion icon, and I was hoping someone could help me come up with a fix. So, the icon works correctly when rendered in the inventory, as always.

T9frXqy.png

Now, the issue is that when it is rendered on the HUD, some of the vanilla icons are rendered as whatever happens to be at the position on my texture, because my icons' texture is still bound, rather than the vanilla one.

SX0VdUR.png

 

My code that gets it to render is in this file.

If I helped please press the Thank You button.

 

Check out my mods at http://www.curse.com/users/The_Fireplace/projects

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.