Jump to content

mysql connector no driver error


Recommended Posts

I've been trying to fix this for a while but its not working.

Using forge version:


I have tried the following:

[*]Added the jdbc connector to my classpath

[*]Added it to my Mods folder

[*]Added it to my Libs folder

[*]Using Class.forName(com.jdbc.mysql.Driver) before connecting


Forge shows that it is loading the connector but when used it returns


No suitable driver found for jdbc:mysql://localhost:3306/users


However if I run the same command through main() it works without a problem. At this point im wondering if its a problem with forge?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.