Jump to content

[1.10.2][SOLVED]Creating a method for spawning particles on the server side


TheMattyBoy

Recommended Posts

I want to spawn particles based on a given item stack (

EnumParticleTypes.ITEM_CRACK

/

EnumParticleTypes.BLOCK_CRACK

), trouble is, particles are client sided and the places in the code where I want the effects are all server sided. I created a method to spawn them so I didn't have to type out the code over and over, but that doesn't help the fact that it's the wrong side. I'm aware of

DataParameter

s, although since I need a given

ItemStack

and they only take booleans, ints, floats etc. (right?), I don't think they will be much use.

 

Here's the method so far, please help improve upon it :)

@SideOnly(Side.CLIENT)
public void spawnEatParticles(ItemStack stack) {
if(stack.getItem() instanceof ItemBlock) {
	Block block = ((ItemBlock)stack.getItem()).getBlock();
	for(int i = 0; i < 20; i++) {
		this.worldObj.spawnParticle(EnumParticleTypes.BLOCK_CRACK, this.headPosition.getX() + (double)this.rand.nextFloat() - (this.getPosition().getX() - this.posX) - 0.5, this.headPosition.getY() + (double)this.rand.nextFloat() - (this.getPosition().getY() - this.posY), this.headPosition.getZ() + (double)this.rand.nextFloat() - (this.getPosition().getZ() - this.posZ) - 0.5, (this.rand.nextInt(6) - 3) / 5, 0.1, (this.rand.nextInt(6) - 3) / 5, new int[] {Block.getIdFromBlock(block)});
	}
}
else {
	for(int i = 0; i < 20; i++) {
		this.worldObj.spawnParticle(EnumParticleTypes.ITEM_CRACK, this.headPosition.getX() + (double)this.rand.nextFloat() - (this.getPosition().getX() - this.posX) - 0.5, this.headPosition.getY() + (double)this.rand.nextFloat() - (this.getPosition().getY() - this.posY), this.headPosition.getZ() + (double)this.rand.nextFloat() - (this.getPosition().getZ() - this.posZ) - 0.5, (this.rand.nextInt(6) - 3) / 5, 0.1, (this.rand.nextInt(6) - 3) / 5, new int[] {Item.getIdFromItem(stack.getItem()), stack.getMetadata()});
	}
}
}

IGN: matte006

Played Minecraft since summer 2011.

Modding is my life now.

Please check out my mod :)

https://minecraft.curseforge.com/projects/gadgets-n-goodies-mod?gameCategorySlug=mc-mods&projectID=230028

Link to comment
Share on other sites

If you want code running on the server to trigger something on the client (or vice versa), you need to send a packet.

 

In this case, vanilla already has a method to do this for you:

WorldServer#spawnParticle

.

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Another Minecraft Launcher https://multimc.org/#Download or https://atlauncher.com/downloads
    • Remove these mods and combine OptiFine HD U I6 with Forge 47.2.18 Start with Optifine - without any other mods - if this works, add the mods one by one or in groups until you find the mod, conflicting with Optifine
    • Ok yeah I think this might be where the problem starts. For starters, I think you can get rid of your RecipeType impl and make it a static constant instead. I'm not 100% sure this will fix it but it's posssible. RuneInscribingRecipe public class RuneInscribingRecipe implements Recipe<SimpleContainer> { public static final RecipeType<RuneInscribingRecipe> RECIPE_TYPE = new RecipeType<>(){}; // .... @Override public RecipeType<?> getType() { return RECIPE_TYPE; } // .... } RuneInscriberMenu private Optional<RecipeHolder<RuneInscribingRecipe>> getCurrentRecipe() { SimpleContainer inventory = new SimpleContainer(2); inventory.setItem(BASE_INPUT_SLOT, this.inventory.getStackInSlot(BASE_INPUT_SLOT)); inventory.setItem(TEMPLATE_INPUT_SLOT, this.inventory.getStackInSlot(TEMPLATE_INPUT_SLOT)); List<RecipeHolder<RuneInscribingRecipe>> list = this.blockEntity.getLevel().getRecipeManager().getRecipesFor(RuneInscribingRecipe.RECIPE_TYPE, inventory, this.blockEntity.getLevel()); if (list.isEmpty()) { return Optional.empty(); } return Optional.of(list.get(0)); }   Also, this here is a little suspicious where you're getting the `this.inventory.getStackInSlot` calls. I'd try and make sure those are what you expect they are with either a Debug line in IDE or print statement SimpleContainer inventory = new SimpleContainer(2); inventory.setItem(BASE_INPUT_SLOT, this.inventory.getStackInSlot(BASE_INPUT_SLOT)); System.out.printf("CHECKING BASE INPUT OF RECIPE: %s\n", this.inventory.getStackInSlot(BASE_INPUT_SLOT)); inventory.setItem(TEMPLATE_INPUT_SLOT, this.inventory.getStackInSlot(TEMPLATE_INPUT_SLOT)); System.out.printf("CHECKING TEMPLATE INPUT OF RECIPE: %s\n", this.inventory.getStackInSlot(TEMPLATE_INPUT_SLOT)); ^ See what the result of those print statements are, make sure they're right
    • Upon testing again after adding them, the game still doesn't crash however the resource packs are still unfortunately broken.
    • Hi! Can someone please point me to the correct FAQ or place? I'm not able do DuckDuckGo myself out of this one. As you can hopefully see, chunks are not rendered. I run a forge server, fresh install on a linux VM. Curseforge on the Win11 client with Embeddium, Oculus and Unbound shader. No mods. Forge 47.2.23 on server & client.  No errors, no crashes, no apparent CPU or RAM issues with the VM. This screenshot was captured while creative, but the same happens when flying in survival. Waiting (floating) for a few minutes sooner or (often) later, lets the missing chunks appear. Usually takes 5-10 minutes.  When on a local game, the chunks appear slowly, but they do appear without pause.   This must be something simple, obvious, but I can't find the correct "search words" to find my way out. "Chunks not loading / rendering" didn't help. Browsing several forums neither. 
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.