Jump to content

[1.11.2] [SOLVED] Required-after keyword no longer working


Recommended Posts



I'm currently working on my mod and ran now into this problem:



The FML Log says this:

[16:14:46] [main/INFO] [FML/]: Forge Mod Loader version for Minecraft 1.11.2 loading


My code in Constants.java:

public static final String FORGE_VERSION		 = "required-after:Forge@[,);";


My code in the main class:

@Mod(modid = Constants.MOD_ID, 
version = Constants.VERSION,
dependencies = Constants.FORGE_VERSION,
acceptedMinecraftVersions = Constants.MC_VERSION,
useMetadata = false,
canBeDeactivated = false,
guiFactory = Constants.GUI_FACTORY_LOCATION,
updateJSON = Constants.UPDATE)


Cause I can't remember something has changed there in 1.11 I'm posting this here. In 1.10.2 it worked quite fine for me. ;)


Tested with:

  • Minecraft 1.11.2
  • Forge Mod Loader version
  • Java 8 JRE & JDK Update 112 64bit
  • Eclipse Neon IDE

I also executed these commands gradlew cleanCache setupDecompWorkspace --refresh-dependencies eclipse just in case that my Forge MDK Installation for eclipse was broken, but this didn't resolve the problem.


Would be nice to have this working again. ;)


Thx in advance.



Developer of Primeval Forest.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.