Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

NoSuchField error using 3.3.7.136


Jdi35
 Share

Recommended Posts

i've been having a bit of trouble with forge while updating my mods(specifically EE 1.4.6.4). Tried swaping/removing a few mods like mdiyo's 4096 fix, modloader MP(which is in there because of bucketcraft(?) and dynamic elevators.), and forge itself with a few different versions of each, that didn't work sadly.

 

Currently i am using MultiMC with my load order as such:

 

MCForge 3.3.7.136

MLMP 1.2.5 v1

4096-fix v 4.0 mc 1.2.5

CCC 0.5.3

NEI 1.2.2.4

InvTweaks 1.41B-1.2.4

Rei's minimap v 3.1

Better enchanting v 127

 

 

when i load up minecraft, it does go to the main screen, but when i load a world, it crashes and gives me this error log:

 

 

44 mods loaded

Minecraft Forge 3.3.7.136

FML v2.2.48.135

Forge Mod Loader version 2.2.48.135 for Minecraft 1.2.5

mod_CodeChickenCore : Available (minecraft.jar)

mod_4096Fix : Available (minecraft.jar)

mod_BE : Available (minecraft.jar)

mod_InvTweaks : Available (minecraft.jar)

mod_MinecraftForge : Available (minecraft.jar)

mod_ModLoaderMp : Available (minecraft.jar)

mod_NotEnoughItems : Available (minecraft.jar)

mod_ReiMinimap : Available (minecraft.jar)

mod_IC2 : Available (industrialcraft-2-client_1.95b.jar)

mod_IC2AdvancedMachines : Available (AdvancedMachines_4.1_client.zip)

mod_BucketCraft : Available (BucketCraft_1-2-5.zip)

mod_AdditionalBuildcraftObjects : Available (buildcraft-C-additionalbuildcraftobjects-latest.zip)

mod_BuildCraftCore : Available (buildcraft-client-A-core-3.1.5.zip)

mod_BuildCraftBuilders : Available (buildcraft-client-B-builders-3.1.5.zip)

mod_BuildCraftEnergy : Available (buildcraft-client-B-energy-3.1.5.zip)

mod_BuildCraftFactory : Available (buildcraft-client-B-factory-3.1.5.zip)

mod_BuildCraftTransport : Available (buildcraft-client-B-transport-3.1.5.zip)

mod_BuildCraftSilicon : Available (buildcraft-client-C-silicon-3.1.5.zip)

mod_AdditionalPipes : Available (buildcraft-client-DA-additionalpipes-3.1.0.zip)

mod_CraftingTableIII : Available (CraftingTableIIIB1.8.zip)

mod_Elevator : Available (DynamicElevators_Client(v1.5.1).zip)

mod_EE : Available (EE2ClientV1.4.6.4.jar)

mod_EnderStorage : Available (EnderStorage-Client 1.1.1.zip)

mod_Forestry : Available (forestry-client-A-1.4.6.2.jar)

mod_BuildCraftZFP : Available (forestry-client-A-1.4.6.2.jar)

mod_IC2NuclearControl : Available (IC2NuclearControl_client_v1.1.8.zip)

mod_PigbearLaser : Available (Laser Mod 1.5.zip)

mod_LogisticsPipes : Available (LogisticsPipes-BC3-0.2.5B.zip)

mod_CompactSolars : Available (mod_compactsolars-client-2.2.0.5.zip)

mod_IronChest : Available (mod_ironchests-client-3.3.1.21.zip)

mod_PortalGun : Available (portalgun)

mod_Railcraft : Available (Railcraft_Client_5.2.4.zip)

mod_RedPowerControl : Available (RedPowerControl-2.0pr5b2.zip)

mod_RedPowerCore : Available (RedPowerCore-2.0pr5b2.zip)

mod_RedPowerLighting : Available (RedPowerLighting-2.0pr5b2.zip)

mod_RedPowerLogic : Available (RedPowerLogic-2.0pr5b2.zip)

mod_RedPowerMachine : Available (RedPowerMachine-2.0pr5b2.zip)

mod_RedPowerWiring : Available (RedPowerWiring-2.0pr5b2.zip)

mod_RedPowerWorld : Available (RedPowerWorld-2.0pr5b2.zip)

mod_SneakyPipes : Available (SneakyPipes-0.1.1.zip)

mod_WirelessRedstoneCore : Available (WR-CBE Core-Client 1.2.1.zip)

mod_WirelessRedstoneAddons : Available (WR-CBE Addons-Client 1.2.1.zip)

mod_WirelessRedstoneRedPower : Available (WR-CBE RedPower-Client 1.2.1.1.zip)

mod_ThaumCraft : Available (ThaumCraft2.1.6c.zip)

 

 

      Minecraft has crashed!     

      ----------------------     

 

Minecraft has stopped running because it encountered a problem.

 

 

 

 

--- BEGIN ERROR REPORT fdfcd7e5 --------

Generated 6/20/12 5:51 PM

 

Minecraft: Minecraft 1.2.5

OS: Windows 7 (amd64) version 6.1

Java: 1.6.0_31, Sun Microsystems Inc.

VM: Java HotSpot 64-Bit Server VM (mixed mode), Sun Microsystems Inc.

LWJGL: 2.8.3

OpenGL: ATI Radeon HD 5670 version 4.2.11631 Compatibility Profile Context, ATI Technologies Inc.

 

java.lang.NoSuchFieldError: isDefaultTexture

at forge.ForgeHooksClient.beforeBlockRender(ForgeHooksClient.java:264)

at ct.a(WorldRenderer.java:210)

at l.a(RenderGlobal.java:1482)

at lr.a(EntityRenderer.java:1070)

at lr.b(EntityRenderer.java:907)

at net.minecraft.client.Minecraft.x(Minecraft.java:873)

at net.minecraft.client.Minecraft.run(Minecraft.java:750)

at java.lang.Thread.run(Unknown Source)

--- END ERROR REPORT 187a0f4 ----------

 

 

Is there a possible fix for this?

 

EDIT: Disregard, i found a fix for forge version 3.3.7.135 here:

http://www.minecraftforum.net/topic/1106178-125-equivalent-exchange-2-v1464/

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • Is this the client or the server not starting? Show the debug.log.
    • Hello, I am trying to play Minecraft with a friend on a server but I need forge for it and it isn't starting. It just says this mesage: Memory Heap: 64 / 2048 MB (3,1%)   OffHeap: 36 MB It also doesn't tell me any bug reports. Please tell me how to fix it.
    • Don't be silly. A script kiddie is capable of basic copy pasting. I can't even do that. However, one more thing to add. How do you connect the registered FlowingFluidBlock, to your actual FluidBlock.class? I wasn't aware that you can actually customize the FlowingFluidBlock RegistryObject(or any other RegistryObject in that regard). Do it like that, and take info from the vanilla FluidBlocks how to build your FluidBlock.class accordingly: Change that...         public static final RegistryObject<FlowingFluidBlock> OIL_BLOCK = MatLibRegister.BLOCKS.register("crudeoil",             () -> new FlowingFluidBlock(() -> MatLibFluidOil.OIL_FLUID.get(), AbstractBlock.Properties.create(MATOIL)                     .doesNotBlockMovement().hardnessAndResistance(100f).noDrops()));           ...to that...         public static final RegistryObject<MyCustomFluidBlock> OIL_BLOCK = MatLibRegister.BLOCKS.register("crudeoil",             () -> new MyCustomFluidBlock(() -> MatLibFluidOil.OIL_FLUID.get(), AbstractBlock.Properties.create(MATOIL)                     .doesNotBlockMovement().hardnessAndResistance(100f).noDrops()));   ...and name your FluidBlock MyCustomFluidBlock.class. As far as I understand you do not want to extend to FlowableFluidBlock, but to FlowableFluid. I've yet to understand why, because in the past a fluid block, was still a block. It seems like it is now an "in between" thingy, or no longer a block at all. I hope someone of the wizards can spread some wisdom on that? And if it's just to ease the tinkering...👍 Edit: If someone wants more learning material, I'd recommend the TechReborn FlowableFluid.class, and their actual Fluid.class(Fabric only, so lots of adaptions needed, but good for getting an idea of structure), or PneumaticCraft(Forge). Notice they seem to be on 1.16.5 or even 1.17.1, but the code is compiling fine and dandy with minor adaptions(for 1.17.1 only?). You'd quickly find traces on how to "adapt" by highlighting methods/fields/etc., and open the declaration. Trouble starts really if references aren't public, because then you have to @Override in a custom.class. Which is something I've yet to learn as well. In the past, for 1.7(yes, that's 2013), it looked something like that:
    • just the error: https://pastebin.com/8duvMgPg debug.log: https://gist.github.com/RVOtakuMike/4e84ac2b090408a9dd8defeddbc96c24 latest.log: https://gist.github.com/RVOtakuMike/44f1dc0e7a52696c530136d51a619dfd World does load in single player when i transferred it over, though it said there were errors in the datapacks?? Then made me click "Safe mode". I wonder what i did wrong... any help is appreciated. Ive run minecraft (forge) servers for years and never had issues with save/load. (Though I am new to 1.16)
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.