Jump to content

[Solved] Updating TileEntitySpecialRenderer


GiannivanMarion

Recommended Posts

Over the last month I've been making a new machine with works fine except one thing. My block has a TileEntitySpecial renderer which I use to display the item with is made after the block has crafting and the item witch has gone into it, but on servers It does not update the item for all players. This problem also also occurring when i use BuildCraft-pipes. is there a way to update my block(maybe from the TileEntity?).

Thanks in advance!

Link to comment
Share on other sites

You need to call markBlockForUpdate for the block on the server side whenever the tile entity changes in a way that the client needs to know about. You also need to call OnInventoryChanged of the tile entity to ensure that the changed state gets saved to disk.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.