Jump to content

When I try To install forge 1.8.9 It doesnt go into the launcher

Recommended Posts

I download straight from the website open it and get the screen that says instal client instal server or Extract and i click instal client and it says:  successfully installed client profile forge for version forge 1.8.9 - - 1.8.9 Into launcher. But when i go into the launcher its not there ive cleared my cache and tried again and nothing is hapening and its still not in launcher



P.s with 1.10.2 i try to load just normal lucky block and it crashes thats why im trying to use 1.8.9



Screenshot (1).png

Edited by Phoenix_legacy
Link to comment
Share on other sites

You should be able to edit or create a profile in the launcher and select Forge 1.8.9- as the version.

Edited by Choonster

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

  • 3 years later...
This topic is now closed to further replies.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.