Jump to content

[1.12] Changes to KeyBinding causing a problem


BatHeart
 Share

Recommended Posts

I have defined several keys for use by a mod, by defining each as a KeyBinding, and registering each by ClientRegistry.registerKeyBinding().

This has been working OK up to 1.11.2, but has hit a problem when I updated to 1.12.

Minecraft crashes when entering Options => Controls, and I can see why:

I have provided a custom category for all of the bound keys, so that they will all appear grouped under a heading for my mod in the Options => Controls screen. What has happened in 1.12 is that several changes have been made to the net.minecraft.client.settings.KeyBinding.class.  

There is a private static final Map attribute called field_193627_d and this is filled with a set of key category descriptions, each mapped to an integer.

E.g. field_193627_d.put("key.categories.inventory", Integer.valueOf(3));

Of course, my custom key category doesn't appear here, and there doesn't seem to be a way I can add it.

This wouldn't be a problem, except there is now a compareTo() method on KeyBinding, which is called (indirectly) from net.minecraft.client.gui.GuiKeyBindingList - and this fails with a NullPointerException because my custom category is unrecognised.

 

I have worked around this, by assigning my key bindings to one of the existing categories, but this isn't ideal, as I would like to be able to group my mod's keys together like I did previously, and of course anybody else who writes a mod that binds keys will probably have to put theirs into the same group, which begins to get messy.

 

I wonder whether anyone has any suggestions as to how to improve the key binding mechanism in 1.12? 

Link to comment
Share on other sites

The announcement box at the top of this forum says: 

Quote

Forge for 1.12   06/10/17

Forge for 1.12 is still in early development. Do not use it yet, crashes and bugs are to be expected.

So to answer your question, no, there isn't currently a fix. Be patient, forge for 1.12 has only just come out, let them fix all the bugs first, it's probably already on the todo list.

  • Like 1
Link to comment
Share on other sites

Thanks, Alpvax.

I was well aware that it's very early days for the 1.12 builds. I don't think this is a bug in Forge, and that's certainly not why I posted. I noticed that work had been going on in the Mojang code in this area which has affected the way we have to do things, and thought I'd bring that to people's attention, along with asking if anyone had any suggestions.

I actually have a workaround which is fine. 

Better will be some adaptation that allows everyone to specify their own 'keybinding categories' - but I didn't think it was the kind of thing anyone would look into unless someone mentioned the change that had occurred. That's all.

Link to comment
Share on other sites

12 minutes ago, Verdelet said:

What's the workaround? I get the same crash but I have no custom category for keybinds. I just started a new world and want to up the mouse sensitivity.

This might not be applicable to your situation, then, but since my crash is caused by binding keys to an undefined category, I just assigned them to a category which is defined, but is not currently used for anything: "key.categories.ui".

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I created an SOUL_JAR Item that has been registered for each mob like - mod:soul_jar_minecraft_cow etc.. but it all has different registry names, i have a model file name soul_jar.json and i want to know how to bind each of those items to this class (When mod iterates through all of vanilla mobs and registering items for them).   I didn't found any info about it because all of info is outdated, and forge docs is complicated asf (i wish there would be more examples) i also used AI but it showing me only outdated info, but theres some code where i registering my item and trying to bind it to model ->   public static void register(IEventBus eventBus){ ITEMS.register(eventBus); Set<ResourceLocation> entityKeyList = ForgeRegistries.ENTITY_TYPES.getKeys(); for (ResourceLocation k : entityKeyList) { EntityType<?> entityType = ForgeRegistries.ENTITY_TYPES.getValue(k); if (!entityType.getCategory().equals(MobCategory.MISC)) { RegistryObject<Item> SOUL_JAR = ITEMS.register("soul_jar" + '_' + k.toString().replace(':', '_').replace('.', '_'), () -> new JarItem(new Item.Properties().rarity(Rarity.RARE).tab(ModTabs.MAGICAL_OBSESSION_JARS), entityType)); if (Thread.currentThread().getThreadGroup() == SidedThreadGroups.CLIENT) { ItemModelShaper itemModelShaper = Minecraft.getInstance().getItemRenderer().getItemModelShaper(); itemModelShaper.register(SOUL_JAR.get().asItem(), new ModelResourceLocation("item.soul_jar", "inventory")); } } } } I also have more questions like how to iterate through all other mods mobs also, or render mob inside of a jar in inventory, but i will try to figure it out.
    • I looked into OctoEconomyAPI and saw that it was a JAR api for fabric. This means you have a fabric mod in your mods folder. I downloaded your mod folder and wasted 2 solid hours creating a Python script to try to find the faulty mod, and eventually just gave up. I suggest you create two installations with half or the mods in each, find which one doesn't launch, cut that one in half, and repeat until you find the fabric mod. Investigué OctoEconomyAPI y vi que era una API JAR para fabric. Esto significa que tienes un mod de Fabric en tu carpeta de mods. Descargué su carpeta de mods y desperdicié 2 horas completas creando un script de Python para tratar de encontrar el mod defectuoso, y finalmente me di por vencido. Le sugiero que cree dos instalaciones con la mitad o las modificaciones en cada una, encuentre cuál no se inicia, córtela por la mitad y repita hasta que encuentre la modificación Fabric.   (The Python script I made is here): (El script de Python que hice está aquí):  
    • I've got it to work now. Instead of using the texture manager I used the Render System:   RenderSystem.setShaderTexture(0, new ResourceLocation("mcaquests", "textures/item/questbook.png"));  
    • Hello ive been having the same issue over Curse Forge's auto modding or when i use manual modding. The error seems to be within either Oculus or Rubidium. Im using 1.19 with the latest 1.19 forge + 1.19 compatible Oculus and Rubidium. Just in case the versions i am using; Oculus - oculus-1.4.3a Rubidium - rubidium-0.6.3 Note: I tried removing the two and add Optifine and it opens without a problem. I didnt use all 3 together to get this error im talking tho, i know they are not compatible with optifine dont worry. Logs Debug The actual error code im getting on start-up is ''1'' and nothing else on the pop up box. I have tried finding the jar files on the internet and insert them on my own but that didnt go too far.
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.