Jump to content

Can't allocate ram to server!


jayman340

Recommended Posts

So, I have a start.bat and it's proper, I have a max of 5 GB and a min of 4, so when I run it it runs the forge-1.10.2-12.18.3.2316-universal.jar, and I guess that jar opens up a default, white java minecraft server console. It runs with ~200+ mb of ram, never exceeding 500, and I really need to dedicated 5 gb of ram. I have the -Xmx5G and -Xms4G and as far as I can tell I everything is proper - I've hosted a lot of servers before on this computer and some modded, too, and I've never encountered this issue. Please help! It's for the Craft of the Titans modpack, by the way.

Edited by jayman340
Link to comment
Share on other sites

8 hours ago, diesieben07 said:

Please explain where you got these numbers from.

And post the FML log.

So, the black console window appears but then the default Minecraft server interface thing appears it it only says using like 300mb (93% free) and I am setting the -Xms to atleast 3GB so I Don't know why It's only using 300mb, and I will post the log soon

Link to comment
Share on other sites

I use the following for windows.

 


java -XX:-UseGCOverheadLimit -Dfml.debugClassPatchManager=true -Dfml.debugRegistryEntries=true ^
-XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy ^
-Xmn128M -Xms1G -Xss1M -XX:MaxPermSize=256M ^
-Djava.net.preferIPv4Stack=true -Dfml.queryResult=confirm ^
-jar forge-version.jar nogui

 

Try that first, if you need more ram for your server increase 1G to the highest you are willing to spare. My megapacks on Curse have no problems running in 3G environments. -Xms3G is the setting. On Java 8 and higher -XX:MaxPermSize=### can be omitted. But if included Java will ignore it for you. The other stuff is for memory management and better error reports.

  • Like 1
Link to comment
Share on other sites

3 minutes ago, kreezxil said:

I use the following for windows.

 


java -XX:-UseGCOverheadLimit -Dfml.debugClassPatchManager=true -Dfml.debugRegistryEntries=true ^
-XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy ^
-Xmn128M -Xms1G -Xss1M -XX:MaxPermSize=256M ^
-Djava.net.preferIPv4Stack=true -Dfml.queryResult=confirm ^
-jar forge-version.jar nogui

 

Try that first, if you need more ram for your server increase 1G to the highest you are willing to spare. My megapacks on Curse have no problems running in 3G environments. -Xms3G is the setting. On Java 8 and higher -XX:MaxPermSize=### can be omitted. But if included Java will ignore it for you. The other stuff is for memory management and better error reports.

Thanks so much!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.