Jump to content

Forge works on mine, but LAN says "need FML/Forge"


Marianne

Recommended Posts

First, let me start with I'm disabled, so sometimes I need things explained a little further...  :) thanks in advance.


I downloaded Forge 1.12.1 on my son's computer after MUCH begging on his part,  for mods.  We eventually mimicked everything on his, onto mine, so we could play together.  He updated his Launcher and Forge to 12.2.  I did the same.

 

Now, I can play single player, and he can join ME on LAN, but every time I attempt to JOIN HIM ON LAN, I get the following error message, that I need FML/Forge on my computer to play.

 

I'm SO confused as to why it plays on mine, but not the opposite... 

 

-Yes, I'm sure I've got forge. 

-Yes, I do choose forge in the profile list

-Yes, it is the same version of forge as he's playing on

-Yes, our mods/versions are identical. 

-Yes, we ONLY downloaded forge from THIS site.  From the recommended file.

-Yes, I have tried reverting back to Forge 1.12.1 on BOTH sides.  This doesn't change it.


I have also moved optifine out of our Mods folder, that didn't work.

 

Here's the only major difference...  When we started this, I will admit, I had NO clue what I was doing.  I followed all instructions, and yet still, forge would NOT download.  (I didn't realize that I hadn't run vanilla by itself yet, at that point) so in an effort to quell the frustrations of a special needs child mid-tantrum, I tried downloading Forge as server vs client.  That worked...  it didn't load the game, of course, so I forged on, until I figured out the issue.  I don't know if that did something to his laptop, or changed something..

 

Can anyone please help? 

 

 

We have the following mods:

Forge 1.12.2

Lucraft Core 1.12.1

Baby Animals 1.11-2

Block Armor 1.12-2.4.8

Hide Names 1.12-1.4

IChunUtil 4.1.0

Lucky Block 1-12_V7-5-0

Metamorph 1.12

Speedster heroes 1.12

 

 

Thank you,

Marianne

Edited by Marianne
Link to comment
Share on other sites

Here are the 2 logs. 

 

Mine:

[15:11:25] [Client thread/INFO]: Setting user: Sandling_All_Day
[15:11:30] [Client thread/INFO]: LWJGL Version: 2.9.4
[15:11:31] [Client thread/INFO]: Reloading ResourceManager: Default
[15:11:45] [Sound Library Loader/INFO]: Starting up SoundSystem...
[15:11:45] [Thread-3/INFO]: Initializing LWJGL OpenAL
[15:11:45] [Thread-3/INFO]: (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)
[15:11:45] [Thread-3/INFO]: OpenAL initialized.
[15:11:46] [Sound Library Loader/INFO]: Sound engine started
[15:12:00] [Client thread/INFO]: Created: 1024x512 textures-atlas
[15:12:07] [Client thread/INFO]: Narrator library for x86 successfully loaded
[15:22:46] [Client thread/INFO]: Connecting to 10.0.0.4, 52743
 

 

His:

 

 

Link to comment
Share on other sites

Sorry, had to log into the site on his computer... here's his log:

 

[15:11:19] [main/INFO]: Setting user: SquarePower6149
[15:11:26] [main/INFO]: LWJGL Version: 2.9.4
[15:11:38] [main/INFO]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:mercurius_updater, FMLFileResourcePack:Baby Animals Model Swapper, FMLFileResourcePack:Block Armor, FMLFileResourcePack:HideNames, FMLFileResourcePack:Lucky Block, FMLFileResourcePack:Lucraft: Core, FMLFileResourcePack:Metamorph, FMLFileResourcePack:SpeedsterHeroes, Faithful 1.12.2-rv4.zip
[15:14:23] [Sound Library Loader/INFO]: Starting up SoundSystem...
[15:14:24] [Thread-6/INFO]: Initializing LWJGL OpenAL
[15:14:24] [Thread-6/INFO]: (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)
[15:14:24] [Thread-6/INFO]: OpenAL initialized.
[15:14:24] [Sound Library Loader/INFO]: Sound engine started
[15:14:34] [main/INFO]: Created: 1024x1024 textures-atlas
[15:14:46] [main/INFO]: Narrator library for x64 successfully loaded
[15:20:35] [Server thread/INFO]: Starting integrated minecraft server version 1.12.2
[15:20:35] [Server thread/INFO]: Generating keypair
[15:20:38] [Server thread/INFO]: Loaded 502 advancements
[15:20:38] [Server thread/INFO]: Preparing start region for level 0
[15:20:40] [Server thread/INFO]: Preparing spawn area: 0%
[15:20:41] [Server thread/INFO]: Preparing spawn area: 38%
[15:20:42] [Server thread/INFO]: Preparing spawn area: 90%
[15:20:42] [Server thread/INFO]: Changing view distance to 12, from 10
[15:20:46] [Server thread/INFO]: SquarePower6149[local:E:33490dfa] logged in with entity id 313 at (-216.09155448908058, 66.0, 282.38165350349476)
[15:20:46] [Server thread/INFO]: SquarePower6149 joined the game
[15:20:49] [Server thread/INFO]: Saving and pausing game...
[15:20:49] [Server thread/INFO]: Saving chunks for level 'Faithful'/overworld
[15:20:49] [Server thread/INFO]: Saving chunks for level 'Faithful'/the_nether
[15:20:49] [Server thread/INFO]: Saving chunks for level 'Faithful'/the_end
[15:20:49] [Server thread/WARN]: Can't keep up! Did the system time change, or is the server overloaded? Running 3334ms behind, skipping 66 tick(s)
[15:20:52] [main/INFO]: [CHAT] §8[§fLucraft: Core§8] §7Your version is up to date!
[15:20:52] [main/INFO]: [CHAT] §6[§eSpeedsterHeroes§6] §7New version is available!
[15:20:52] [main/INFO]: [CHAT] §2[§aDownload§2] §71.12-1.2.1
[15:20:53] [main/INFO]: Loaded 147 advancements
[15:21:00] [Server thread/INFO]: Saving and pausing game...
[15:21:00] [Server thread/INFO]: Saving chunks for level 'Faithful'/overworld
[15:21:01] [Server thread/INFO]: Saving chunks for level 'Faithful'/the_nether
[15:21:01] [Server thread/INFO]: Saving chunks for level 'Faithful'/the_end
[15:21:04] [main/INFO]: Using default channel type
[15:21:04] [main/INFO]: Started on 52743
[15:21:04] [main/INFO]: [CHAT] Local game hosted on port 52743
 

Link to comment
Share on other sites

Thanks Diesieben07, for your initial response.  After a lot of digging, reading crash/output logs (not much I understood, but some of It was helpful...) I figured out my issue.  If you hadn't posted, I wouldn't have delved into the logs in the first place, and my fix wouldn't have been so obvious. 

Since it's a pet peeve of mine when people come for help, and simply update "I figured it out" and leave it at that (where there remains a possibility that others may have similar issues in the future, I will share my mistake/fix.

________

For some reason, Forge didn't update on Minecraft, so we were on 2 different updates (him 1.12.2 & myself on 1.12.1) . I re-updated Forge, ran Vanilla Minecraft's 1.12.2 update in a new world, , then manually updated Forge via Minecraft's  update list.   Viola.  I was able to connect to the HIS world via LAN.

 

TYVM again.  I really appreciate all of you who take your time to help ppl like me (especially those like me) who aren't a BIT knowledgeable about code/mods/logs or anything close to the internal workings of a computer.  I'm learning SO much, but there's still so much that confuses me!  Apparently my 12yr old is right... "Mom, you're a noob"

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • !warudo.isClientSide() still not a gui not an error just a simple message [06:44:39] [Render thread/WARN] [minecraft/MenuScreens]: Failed to create screen for menu type: mercmod:gem_polishing_menu Not a hint of what the problem is  this silent simple error dont tell much about the problem the code i made don't show errors highlighted   in mi old code 1.19.4 i launch the menu part from client side  but now i recheck the video and kapenjoe does it server side         
    • Hey, for getting your model to show up in Forge, double-check the way you've set up your model registration. Sometimes, it's just a tiny mix-up with where you've put your model file or maybe missing the right event to hook it up. Also, peek at your @Mod.EventBusSubscriber setup; it's gotta be listening in the right place. And don't forget to place your model file in the exact right spot with the correct naming. If in doubt, the Forge docs or forum threads can be super helpful.
    • Since flying mobs like bees and flies aren't affected, the problem likely lies with how ground mob AI interacts with the server environment. Checking the server logs, as you've done, is a good step. You might want to look for errors related to mob AI or pathfinding. Consider removing or updating mods one at a time to isolate the issue. Additionally, ensure your server's performance isn't being overly taxed by the modpack, as this can sometimes lead to unusual behavior with entity AI.
    • I'm having the same issue rn. Hostile mobs wont move until attacked but peaceful land mobs wont move at all. If it swims or flies its unaffected until it touches blocks.
    • Im trying to register model for my item but it doesn't works. First I Created a class where i declared all my items.   public class ModItems { public static final List<Item> ITEMS = new ArrayList<Item>(); public static final Item MY_ITEM = new MyItemClass(); } Then I created the MyItemClass where i describe my item. public class MyItemClass extends Item { public MyItemClass() { this.setRegistryName("my_item"); this.setUnlocalizedName("my_item"); this.setCreativeTab(CreativeTabs.COMBAT); ModItems.ITEMS.add(this); } } And The i created a class where i was trying register the model and where i registered my item @Mod.EventBusSubscriber public class EventsHandler { @SubscribeEvent public void registerItems(RegistryEvent.Register<Item> event) { event.getRegistry().register(new MyItemClass()); } @SubscribeEvent @SideOnly(Side.CLIENT) public static void onRegistryModel(ModelRegistryEvent event) { registryModel(new MyItemClass()); } @SideOnly(Side.CLIENT) private static void registryModel(Item item) { final ResourceLocation regName = item.getRegistryName(); final ModelResourceLocation mr1 = new ModelResourceLocation(regName, "inventory"); ModelBakery.registerItemVariants(item, mr1); ModelLoader.setCustomModelResourceLocation(item, 0, mr1); } } The registerItems method just registers my items. Then im catching ModelRegistryEvent to register my model. And in the last private method im registering models. In The game iitem still has purple-black cube instead of texture. I dont forgot to create the models\item folder and my_item.json file im sorry if this text has a grammatical errors. My english is very low  
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.