Jump to content

[1.12]ConfigChangedEvents not firing


Vatuu

Recommended Posts

And here we go with a different problem.

So I'm using the Annotation-based Configuration to create my... well, config.
However, several things are simply not working.

 

  1. ConfigChangedEvent.OnConfigChange and ConfigChangedEvent.PostConfigChange are not firing at all. (And yes, the event handler are subscribed and registered).
  2. All Config field names are lowercase, no matter the capitalisation on the annotation.
  3. Buttons that cycle through an enum-list of strings cannot have a changed display string and instead rely on the enum's name.
  4. This is more of a question than anything, but is it possible to render a texture inside of the mod config GUI?

 

Help is appreciated, and sorry to annoy you with my issues again.

 

Best regards, Vatuu.

Edited by Vatuu
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.