Jump to content

Custom Structures only Half-generating?


mrburgerUS

Recommended Posts

Hello everyone,

 

I am in the process of creating a Beta-Remix mod which re adds Beta terrain with modern features. The code for normal generation has been complete, but after starting on remixing the Temples (aka Scattered Features), I have hit a snag. Temples are generated from a single point that can be found using /locate, but on the negative X or Z before that NOTHING generates, so I get "half structures". Initially I thought it could possibly be chunk boundaries, but as the picture shows, the area of no-generation is fully within a chunk. My source code can be viewed at: https://github.com/mrburger/Beta-Plus, specifically in the https://github.com/mrburger/Beta-Plus/tree/master/src/main/java/com/mrburgerUS/betaplus/beta/feature/structure folder.

 

Thank you for your help!

World Gen.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.