Jump to content

Forge for 1.11.2 not downloading correctly.


Recommended Posts

Hello, I’ve been having a problem regarding the download of forge for the last few days and was wondering if you guys could help. After looking through the internet, I still can’t find a fix for my problem. When I get to the part of downloading where you choose Client, Server or Extract, I always choose Client, which has worked for versions 1.7.10 and 1.10.2. However, all of a sudden I get an error about the Mercurius Updater. At first I thought it was a problem with the 1.11.2, so I went back and tried to download 1.10.2 again, receiving the same error. I’ve tried countless times replacing the updater, but nothing seems to work. When I checking the mercurius box, it will fully download. When I try and play this version, I’m greeted with an error message saying that the version is not correct and Minecraft never boots up. I’m new to all this mod stuff along with the “advanced language” and I’m really frustrated. Please help. 


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.