Jump to content

[1.12.2] Creating a block color handler- only half-working?


Asanmi

Recommended Posts

I'm trying to add a colorMultiplier to a block and its itemblock, pulling the color from a cut-down EnumDyeColor for it, because I don't want to make textures and blockstates for every single color variant. The textures all work, everything works except I can't get the actual color to change for either.

 

The particles are properly colored when breaking the blocks so I know it's registered. A chat output on block activation shows BlockColors itself is returning the correct value, so I know the code for that is correct. So I can't figure out where I've gone wrong, or whether I'm missing an obvious thing. Does anything immediately pop out to anyone?

 

Color registration here.

 

BlockState JSON for the block here.

 

Model JSON for the block here.

Edited by Asanmi
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.