Jump to content

PlayerEvent.LoadFromFile serialization issues


jredfox
 Share

Recommended Posts

during PlayerEvent.LoadFromFile I am trying to make the player update it's variables through a new entire nbt from another file. During this test of changing the dimension and position seems to all sync fine on server side but, if player use to be in the nether it still thinks the sky is the nether when going to either overworld/end dimension. This code is eventually for a vanilla bug fix when swaping worlds between two players and eventually another bug fix


I am confused since the data on the client shouldn't even be there till after the load from file event the connection of the player is still null so what the heck isn't syncing? 


Test 1:
have player in vanilla nether somewhere
use this code during PlayerEvent.LoadFromFile event

notice player is at right pos and dimension but, the sky isn't right

NBTTagCompound nbt = new NBTTagCompound();
nbt.setInteger("Dimension",1);
NBTTagList pos = new NBTTagList();
pos.appendTag(new NBTTagDouble(0));
pos.appendTag(new NBTTagDouble(67));
pos.appendTag(new NBTTagDouble(0));
nbt.setTag("Pos",pos);
e.getEntityPlayer().readFromNBT(nbt);

 

Edited by jredfox
Link to comment
Share on other sites

5 hours ago, diesieben07 said:

Do you even know what this event does? It is not the correct place to do this.

it's when the player is suppose to be serialized from the disk and the client shouldn't be getting any data till after this. This is the right event I have verified when this is firing.

So I need to know what data isn't synced/needs to be changed since when I change it the client thinks it's still there

Edited by jredfox
Link to comment
Share on other sites

55 minutes ago, diesieben07 said:

No, it is not the right event.

But trying to explain things to you is like arguing with a brick wall.

then what is? You wanted me fixing uuidfixer to another event this is the right event to fix it on. So yes I need this event to serialize the player with the corrected data. Doing it on construction Is too early I will surely get overridden

Edited by jredfox
Link to comment
Share on other sites

I don't know how the heck the player serialization event isn't the right event for calling player.readFromNBT(). I made a test and the above code produces the issue described don't know why that is since my event serialized it forcibly to be those coords and that dimension.

Edited by jredfox
Link to comment
Share on other sites

anybody know why the client is rendering the nether. I am trying to override data on de- serialization on server side but, client an't syncing and the data shouldn't get to the client till this event is done what am I missing here?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I created an SOUL_JAR Item that has been registered for each mob like - mod:soul_jar_minecraft_cow etc.. but it all has different registry names, i have a model file name soul_jar.json and i want to know how to bind each of those items to this class (When mod iterates through all of vanilla mobs and registering items for them).   I didn't found any info about it because all of info is outdated, and forge docs is complicated asf (i wish there would be more examples) i also used AI but it showing me only outdated info, but theres some code where i registering my item and trying to bind it to model ->   public static void register(IEventBus eventBus){ ITEMS.register(eventBus); Set<ResourceLocation> entityKeyList = ForgeRegistries.ENTITY_TYPES.getKeys(); for (ResourceLocation k : entityKeyList) { EntityType<?> entityType = ForgeRegistries.ENTITY_TYPES.getValue(k); if (!entityType.getCategory().equals(MobCategory.MISC)) { RegistryObject<Item> SOUL_JAR = ITEMS.register("soul_jar" + '_' + k.toString().replace(':', '_').replace('.', '_'), () -> new JarItem(new Item.Properties().rarity(Rarity.RARE).tab(ModTabs.MAGICAL_OBSESSION_JARS), entityType)); if (Thread.currentThread().getThreadGroup() == SidedThreadGroups.CLIENT) { ItemModelShaper itemModelShaper = Minecraft.getInstance().getItemRenderer().getItemModelShaper(); itemModelShaper.register(SOUL_JAR.get().asItem(), new ModelResourceLocation("item.soul_jar", "inventory")); } } } } I also have more questions like how to iterate through all other mods mobs also, or render mob inside of a jar in inventory, but i will try to figure it out.
    • I looked into OctoEconomyAPI and saw that it was a JAR api for fabric. This means you have a fabric mod in your mods folder. I downloaded your mod folder and wasted 2 solid hours creating a Python script to try to find the faulty mod, and eventually just gave up. I suggest you create two installations with half or the mods in each, find which one doesn't launch, cut that one in half, and repeat until you find the fabric mod. Investigué OctoEconomyAPI y vi que era una API JAR para fabric. Esto significa que tienes un mod de Fabric en tu carpeta de mods. Descargué su carpeta de mods y desperdicié 2 horas completas creando un script de Python para tratar de encontrar el mod defectuoso, y finalmente me di por vencido. Le sugiero que cree dos instalaciones con la mitad o las modificaciones en cada una, encuentre cuál no se inicia, córtela por la mitad y repita hasta que encuentre la modificación Fabric.   (The Python script I made is here): (El script de Python que hice está aquí):  
    • I've got it to work now. Instead of using the texture manager I used the Render System:   RenderSystem.setShaderTexture(0, new ResourceLocation("mcaquests", "textures/item/questbook.png"));  
    • Hello ive been having the same issue over Curse Forge's auto modding or when i use manual modding. The error seems to be within either Oculus or Rubidium. Im using 1.19 with the latest 1.19 forge + 1.19 compatible Oculus and Rubidium. Just in case the versions i am using; Oculus - oculus-1.4.3a Rubidium - rubidium-0.6.3 Note: I tried removing the two and add Optifine and it opens without a problem. I didnt use all 3 together to get this error im talking tho, i know they are not compatible with optifine dont worry. Logs Debug The actual error code im getting on start-up is ''1'' and nothing else on the pop up box. I have tried finding the jar files on the internet and insert them on my own but that didnt go too far.
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.