Jump to content

[Solved]read/write NBT methods not running


BURN447

Recommended Posts

I'm not sure what's happening, but my TileEntity is not calling the readFromNBT or writeToNBT functions. My best guess is that I have it registered incorrectly, but I'm not sure where or how to correct it.

 

https://github.com/BURN447/DartcraftReloaded/blob/master/src/main/java/burn447/dartcraftReloaded/tileEntity/TileEntityInfuser.java

 

edit: I'm honestly not 100% sure why it works now, but it does. I ended up implementing ITileEntityProvider in my TileEntityInfuser class and returned a new TileEntityInfuser in the createNewTileEntity

Edited by BURN447
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.