Jump to content

[Solved] [1.12.2] Light sources not working (Custom Dimension)


guyWITH2forks

Recommended Posts

Hello, 

So I am currently in the proccess of creating my own dimension. I have the dimension generating properly, and the custom blocks spawning as they should.

The issue I seem to have run into is that no light sources work at all. Its as if the light level is permanently zero.

I tried looking into my World Provider for something I missed in the light brightness table calculations.

 

If you have an idea of what this could be, as a result of this being a common problem please let me know!

If its me missing something specific, then I can post code as needed.

Any help would be fantastic as this is the last problem to fix!

Thanks

 

[Update]

I solved this issue by removing the overridden "generateLightBrightnessTable" method. I guess the game doesn't want me to tamper with it.

Edited by guyWITH2forks
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.