Jump to content

[1.12.2] New to Forge and getting NoSuchField or NoSuchMethod errors with every reference to net.minecraft resources


Felix_2000

Recommended Posts

I'm new to Forge and I just installed the client and downloaded the MDK. I ran the installer and selected "client." When I run an installation with the forge version, it seems to run fine, and the "mods" button does appear. I made sure to use the same version for both the MDK and the client, which was also the latest recommended version. But every time I call something from net.minecraft (such as Blocks.DIRT), it crashes with a NoSuchField exception. At first I modified the example mod a little, but finally I just downloaded it, put it in IntelliJ, and compiled it into a .jar with no modifications. It still gives me this error as soon as it loads:

Caused by: java.lang.NoSuchFieldError: DIRT
    at com.example.examplemod.ExampleMod.init(ExampleMod.java:29)
...

I would think this would be caused by a version mismatch, but again, I did make double sure that the versions were the same. If nobody has an answer to why this is happening, could someone at least tell me a better way to get started to avoid this? I seem to be the only one with this problem, so maybe I'm approaching it wrong from the start.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.