Jump to content

Vanilla Forge - My Personal Server kicks me


Recommended Posts

Thanks in advance to whoever helps me with my problem


Here's the stuff: I always hosted vanilla minecraft servers, which worked fine from my laptop for aproximately 10 people. I'm attempting to enter the realm of Forge, and tried to host a pure vanilla Forge (no mods loaded); whenever I do, I can enter the server, play for between 1 and 3 minutes, and then get kicked due to an error:


[17:57:15] [Netty Server IO #2/ERROR] [FML]: NetworkDispatcher exception java.io.IOException: An existing connection was forcibly closed by the remote host

at sun.nio.ch.SocketDispatcher.read0(Native Method) ~[?:1.8.0_201]

at sun.nio.ch.SocketDispatcher.read(Unknown Source) ~[?:1.8.0_201]

at sun.nio.ch.IOUtil.readIntoNativeBuffer(Unknown Source) ~[?:1.8.0_201]

at sun.nio.ch.IOUtil.read(Unknown Source) ~[?:1.8.0_201]

at sun.nio.ch.SocketChannelImpl.read(Unknown Source) ~[?:1.8.0_201]

at io.netty.buffer.PooledUnsafeDirectByteBuf.setBytes(PooledUnsafeDirectByteBuf.java:288) ~[PooledUnsafeDirectByteBuf.class:?]

at io.netty.buffer.AbstractByteBuf.writeBytes(AbstractByteBuf.java:1100) ~[AbstractByteBuf.class:?]

at io.netty.channel.socket.nio.NioSocketChannel.doReadBytes(NioSocketChannel.java:372) ~[NioSocketChannel.class:?]

at io.netty.channel.nio.AbstractNioByteChannel$NioByteUnsafe.read(AbstractNioByteChannel.java:123) [AbstractNioByteChannel$NioByteUnsafe.class:?]

at io.netty.channel.nio.NioEventLoop.processSelectedKey(NioEventLoop.java:624) [NioEventLoop.class:?]

at io.netty.channel.nio.NioEventLoop.processSelectedKeysOptimized(NioEventLoop.java:559) [NioEventLoop.class:?]

at io.netty.channel.nio.NioEventLoop.processSelectedKeys(NioEventLoop.java:476) [NioEventLoop.class:?]

at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:438) [NioEventLoop.class:?]

at io.netty.util.concurrent.SingleThreadEventExecutor$5.run(SingleThreadEventExecutor.java:858) [SingleThreadEventExecutor$5.class:?]

at java.lang.Thread.run(Unknown Source) [?:1.8.0_201]


I am using the Forge Server version, for Minecraft 1.12.2


Any type of help is apprecieated. Thanks!


EDIT: I can host Vanilla Minecraft servers fine, tried 1.12.2 and 1.14.3


Edited by TheSirYeti
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.