Jump to content

Current Forge not working for mods?


Recommended Posts

I tried to download these mods here:




And everything seemed to be running smoothly, that is until I was confronted with my game stating:


'File Jurassicraft-1.12.2-2.1.23.jar is for an older version of Forge and can not be loaded' 

As well as the same line, but with LLibrary

So, I tried to download bunches of different versions of Forge, from the most recent to recommended, 1.12. and 1.11, and still nothing. Am I doing something wrong here? 



Screen Shot 2019-07-24 at 10.52.03 PM.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.