Jump to content

Need org.apache.commons.collections4 library in mod


Recommended Posts

My mod uses a library that depends on the org.apache.commons.collections4 library. When I run Minecraft, I get the error: java.lang.NoClassDefFoundError: org/apache/commons/collections4/map/CaseInsensitiveMap

The mod works fine in IntelliJ, it only has this problem when I export it. I tried including the library the same way I added the first library, but it didn't work. I read online that this is a choice by Forge because a couple of the org.apache.commons libraries are included in Minecraft already, but not the one I need. Does anyone have a solution to this?

Edited by MC_CatMaster
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.