Jump to content

Forge 1.15.2 crashes after clicking "Play"


vCrili

Recommended Posts

So, i updated my Forge version 1.15.2 and stills crashing, i don't know why this happens, i have the latest Java version.

 

Here's the debug.log

 

[17abr2020 12:31:01.845] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--username, vCrili, --version, 1.15.2-forge-31.1.0, --gameDir, C:\Users\pipol\AppData\Roaming\.minecraft, --assetsDir, C:\Users\pipol\AppData\Roaming\.minecraft\assets, --assetIndex, 1.15, --uuid, 5d21f01bcde44f9a94b5c0b25d7dc313, --accessToken, ????????, --userType, mojang, --versionType, release, --launchTarget, fmlclient, --fml.forgeVersion, 31.1.0, --fml.mcVersion, 1.15.2, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20200122.131323]
[17abr2020 12:31:01.849] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 5.0.0-milestone.4+67+b1a340b starting: java version 1.8.0_251 by Oracle Corporation
[17abr2020 12:31:01.871] [main/DEBUG] [cpw.mods.modlauncher.LaunchServiceHandler/MODLAUNCHER]: Found launch services [minecraft,testharness,fmlclient,fmlserver]
[17abr2020 12:31:01.883] [main/DEBUG] [cpw.mods.modlauncher.NameMappingServiceHandler/MODLAUNCHER]: Found naming services : []
[17abr2020 12:31:01.895] [main/DEBUG] [cpw.mods.modlauncher.LaunchPluginHandler/MODLAUNCHER]: Found launch plugins: [eventbus,object_holder_definalize,runtime_enum_extender,accesstransformer,capability_inject_definalize,runtimedistcleaner]
[17abr2020 12:31:01.907] [main/DEBUG] [cpw.mods.modlauncher.TransformationServicesHandler/MODLAUNCHER]: Discovering transformation services
[17abr2020 12:31:01.972] [main/DEBUG] [cpw.mods.modlauncher.TransformationServicesHandler/MODLAUNCHER]: Found additional transformation services from discovery services: [C:\Users\pipol\AppData\Roaming\.minecraft\mods\DynamicSurroundings-1.12.2-3.6.1.0.jar, C:\Users\pipol\AppData\Roaming\.minecraft\mods\VanillaFix-1.0.10-150.jar]
[17abr2020 12:31:02.049] [main/DEBUG] [cpw.mods.modlauncher.TransformationServicesHandler/MODLAUNCHER]: Found transformer services : [mixin,fml]
[17abr2020 12:31:02.049] [main/DEBUG] [cpw.mods.modlauncher.TransformationServicesHandler/MODLAUNCHER]: Transformation services loading
[17abr2020 12:31:02.050] [main/DEBUG] [cpw.mods.modlauncher.TransformationServiceDecorator/MODLAUNCHER]: Loading service mixin
[17abr2020 12:31:02.050] [main/DEBUG] [cpw.mods.modlauncher.TransformationServiceDecorator/MODLAUNCHER]: Loaded service mixin
[17abr2020 12:31:02.050] [main/DEBUG] [cpw.mods.modlauncher.TransformationServiceDecorator/MODLAUNCHER]: Loading service fml
[17abr2020 12:31:02.050] [main/DEBUG] [net.minecraftforge.fml.loading.FMLServiceProvider/]: Injecting tracing printstreams for STDOUT/STDERR.
[17abr2020 12:31:02.053] [main/DEBUG] [net.minecraftforge.fml.loading.LauncherVersion/CORE]: Found FMLLauncher version 31.1
[17abr2020 12:31:02.053] [main/DEBUG] [net.minecraftforge.fml.loading.FMLLoader/CORE]: FML 31.1 loading
[17abr2020 12:31:02.053] [main/DEBUG] [net.minecraftforge.fml.loading.FMLLoader/CORE]: FML found ModLauncher version : 5.0.0-milestone.4+67+b1a340b
[17abr2020 12:31:02.054] [main/DEBUG] [net.minecraftforge.fml.loading.FMLLoader/CORE]: Initializing modjar URL handler
[17abr2020 12:31:02.054] [main/DEBUG] [net.minecraftforge.fml.loading.FMLLoader/CORE]: FML found AccessTransformer version : 2.0.0-milestone.1+47+4a08f17
[17abr2020 12:31:02.055] [main/DEBUG] [net.minecraftforge.fml.loading.FMLLoader/CORE]: FML found EventBus version : 2.0.0-milestone.1+57+de55078
[17abr2020 12:31:02.055] [main/DEBUG] [net.minecraftforge.fml.loading.FMLLoader/CORE]: Found Runtime Dist Cleaner
[17abr2020 12:31:02.059] [main/DEBUG] [net.minecraftforge.fml.loading.FMLLoader/CORE]: FML found CoreMod version : 2.0.0-milestone.1+5+5b32e68
[17abr2020 12:31:02.059] [main/DEBUG] [net.minecraftforge.fml.loading.FMLLoader/CORE]: Found ForgeSPI package implementation version 2.0.0-milestone.1+7+a2eaa64
[17abr2020 12:31:02.060] [main/DEBUG] [net.minecraftforge.fml.loading.FMLLoader/CORE]: Found ForgeSPI package specification 3
[17abr2020 12:31:02.385] [main/INFO] [net.minecraftforge.fml.loading.FixSSL/CORE]: Added Lets Encrypt root certificates as additional trust
[17abr2020 12:31:02.385] [main/DEBUG] [cpw.mods.modlauncher.TransformationServiceDecorator/MODLAUNCHER]: Loaded service fml
[17abr2020 12:31:02.387] [main/DEBUG] [cpw.mods.modlauncher.TransformationServicesHandler/MODLAUNCHER]: Configuring option handling for services
[17abr2020 12:31:02.396] [main/DEBUG] [cpw.mods.modlauncher.TransformationServicesHandler/MODLAUNCHER]: Transformation services initializing
[17abr2020 12:31:02.397] [main/DEBUG] [cpw.mods.modlauncher.TransformationServiceDecorator/MODLAUNCHER]: Initializing transformation service mixin
[17abr2020 12:31:02.398] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: org.spongepowered.asm.launch.MixinInitialisationError: Mixin Launch Plugin Service could not be located
[17abr2020 12:31:02.398] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at org.spongepowered.asm.launch.MixinTransformationService.initialize(MixinTransformationService.java:76)
[17abr2020 12:31:02.398] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at cpw.mods.modlauncher.TransformationServiceDecorator.onInitialize(TransformationServiceDecorator.java:68)
[17abr2020 12:31:02.399] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at cpw.mods.modlauncher.TransformationServicesHandler.lambda$initialiseTransformationServices$7(TransformationServicesHandler.java:107)
[17abr2020 12:31:02.399] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at java.util.HashMap$Values.forEach(Unknown Source)
[17abr2020 12:31:02.399] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at cpw.mods.modlauncher.TransformationServicesHandler.initialiseTransformationServices(TransformationServicesHandler.java:107)
[17abr2020 12:31:02.399] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at cpw.mods.modlauncher.TransformationServicesHandler.initializeTransformationServices(TransformationServicesHandler.java:59)
[17abr2020 12:31:02.400] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at cpw.mods.modlauncher.Launcher.run(Launcher.java:75)
[17abr2020 12:31:02.400] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]:     at cpw.mods.modlauncher.Launcher.main(Launcher.java:65)
 

Link to comment
Share on other sites

Same here. No mods installed on the moment.
Only error from the log is following:

[Error: 2020-04-17 17:33:21.1696255: GameController.cpp(166)] Missing 'url' on libraries[*].artifact (should be string) in library net.minecraftforge:forge:1.15.2-31.1.0

It looks that Forge devs commented out or have deleted url path for certain libraries from the launcher. or even forgot to setup variable as a string.

please fix this asap.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I downloaded forge for 1.21 because I wanted to play the new update with a few mods. When I load up the game on the forge installation, the game seems to launch fine, but then freezes and goes into that "not responding" state a few seconds after sitting on the menu. It stays on not responding forever, and I have to close the game myself. The normal vanilla game without forge loads and works perfectly fine, though. The exit code I receive is either 1 or -805306369, depending on how I close the game. When I force close with task manager, I get exit code 1. When I close using the not responding menu (close the program or wait for it to respond), I get exit code -805306369. I tried taking all of the mods out to see if they were the problem, but the same issue still persists even with 0 mods in the mods folder. The pastebin linked is the log from when I launched the game with forge after taking all of the mods out of the mods folder. (Nothing ever shows up in the crash-reports folder, but I do have this from the logs): https://pastebin.com/9bL8awvE I had to delete some of the bottom of the log to be able to upload it onto pastebin, but anything deleted was identical to the lines there at the bottom. Some things I have tried include: Allocating more ram, updating display drivers, updating java version (currently have Java 21, tried switching to java 17 but that did not work either), removing or changing settings on programs that may conflict with minecraft (followed this list https://minecrafthopper.net/help/known-incompatible-software/). None have worked so far. I'm aware of course that this is a beta version of forge, but I just wanted to see if there was something I could do to fix this, or if I will just need to wait for a more stable, non beta version to be released.  
    • sorry if this is an incorrect log or wrong tag ive never used this before and im new to modding latest log: file:///C:/Users/jason/curseforge/minecraft/Instances/Cottage Witch/logs/latest.log
    • Hi its me from my first account. I added creative core but when i start minecraft he gives me an error. Now i can't send you the log but I will later 
    • I want my mod to add two new NBT values to Block Displays and Item Displays (Like left-rotation, scale, transformation, etc.), which I call texture_repetition and texture_shift (both Vector3f variables). Texture_repetition allows the Display to repeat its texture or only show part of it, and the texture_shift value allows you to shift to the part of the texture you want the display to show. I already tried Mixins, and I assume I need to use the renderstate() function and entityData variable, but entityData is protected, which means I can not edit it using Mixins. How would I add these NBT values to the Display class without using the entityData class? (These two data values, if coded correctly, could allow slabs/stairs/walls of any block to be represented using Displays without being limited by the vanilla inventory options)
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.