• Recently Browsing

    No registered users viewing this page.

  • Posts

    • Forge version 31.2.33, download on this site, install on vanilla 1.15.2, after that try launch game from my custom launch and get crash with this log^ [03авг2020 20:54:40.370] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--width, 900, --height, 532, --server,, --port, 25575, --accessToken, ????????, --uuid, 5d6dd94ab2ab3030aaac665d39d079d9, --assetIndex, 1.15.2, --userType, mojang, --versionType, modified, --username, Sanysvo, --version, 1.15.2, --gameDir, C:\barscraft\barscraft1.15.2, --assetsDir, C:\barscraft\assets, --launchTarget, fmlclient, --fml.forgeVersion, 31.2.33, --fml.mcVersion, 1.15.2, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20200515.085601] [03авг2020 20:54:40.374] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 5.1.2+70+master.2845bb9 starting: java version 1.8.0_221 by Oracle Corporation [03авг2020 20:54:40.837] [main/INFO] [net.minecraftforge.fml.loading.FixSSL/CORE]: Added Lets Encrypt root certificates as additional trust [03авг2020 20:54:41.991] [main/INFO] [cpw.mods.modlauncher.LaunchServiceHandler/MODLAUNCHER]: Launching target 'fmlclient' with arguments [--version, 1.15.2, --gameDir, C:\barscraft\barscraft1.15.2, --assetsDir, C:\barscraft\assets, --uuid, 5d6dd94ab2ab3030aaac665d39d079d9, --width, 900, --height, 532, --server,, --port, 25575, --accessToken, ????????, --assetIndex, 1.15.2, --userType, mojang, --versionType, modified, --username, Sanysvo] [03авг2020 20:54:42.013] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: java.lang.RuntimeException: java.lang.IllegalArgumentException [03авг2020 20:54:42.014] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: at cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:39) [03авг2020 20:54:42.014] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:54) [03авг2020 20:54:42.014] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:72) [03авг2020 20:54:42.014] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: at cpw.mods.modlauncher.Launcher.run(Launcher.java:81) [03авг2020 20:54:42.014] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: at cpw.mods.modlauncher.Launcher.main(Launcher.java:65) [03авг2020 20:54:42.014] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: Caused by: java.lang.IllegalArgumentException [03авг2020 20:54:42.014] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at org.objectweb.asm.ClassVisitor.<init>(ClassVisitor.java:69) [03авг2020 20:54:42.015] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at org.objectweb.asm.ClassVisitor.<init>(ClassVisitor.java:56) [03авг2020 20:54:42.015] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at org.objectweb.asm.tree.ClassNode.<init>(ClassNode.java:150) [03авг2020 20:54:42.015] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at cpw.mods.modlauncher.ClassTransformer.transform(ClassTransformer.java:69) [03авг2020 20:54:42.015] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at cpw.mods.modlauncher.TransformingClassLoader$DelegatedClassLoader.findClass(TransformingClassLoader.java:247) [03авг2020 20:54:42.015] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at cpw.mods.modlauncher.TransformingClassLoader.loadClass(TransformingClassLoader.java:134) [03авг2020 20:54:42.015] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at cpw.mods.modlauncher.TransformingClassLoader.loadClass(TransformingClassLoader.java:96) [03авг2020 20:54:42.015] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at java.lang.ClassLoader.loadClass(ClassLoader.java:357) [03авг2020 20:54:42.015] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at java.lang.Class.forName0(Native Method) [03авг2020 20:54:42.016] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at java.lang.Class.forName(Class.java:348) [03авг2020 20:54:42.016] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at net.minecraftforge.fml.loading.FMLClientLaunchProvider.lambda$launchService$0(FMLClientLaunchProvider.java:51) [03авг2020 20:54:42.016] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:37) [03авг2020 20:54:42.016] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: ... 4 more I cant understand that is the wrong argument on the launch...
    • Then the world is null, which makes sense since this is happening during creation of your tile entity where it's not attached to the world yet.
    • Hello, I'm working on a mod that displays the name of a shulkerbox in 3d text above the block. I've been stuck at this part for the last 3 days, and have gotten quite a few false starts. I've looked at renderLivingLabel, but in the sources it includes GameRenderer.drawNameplate, which can't be resolved. I've also looked into the Tessellator, but the key methods that I've seen used seem to not exist anymore. In addition looked through the GitHub's of mods that display text in-game (Healthbar mods, minimap mods). All of this to say, I've tried multiple approaches but haven't quite gotten where I need to. (TL;DR: I've tried a lot of things, and a lot of things haven't worked) So that (finally) brings me to the question: How should I go about rendering billboard text? One idea I had is to create a client-side entity with no physics or appearance, only a rendered name. If anyone things this is another false start, or has a different approach they've used to seen used, I'd love to hear. Thank you   (I've mocked up the effect I'm going for using an armorstand. Ironically this is similar to the entity approach I mentioned ealier) (Also here is the code that will call the name rendering. It doesn't seem particularly pertinent, but if it helps it's here) EventSubscriver.java @SubscribeEvent public void onPlayerEvent(EntityEvent e) { if(Minecraft.getInstance().player == null) { return; } player = Minecraft.getInstance().player; world = Minecraft.getInstance().world; if(!hasMoved(player)) return; BlockPos bp = getCurrentBlock(); BlockState bs = world.getBlockState(bp); if (bs.getMaterial() == Material.SHULKER) { TileEntity te = world.getTileEntity(bp); ShulkerBoxTileEntity sbte = (ShulkerBoxTileEntity)te; System.out.println(sbte.getDisplayName().getFormattedText()); sb = sbte; hovering = true; } else hovering = false; } private BlockPos getCurrentBlock() { int maxdistance = 3; Vec3d vec = player.getPositionVector(); Vec3d vec3 = new Vec3d(vec.x,vec.y+player.getEyeHeight(),vec.z); Vec3d vec3a = player.getLook(1.0F); Vec3d vec3b = vec3.add(vec3a.getX() * maxdistance, vec3a.getY()* maxdistance, vec3a.getZ()* maxdistance); BlockRayTraceResult brtr = world.rayTraceBlocks(new RayTraceContext(vec3, vec3b,RayTraceContext.BlockMode.OUTLINE, RayTraceContext.FluidMode.ANY, player)); return brtr.getPos(); } private double x,y,z,p,w; private boolean hasMoved(PlayerEntity player) { double newX = player.getPosX(); double newY = player.getPosY(); double newZ = player.getPosZ(); double newP = player.rotationPitch; double newW = player.rotationYaw; if(x != newX || y != newY || z != newZ || p != newP || w != newW) { x = newX; y = newY; z = newZ; p = newP; w = newW; return true; } return false; }  
  • Topics

  • Who's Online (See full list)