Jump to content

Forge Corrupted?


Remii

Recommended Posts

Recently I've been interested in getting shaders for 1.15 minecraft which requires optifine 1.15 as well. In order for me to get optifine working in 1.15 is through forge, but I cant seem to open forge after it's been downloaded. I right click forge and click "Open with" then click Java, but forge immediately crashes. Java is updated to it's latest version. I'm afraid one of the other files on my computer are corrupting it/ the path in order for forge to open or perhaps one of my drivers isn't updated properly even though I've check them as well and everything is up to date. This is a very unique and specific problem as I've tried all the generic fixes but I'm open to suggestions.

 

Regular Minecraft works fine. Mod Installers such as MC Modinstaller, Technic Launcher, and Twitch mods work however they do not have optifine in 1.15. Using MC Modinstaller, optifine works in 1.12 as well as shaders on top of that, but I'd like to find a way to have this in 1.15. If you know another way in getting optifine/shaders without directly from forge please let me know (through a mod launcher). Or perhaps I'm simply doing something wrong. The main goal is to just have some pretty shaders in minecraft 1.15?

Link to comment
Share on other sites

Pretty sure you don't need Forge for Optifine unless you're running other mods also. (At least that's not how I use it) You should be able to just open the Optifine jar and install it from there.

How to ask a good coding question: https://stackoverflow.com/help/how-to-ask

Give logs, code, desired effects, and actual effects. Be thorough or we can't help you. Don't post code without putting it in a code block (the <> button on the post - select "C-type Language"): syntax highlighting makes everything easier, and it keeps the post tidy.

 

My own mod, Magiks Most Evile: GitHub (https://github.com/GenElectrovise/MagiksMostEvile) Wiki (https://magiksmostevile.fandom.com/wiki/Magiks_Most_Evile_Wiki)

Edit your own signature at https://www.minecraftforge.net/forum/settings/signature/

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • SOLVED! I ended up fixing this after a fresh night of sleep and cloning the forge repo and looking through that. I had to add a BiomeModifier class to my mod, see this file here for assistance: MinecraftForge/src/test/java/net/minecraftforge/debug/world/BiomeModifierTest.java at 1.20.1 · MinecraftForge/MinecraftForge (github.com)
    • Hello, I'm creating a mod that should have a classic config file that I create with: ModLoadingContext.get().registerConfig(ModConfig.Type.COMMON, Config.SPEC); but I want also to have into server config folder more files .yml that I handle from the plugin. How can I create that yaml files?
    • Hi, I've been having a problem with Level 4 enchants on tools and items, it will not let me enchant any weapon or item past level 4, level 3 works on somethings but when I try to enchant it will either not show up in the anvil or when using the /enchant command it will say *item does not support the enchantment. I've tried efficiency 4 on a pickaxe and axe and it will not work.
    • Hello! I am posting since I am at the end of the road in terms of googling this solution and/or pouring through github projects. As the title suggests, I am trying to spawn my custom flower into the overworld into existing biomes, nothing crazy just a flower block spawned into the world. I added an entry into forge/biome_modifier called add_dreamcap_mushroom.json. It is as follows: { "type": "forge:add_features", "biomes": [ , "minecraft:plains", "minecraft:jungle", "minecraft:birch_forest", "minecraft:sparse_jungle", "minecraft:forest" ], "features": "herbalistmod:dreamcap_mushroom_patch", "step": "vegetal_decoration" }   I have a directory worldgen/configured_feature with dreamcap_mushroom_patch.json as follows:   { "type": "minecraft:random_patch", "config": { "feature": { "feature": { "type": "minecraft:simple_block", "config": { "to_place": { "type": "minecraft:simple_state_provider", "state": { "Name": "herbalistmod:dreamcap_mushroom_block" } } } }, "placement": [ { "type": "minecraft:block_predicate_filter", "predicate": { "type": "minecraft:matching_blocks", "blocks": "minecraft:air" } } ] }, "tries": 32, "xz_spread": 7, "y_spread": 3 } }   I have a directory worldgen/placed_feature with dreamcap_mushroom_patch.json as follows: { "feature": "herbalistmod:dreamcap_mushroom_patch", "placement": [ { "type": "minecraft:count", "count": 2 }, { "type": "minecraft:in_square" }, { "type": "minecraft:heightmap", "heightmap": "WORLD_SURFACE_WG" }, { "type": "minecraft:biome" } ] }   As far as I know, these are the only files I need in order to generate blocks, etc into the world, yet despite this I have made tons of worlds searching high and low and my block is nowhere to be found. Am I doing something wrong here or missing something obvious? Thanks in advance!  
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.