Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Opening 1.15.2 World In 1.12.2?


Recommended Posts

So I got forge and world edit a while ago and not realizing that there are a lot of mods that are still only in 1.12.2 I got both forge and world edit in 1.15.2. Of course this would not normally be an issue since I could just download both of those in an earlier version if needed however I began a build using world edit in 1.15.2. So the problem arises when I decide that I want to integrate chisels and bits into the build, which of course is only in 1.12.2. I've been trying to find some way to open the world or transfer the build over to that version but it seems there is just no way. But if there is any way at all I would love to know. And no I cant rebuild it in 1.12.2. It is already way to massive and way to many hours of work. Yea its my fault for getting that far before I decided I wanted chisels and bits and not starting it in 1.12 but its to late so if there is any way to transfer it over I would love to know. Thanks.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • You sort of wrote yourself into a corner there..... But, truthfully, 1.7 is no longer supported due to being so old, only the current (1.16.x) and previous (1.15.x) versions are supported. You will need to update to a modern version to receive support.
    • Alright so I don't really understand all the files and technical stuff so please don't answer with that. I saw a forum with the same problem where 1.7 wasn't working for him. He said that he manually installed forge and that worked. what does that mean and how do I do that?
    • I have done that, but I still cannot find a "EntityAttributeCreationEvent" event class or method anywhere when using intellij's search feature. Also when I try to run, I now get an error: BlocksReal's Block Creatures\build\tmp\expandedArchives\forge-1.16.5-36.1.6_mapped_snapshot_20210421-1.15.1-sources.jar_a6143e0dca70b177e5cb22179a0cd7b2\net\minecraft\entity\EntityClassification.java:40: error: method getName() is already defined in enum EntityClassification public String getName() {  
    • Hello! Wanted to make a server, and when i launched the server with all of the mods its just crashing with "io.netty.channel.abstractchannel$annotatedconnectexception connection refused no further information:" Can someone tell me what to do in order to fix it?         Server log: Starting Gameserver now... [18:44:48] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 36.1.6, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge, nogui] [18:44:48] [main/INFO] [cp.mo.mo.Launcher/MODLAUNCHER]: ModLauncher 8.0.9+86+master.3cf110c starting: java version 1.8.0_272 by Red Hat, Inc. [18:44:49] [main/INFO] [op.OptiFineTransformationService/]: OptiFineTransformationService.onLoad [18:44:49] [main/INFO] [op.OptiFineTransformationService/]: OptiFine ZIP file: /mnt/minecraftotherpacks/mods/OptiFine_1.16.5_HD_U_G7_MOD.jar [18:44:49] [main/INFO] [op.OptiFineTransformer/]: Target.PRE_CLASS is available [18:44:49] [main/INFO] [ne.mi.fm.lo.FixSSL/CORE]: Added Lets Encrypt root certificates as additional trust [18:44:49] [main/INFO] [mixin/]: SpongePowered MIXIN Subsystem Version=0.8.2 Source=file:/mnt/minecraftotherpacks/libraries/org/spongepowered/mixin/0.8.2/mixin-0.8.2.jar Service=ModLauncher Env=SERVER [18:44:49] [main/INFO] [op.OptiFineTransformationService/]: OptiFineTransformationService.initialize [18:44:50] [main/INFO] [STDERR/]: [org.antlr.v4.runtime.ConsoleErrorListener:syntaxError:38]: line 1:0 token recognition error at: '~' [18:44:50] [main/INFO] [op.OptiFineTransformationService/]: OptiFineTransformationService.transformers [18:44:50] [main/INFO] [op.OptiFineTransformer/]: Targets: 308 [18:44:50] [main/INFO] [op.OptiFineTransformationService/]: additionalClassesLocator: [optifine., net.optifine.] [18:44:51] [main/INFO] [mixin/]: Successfully loaded Mixin Connector [com.qouteall.hiding_in_the_bushes.MyMixinConnector] [18:44:51] [main/INFO] [mixin/]: Successfully loaded Mixin Connector [tictim.paraglider.MixinConnector] [18:44:51] [main/INFO] [mixin/]: Successfully loaded Mixin Connector [midnight.core.MixinConnector] [18:44:51] [main/INFO] [Portal/]: Invoking Mixin Connector [18:44:51] [main/ERROR] [mixin/]: Mixin config imm_ptl_mixins.json does not specify "minVersion" property [18:44:51] [main/ERROR] [mixin/]: Mixin config imm_ptl_mixins_forge.json does not specify "minVersion" property [18:44:51] [main/ERROR] [mixin/]: Mixin config imm_ptl_peripheral_mixins.json does not specify "minVersion" property [18:44:51] [main/INFO] [cp.mo.mo.LaunchServiceHandler/MODLAUNCHER]: Launching target 'fmlserver' with arguments [--gameDir, ., nogui] [18:44:52] [main/WARN] [mixin/]: @Mixin target net/minecraft/world/server/ChunkManager$EntityTracker is public in imm_ptl_mixins.json:common.entity_sync.MixinEntityTracker and should be specified in value [18:44:52] [main/FATAL] [ne.mi.fm.lo.RuntimeDistCleaner/DISTXFORM]: Attempted to load class net/minecraft/client/gui/screen/Screen for invalid dist DEDICATED_SERVER Exception in thread "main" [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: java.lang.RuntimeException: java.lang.reflect.InvocationTargetException [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: at cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:39) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:54) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:72) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: at cpw.mods.modlauncher.Launcher.run(Launcher.java:82) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: at cpw.mods.modlauncher.Launcher.main(Launcher.java:66) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: at net.minecraftforge.server.ServerMain$Runner.runLauncher(ServerMain.java:63) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: at net.minecraftforge.server.ServerMain$Runner.access$100(ServerMain.java:60) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1052]: at net.minecraftforge.server.ServerMain.main(ServerMain.java:57) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: Caused by: java.lang.reflect.InvocationTargetException [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at java.lang.reflect.Method.invoke(Method.java:498) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at net.minecraftforge.fml.loading.FMLServerLaunchProvider.lambda$launchService$0(FMLServerLaunchProvider.java:51) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: at cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:37) [18:44:52] [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:1061]: ... 7 more [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:644]: Caused by: java.lang.ExceptionInInitializerError [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:644]: at net.minecraft.crash.CrashReport.func_71504_g(CrashReport.java:101) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:644]: at net.minecraft.crash.CrashReport.<init>(CrashReport.java:54) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:644]: at net.minecraft.crash.CrashReport.func_230188_h_(CrashReport.java:425) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:644]: at net.minecraft.server.Main.main(Main.java:91) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:644]: ... 13 more [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:668]: Caused by: java.lang.RuntimeException: Attempted to load class net/minecraft/client/gui/screen/Screen for invalid dist DEDICATED_SERVER [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:668]: at net.minecraftforge.fml.loading.RuntimeDistCleaner.processClassWithFlags(RuntimeDistCleaner.java:71) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:668]: at cpw.mods.modlauncher.LaunchPluginHandler.offerClassNodeToPlugins(LaunchPluginHandler.java:85) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:668]: at cpw.mods.modlauncher.ClassTransformer.transform(ClassTransformer.java:120) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:668]: at cpw.mods.modlauncher.TransformingClassLoader$DelegatedClassLoader.findClass(TransformingClassLoader.java:265) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:668]: at cpw.mods.modlauncher.TransformingClassLoader.loadClass(TransformingClassLoader.java:136) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:668]: at cpw.mods.modlauncher.TransformingClassLoader.loadClass(TransformingClassLoader.java:98) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:668]: at java.lang.ClassLoader.loadClass(ClassLoader.java:351) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:668]: at net.optifine.reflect.Reflector.<clinit>(Reflector.java:185) [18:44:52] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:668]: ... 17 more Gameserver exited without success - 1 Exiting now...     "[18:51:30] [main/FATAL] [ne.mi.fm.lo.RuntimeDistCleaner/DISTXFORM]: Attempted to load class net/minecraft/client/gui/screen/Screen for invalid dist DEDICATED_SERVER" I think this one might be the Error, but I dont know how to fix that  
    • I can't. This computer doesn't support windows any higher. And. I don't like Linux. Just with no reason. Idc about the security, cuz my browser just stops me from connecting to unsafe websites, so i don't have to be afraid of getting a virus from the internet. Even if i got something, i can just dowload free version of Dr Web and scan the computer.
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.