Jump to content

Not able to open forge server jar

Recommended Posts

I am planning to make a modded server with my friend. I installed forge server with the installer and the vanilla jar works fine. However when I try to launch the forge jar, nothing. Not even a log. I tried updating java, I tried running the jar off of a command file, still nothing.


Any way to fix this?


I am using Mac OS Big Sur.

Link to comment
Share on other sites

I ran a .command file that read:


cd "$( dirname "$0" )"
java -Xms8G -Xmx8G -jar Forge.jar -o true




And I got this error:


A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException

at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:64)

at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

at java.base/java.lang.reflect.Method.invoke(Method.java:564)

at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:62)

at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:31)

Caused by: java.lang.ClassCastException: class jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to class java.net.URLClassLoader (jdk.internal.loader.ClassLoaders$AppClassLoader and java.net.URLClassLoader are in module java.base of loader 'bootstrap')

at net.minecraft.launchwrapper.Launch.<init>(Launch.java:34)

at net.minecraft.launchwrapper.Launch.main(Launch.java:28)

... 6 more

Saving session...

...copying shared history...

...saving history...truncating history files...



Link to comment
Share on other sites

This topic is now closed to further replies.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.