Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.16] Large collision box is not working correctly


Recommended Posts

I made test 3x3 collision. For convenience, I have marked with colors the areas of the cube (see screenshots). Bounding box shows up correctly but collision works strange. I can't fly horizontally through yellow blocks but I can fall through them. Сorner blocks (red) don't work at all. And I can't fall or walk into blue area. 
Forge 1.16.5 -  35.1.37

public class TestTileEntityBlock extends TileEntityBlock<TestTileEntity> {
    private static final VoxelShape SHAPE = makeCuboidShape(-16, -16, -16, 32, 32, 32);

    public TestTileEntityBlock(Properties properties) {
        super(properties);
    }

    @Override
    public TileEntity createTileEntity(BlockState state, IBlockReader world) {
        return new TestTileEntity();
    }

    @SuppressWarnings("deprecation")
    @Override
    public VoxelShape getCollisionShape(final BlockState state, final IBlockReader world, final BlockPos pos, final ISelectionContext context) {
        return SHAPE;
    }

    @SuppressWarnings("deprecation")
    @Override
    public VoxelShape getShape(final BlockState state, final IBlockReader world, final BlockPos pos, final ISelectionContext context) {
        return SHAPE;
    }
}

spacer.pngspacer.png

lc.png

cornerlc.png

yellowlc.jpg

bluelc.jpg

Edited by Aviator737
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.