Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Forge jar file not opening


Varzac
 Share

Recommended Posts

Hello,

i tried to install forge on my pc over the last couple of days. However, I can't get it to work. What double clicking nother happens, not even using the "open with" method. Most times a black box flashes for a millisecond. When looking at the task bar i do notice that it is the java program that is opening and closing.

 

Heres what I tried so far:

Updating java to newest version

Changing to different version of jav

Using the command prompt

Using powershell

Giving myself admin access

 

Does anyone have any ideas on how to fix this? 

 

Thankful for all the help I can get!

Link to comment
Share on other sites

34 minutes ago, am pro said:

download winrar https://www.rarlab.com/download.htm and click english 64 bit

This is the exact thing that will not help you here.

In fact WinRAR especially likes to say "hey I open Jar files", when it has no business doing so.

 

Some zip managers like to take control of the .jar file extension away from Java.
Make sure you have Java installed and try running Jarfix once, then try the installer again.

Link to comment
Share on other sites

10 hours ago, diesieben07 said:

This is the exact thing that will not help you here.

In fact WinRAR especially likes to say "hey I open Jar files", when it has no business doing so.

 

Some zip managers like to take control of the .jar file extension away from Java.
Make sure you have Java installed and try running Jarfix once, then try the installer again.

I ran Jarfix and then tried installing again with the same results. Nothing happening

I even tried using winrar, but as you said nothing happened

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Here is my configuration: % java -version java version "18.0.2" 2022-07-19 Java(TM) SE Runtime Environment (build 18.0.2+9-61) Java HotSpot(TM) 64-Bit Server VM (build 18.0.2+9-61, mixed mode, sharing) forge-1.19-41.1.0-mdk on macOS Monterey 12.5 I ran the command: ./gradlew genEclipseRuns and was hoping it will generate the Eclipse project files for me. The run log is at https://gist.github.com/arun-gupta/06b983a6976b4c0a0f510d0dc225ddd3 and the generated directory structure is at https://gist.github.com/arun-gupta/3f5bfc70ec5d3d903b0f97d42840abda. In previous versions (1.12-ish), it used to generate an eclipse directory but 1.19 does not seem to have it. I tried opening the top-level forge directory but Eclipse does not recognize it as a project as well. How do I open this project in Eclipse now?  
    • I didn't put in credentials, I used it only for testing installing forge. But still the problem mentioned above.
    • I am trying to use Forge 1.18.2, I have checked my firewall, redownloaded Forge, deleted the fml.toml file (which keeps reappearing) and looked at countless help pages. I am just trying to download and use forge so that I can play with my friends and it will not download. It tells me there may be an issue with the Java runtime config and that the exit code is one, and I have copied the exit code.   
    • Okay, i think i understand but im getting issues, i create another packet to sync entity to another players like this package com.naim.belloto.networking.packet; import com.naim.belloto.networking.handler.ClientSyncHandler; import net.minecraft.client.Minecraft; import net.minecraft.network.FriendlyByteBuf; import net.minecraftforge.api.distmarker.Dist; import net.minecraftforge.fml.DistExecutor; import net.minecraftforge.network.NetworkEvent; import java.util.Objects; import java.util.function.Supplier; public class ClientSyncPacket { public ClientSyncPacket() { } public ClientSyncPacket(FriendlyByteBuf buf) { } public void toBytes(FriendlyByteBuf buf) { } public boolean handle(Supplier<NetworkEvent.Context> ctx) { NetworkEvent.Context context = ctx.get(); context.enqueueWork(() -> { assert Minecraft.getInstance().player != null; int idplayer = Minecraft.getInstance().player.getId(); DistExecutor.unsafeCallWhenOn(Dist.CLIENT,() -> () -> ClientSyncHandler.handlePacket(ctx, idplayer)); }); return true; } } And in the handler: public class ClientSyncHandler { public static boolean handlePacket(Supplier<NetworkEvent.Context> ctx, int idPlayer) { Minecraft.getInstance().level.getEntity(idPlayer); return true; } } But is not working :// 
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.