Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.16.4] Texture won't load for my obj model


RMSCA
 Share

Recommended Posts

Here is my blockstate file

{
  "variants": {
    "": { "model": "tamako_market:block/kotatsu"}
  }
}

Here is my model file

{
  "loader": "forge:obj",
  "model": "tamako_market:models/block/kotatsu.obj"
}

Here is my mtl file

newmtl m_0
map_Kd tamako_market:block/kotatsu

Here is my obj file

 

And here is my assets folder

Thanks for helping!

Screen Shot 2021-03-12 at 9.41.01 AM.png

Link to comment
Share on other sites

so I have managed to get my texture work, but now my block looks like this:

image.png

 

if I disable this emissive lighting in my mtl file, my model will looks like this:

image.png.987308c63545326f9349b2e46105e30a.png

is there a way to fix this?

thank you!

Edited by RMSCA
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.